Answered

Is Beam 2's 5 ghz surround network the worst engineering decision ever?

  • 29 February 2024
  • 9 replies
  • 146 views

I have a Beam 2 and 2 Era 100 speakers. As far as I know the Beam creates a 5 ghz network to connect with the Eras to form a surround system. But we, the users do not have any control over the settings of this network. And as I know the Beam do changes in it based on something.

And this is causing many, many problems at home, because I have a 5 ghz wi-fi network for all my devices and very often the Beam is causing interference with my wi-fi. In many cases as soon the beam starts working when I’m watching something or listening to music my wi-fi speed drops from 200-300 mbits up/down to under 60 megabits and sometimes even to 5-7mbits. Seconds after I unplug the Beam 2 and it’s network disappears my wi-fi stars working normally again. So my conclusion is that it’s the Beam that causes the problems. And that was verified multiple times. And because I don’t have any control over Beam’s network and because it changes it there is nothing I can do. There is no point of doing any changes in my router because at some point Beam’s wi-fi will start messing with the router signal again.

For me this is one of the worst UX and engineering decision ever. I know you want to make it easier for the most users, but doing it without any possible ways for manual setting is not a good thing at all.

I can’t work and use my devices normally because of the low wi-fi speed. It is insane to have to disable  the sound system and no one to used it when someone needs normal internet speed for work or something else. Sometimes I can’t stream movies or other media from my computer to the TV because to watch a movie I need sound, the the sound systems affects the wi-fi speed and the streaming is not possible. It’s like paragraph 22.

Make it possible for users with knowledge to setup it manually or fix your algorithms because the urges to throw your entire system out is growing stronger every day. I was planning to add a Sub 3 to finish my setup, but after I’ve got the Eras and the problems that this caused makes me reconsider it. At this point I’m not sure I want to buy more Sonos products

icon

Best answer by ratty 3 March 2024, 21:58

View original

9 replies

What did Sonos support suggest, when you contacted them with your issue? Unfortunately, this is only a community support forum, and Sonos engineering, to my knowledge, doesn’t read here. 

We have several Sonos HT setups in our Home, all have surrounds/sub (or sub-mini) and whilst the Wife and I may use just one, or two, of those HT ‘rooms’ at any one time (usually), I can’t say I’ve ever seen the Sonos ‘often-used’ DFS 5Ghz channels ever affect my local WiFi network. In fact most modern networks these days, would simply alter their channel(s) if things were to get in their way. 

I usually see the Sonos surrounds using DFS channels, so perhaps just set/fix the local router to use the standard 5Ghz channels 36 to 48 and let the Sonos HT primary device sort its own inter-connecting 5Ghz channels.

If you want to go a little further, then set the routers 2.4Ghz band to use a channel-width of 20Mhz only and set the 5Ghz band to use 40Mhz only. (I use 80Mhz here).

If still encountering issues after that, then I too, would also recommend reproducing the issue and then immediately submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter. 

You perhaps may find this table (attached) useful for Sonos 5Ghz channel discovery as it shows the corresponding central frequency for each channel. Just goto the Sonos web/matrix page via "http://[HT IP_Address]:1400/support/review” and select the HT device and expand /proc/ath_rincon/status

The HT surrounds 5Ghz channel is listed as HT Channel

I’ve occasionally noticed a slow-down when the Living Room HT channel was operating, but there were still several hundred Mbps available on the nearby WiFi. Sonos will seek out the best channel. Unless you’re using all 320MHz in the 36-64/100-128 blocks Sonos should find a quiet spot. It only needs 20MHz but can sometimes land in the ‘other’ half of a 80MHz channel, clipping it back (on a frame-by-frame basis) to 40MHz.

To be honest if one’s seeing only 5-7 Mbps it’s more likely to be due to transceiver proximity/blocking. Make sure there’s at least 50cm -- ideally 100cm+ -- between any WiFi access point and the nearest Sonos unit.

My 5 GHz wi-fi is set to channel 38(5240) / 80MHz, the 2.4 Ghz wi-fi is using 20/40

The Sonos support only suggestion was to change the beam’s 2ghz channel. It’s set to 11, while my 2.4 ghz network uses 2422(channel 3). Yet I still have problems.

The current channel selected by the soundbar is 5180 (36)

Edit:

I’ve performed two speed tests with the speakers on and off, with the same server. the speeds drop h3 when the Beam is working. And now it changed its channel to 5200

Edit2:

Now it switched to 5240 while the soundbar was working. This is the channel of my home wi-fi network. So as I said - very bad engineering decision and implementation.

You didn’t comment about the proximity of WiFi sources to your Sonos devices.

What country are you located in? Radio frequency regulations differ between regions.

When you run a WiFi scanner what does it show about the usage in channels 52-64 and 100-144?

And since your comment is about Sonos' “very bad engineering decision” you’ll know that the choice of channel 3 / 40MHz for 2.4GHz is a “very bad decision” too...

“And since your comment is about Sonos' “very bad engineering decision” you’ll know that the choice of channel 3 / 40MHz for 2.4GHz is a “very bad decision” too... “

But I don’t charge hundreds of euros for products with my “bad decisions”.

I live in apartment building and there are 7 wi-fi networks on channels 1 and 6 that are in reach in the room where my router is. There are few other networks on the other channels. Mine is the only one on channel 3. And I have a 2.4 Ghz network only for such devices as the Sonos. The router is over half a meter away from the soundbar. There are only 2 other 5GHz networks in reach - on channels 5500 and 5560 20 Khz, from a local telecom based on ther names.

And my problems are with the 5Ghz network, and only when the Sonos speakers are working.

Even if I connect the bar with the router wit a LAN cable and disable my 2.4 wi-fi, I still have the speed drop when the HT is working

I’ve connected the soundbar with LAN cable and disabled my 2.4 wifi

This is with Sonos working

And this is when I turn it off

 

You apparently don’t appreciate the antisocial effect of using channel 3 / 40MHz on nearby users of channels 1 and 6 (and likewise their effect on you). You might wish to acquaint yourself with how all this works. 

Returning to 5GHz, in most regions anything above channels 36-48 requires the use of DFS (dynamic frequency selection) to avoid causing interference to priority users of those channels. We still don’t know your home region, but Sonos has been opting to use DFS channels -- when available -- ever since the advent of Playbar. Sonos Support ought to be able to examine a diagnostic and see what the Beam is doing and why.

In the meantime I’d advise moving the router further away from the Beam and seeing if that has any effect.

Userlevel 7
Badge +18

Hi @mIRCata 

Welcome to the Sonos Community!

Thank you - I've marked this thread as a feature request and it will be seen by the relevant teams for consideration. Keep the ideas coming!

However, I do agree with @ratty that you should keep your router and Beam further apart than half a metre - they should be at least 1m apart.

I hope this helps.

Reply