ARC outputting Stereo PCM when playing 4K Blu Ray

  • 9 February 2024
  • 21 replies


Hi all,

I recently upgraded my Beam Gen 2 to an Arc and ever since I’m only getting Stereo PCM outputted when I play a 4K Blu Ray that outputs DTS HD. This was working fine on my Beam 2 and it would convert this to PCM Multichannel 7.1.

My set up:

TV - LG C1 - Passthrough and eArc enabled 

Sound - Arc, Sub Gen 3, Era 100’s x2

4K Player - Panasonic DP-UB450EB-K


Dolby Atmos works fine but since changing to an Arc it’s only converting DTS HD to stereo PCM.

I’ve looked through all the posts on here and it seems a lot of people have had this problem before. I’ve amended my settings on the Blu Ray player but this hasn’t worked.

Any help would be greatly appreciated.

Thank you


21 replies

Userlevel 7

Make sure the DTS/DTS-HD setting on the Panasonic player is set to PCM. Also be sure to set the HDMI Input Audio Format setting on the TV to Bitstream.


Thanks for your reply I really appreciate it. 

Unfortunately I’m still having the same issue and it’s still outputting in Stereo PCM. I’ve attached some pictures of my settings.


Userlevel 7

Is the HDMI Input Audio Format setting on the TV set to Bitstream?

Try unplugging the TV and Arc from power for a couple of minutes.


Is it yes, HDMI input set as Bitstream across all 4 ports. Equipment has been powered off a few times. Just really strange it’s not working since changing from Beam 2 to an Arc. No settings have been changed. 

The 4k Blu Ray I’ve tested this on is The Shining. Previously would get multichannel pcm 7.1 and now get stereo PCM.

Userlevel 7

Did you actually unplug the equipment from power? Is the firmware up to date on the TV and Panasonic player?


I do power it off every night at the plug but I’ve just completely removed all the power cables for 10 minutes so they are isolated from the power and yes still getting the same problem. Firmware is up to date on the Panasonic 4K player.

I've attached another screenshot with a bit more information when playing the disc.


Userlevel 7

Try toggling the DTS/DTS-HD setting to Bitstream and back to PCM. And disconnect/reconnect all of the HDMI cables on back of the TV.


Unfortunately still not working. It’s really frustrating as I get multichannel pcm 5.1 when watching some stuff on TV. 


Tested the 4K Disc on my PS5 and it outputs multichannel pcm 5.1 but obviously can’t get Dolby Vision on that and I want to use my 4K player. Does that rule out my TV and Soundbar then? Just really don’t understand why it’s not working on the 4K player.

Userlevel 7

There isn’t any reason why the Arc shouldn’t support Multichannel PCM audio from the Panasonic player especially since it worked with the Beam.

Try connecting the Panasonic to a different HDMI port on the TV and test again.


Thanks for your continued help.

Yes just done that and same result unfortunately. I’ve also just replaced the HDMI cables which are 2.1 high speed but this had no effect.

I’ve also just done a hard factory reset of the 4K player and this also made no difference. So frustrating. 


Did some more testing and played the 4k disc in my PS5 which outputted PCM multichannel 7.1 without issue. The only issue with the PS5 is that it doesn’t support Dolby Vision.

To correct my original post my 4K Player is a Panasonic DP-UB820EB-K.

So if this outputs the correct audio on my PS5 does the issue lie with my 4K Player?

I’ve copied all the settings suggested on the TV and 4K player. I’ve also hard reset the 4K player and changed the cables but still get stereo PCM. 


Userlevel 7

I have the same model Blu-ray player connected to an LG C3 and have no issues with getting Multichannel PCM audio.

Is the firmware up to date on the TV?

If you go through the audio options using the Audio button on the Panasonic remote while the movie is playing, does it make any difference?


Yes no update available for the TV as it has the latest and I recently did update the firmware on my 4K Player too.

I’m pretty sure I tried that and didn’t seem to make any difference. I don’t want to get rid of my player as it’s one of the best around but just can’t understand why it’s suddenly started after swapping my Beam 2 to an Arc.


I just got the ub820k as well and I’m having the same issue


Sounds like a few of us are having this. Have you got the LG C1? As wondering if this is to do with the latest update. 


Sounds like a few of us are having this. Have you got the LG C1? As wondering if this is to do with the latest update. 

Yes I do. Also tested it with my ps5 and was outputting dts-hd movies with the correct pcm 5.1/7.1. Not sure how some people got theirs to work. Tried just about everything 


Yeah exactly the same as me. All fine with my PS5 but no longer working with my Panasonic 4K player. No idea how we get this resolved. 

Having same issue. C1, Panasonic uB820, Arc, sub, Ones. 

Dolby discs play fine, but any other coding 5.1/7.1 I am getting stereo pcm.


very frustrating. 


Wonder what has happened then. Appears to be affecting all of us who have an LG C1.

Hi. Yep i’m having the same issue. Started about 4 weeks ago. DTS-HD 5.1 discs that I’ve previously played with no issue are now playing with no sound. 

When changing the sound on my LG C2 to PCM it works, but only showing ‘Stereo PCM’ on my Sonos app.

I’ve updated everything and unplugged multiple times - something has definitely changed!


However….i decided to watch The Dark Knight the other night and despite it showing as Stereo PCM on my Sonos app, it sounded great. Tapped the Display button on my Sony UBP-X700 remote, low and behold it’s showing as 5.1 sound! 

So whilst i’m not 100% sure what i’m getting, this could just a problem with the Sonos app displaying the wrong information (Stereo PCM). Either way it sounded great so for those having this problem, might be worth you checking this on your 4K players 👍🏽