Airplay - Unable to Connect

I do see other related topics, but thought I’d start my own to avoid confusion.  I just replaced my router/modem combo with a Netgear C7800 and now I can’t seem to get Airplay to work with my Sonos speakers.  I have an Arc and three Ones.  I tried reconnecting them all the network and I tried a full factory reset.  I even unistalled and reinstalled the app.  On the reset, I connected the Arc first and tried Airplay - it worked.  But, the second I added another speaker none of them worked with Airplay (and I had no issues up until yesterday).  Other than that, everything seems to work fine.  I can Airplay to my TV, I can play from the Sonos app (on my phone and computer), and I can cast music from my computer to a speaker.  Everything is up to date.  Possibly some hidden setting that I’m missing???  


Diagnostics - 18134826239.  Any help would be appreciated.  Thank you!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Userlevel 7
Badge +18


Welcome to the Sonos Community!

First, please remove power from your WiFi router and Sonos devices. Wait 30 seconds, and turn your router back on. Once you have WiFi again, switch on your Sonos devices again and wait for solid white lights. It’s best to wait for the solid white light on your Arc before turning on the surround speakers. 

Please be aware that if you initiate the AirPlay connection from your Mac’s settings, AirPlay 1 is used, which is not supported by Sonos. AirPlay 2, which is supported by Sonos, is typically started from within an application (like Spotify, Safari or iTunes/Apple Music).

If you still struggle with AirPlay after the reboot of everything, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system. We recommend you don’t factory-reset unless instructed to by our technical support team due to the risk involved.

So, just as an update:


  • Rebooted the router (15+ times)
  • Rebooted Sonos system (15+ times)
  • Factory reset router (3 times)
  • Factory reset Sonos system (4 times) - yes, this is not recommended
  • Installed and reinstalled the Sonos app (3 or 4 times) to reconnect to the system
  • Did “forget this network” on my iPhone to reconnect to WiFi
  • Did “reset network settings” on my iPhone to reconnect to WiFi
  • Factory reset my iPhone
  • Called Sonos Tech Support twice (90 minutes in total)
  • ...probably some other things, but that’s what I can think of right now


To provide more detail, I have 4 speakers - 1 Arc and 2 Sonos Ones in the Living Room; 1 Sonos One SL in the Kitchen.  The Arc is connected to an ethernet cable, creating a wired system.


Tech Support wasn’t able to see any issues (besides the fact that they could see that I wasn’t able to connect).  They suggested calling Apple, but I don’t think Airplay is the issue because AirPlay works from my iPhone to my TV.


Something odd that I discovered though - after rebooting the Arc, I can AirPlay to it ONCE.  After that 1 time, it stops working.  It just spins, and after 1-10 minutes (it varies that much), I’ll get an “unable to connect” error.  I did a diagnostics right after this in hopes that it might provide some useful information - 2085711337.  If I unplug the ethernet cable from the Arc or I disable WiFi on the Arc, I can AirPlay to the Kitchen (but not to the Living Room) - that seems to stick.  So, is the issue the Arc?

Userlevel 7
Badge +18


The diagnostic did not include any part of your Sonos system - perhaps this is part of the issue.

Please type the following link for each Sonos speaker on your network into your browser. At the bottom of the page, click mDNS Announce. When you see “Success”, move on to the next speaker.

http://[IP address of speaker]:1400/tools.htm

Once all your speakers have been done, please try AirPlay again - has that changed anything?

I received “success” for all 4, but still no change to the system. 

Userlevel 7
Badge +18

Could you please let me know what router you have, if you have a mesh WiFi, boosters/extenders, network switches or Wired Access Points, and where on your network your Arc connects? As many details of networking equipment as you can think of, please (but not client devices like a TV or computer).

Your Sonos system knows your WiFi password - if you remove the ethernet cable from the Arc and reboot the router and Sonos, does that help or change anything?


I have a Netgear C7800 (modem/router combo).  No boosters, switches, or anything else.  Everything on my network is on WiFi (computer, TV, etc.) and the only thing plugged into the router is the Arc.  AirPlay works in my Kitchen (different room from the Arc) if I disconnect the Arc from the router or disable WiFi on the router through the Sonos app.  So, if I disconnect from the Arc and reboot the Arc and the router, I can use AirPlay in the Living Room once and only once - then it stops working again.  But, my Kitchen continues to work.  


Sorry, but I didn’t understand what you meant by “where on your network your Arc connects.”  

Userlevel 7
Badge +18


Thanks for the details.

I’d like to make sure the QoS (Quality of Service) feature isn’t turned on in your router’s settings. These instructions are for turning QoS on, but please follow them in order to disable the feature (on step 6, untick the box):

Although your router’s manual doesn’t mention QoS, perhaps it was added at a later date with an update? If you don’t find the setting, we’ll need to try something else.

I did notice that your DNS resolution times are excessive. Normally, we’d recommend a router reboot for this, but I’m guessing that the diagnostic wasn’t months after the last reboot. Therefore, I think changing your DNS servers in the router’s DHCP settings to Google’s ( and is worth doing, even if it doesn’t help this issue (AirPlay uses mDNS which is done locally, but maybe there’s a common denominator here). Page 23 of the manual describes how to do this.

You’ll need to reboot your router after performing this change. Please don’t get distracted by the Dynamic DNS settings - this is something else, for which you’d need an account with a server.

By “where on your network your Arc connects” I meant I wanted to know what your Arc ethernet connection was wired to, but by explaining your network only consisted of your router, you’ve already answered.



Sorry for the delay, but I’ve been trying multiple things over the last few days.  I do not have an option for QoS, and I’m on the latest firmware - so, this was not something added to my system.  As an alternative though, I tried disabling Beamforming (though it made no difference).  I tried reducing Fragmentation Length, CTS/RTS Threshold, and MTU size based on other things I found online (although none of those were related to Sonos issues) - that didn’t fix the issue either (and I tried them all separately just to be sure).  I did change my DNS servers, as you suggested.  

Userlevel 6
Badge +15

Hi @TNJGA, thanks for trying that.

Do you happen to have the previous router available at all? If so, would it be possible to connect the Arc directly to the old router via Ethernet cable, connect your phone to the old WiFi, and check if you experience the same issues with AirPlay failing to connect?

If the old router doesn’t cause any issues with AirPlaying to the Arc, I’d recommend reaching out to Netgear - if the Arc has the same problem on both networks, then I’d recommend getting back in touch with our Support Team via either phone call or live chat. Feel free to send the agent you speak to a link to this thread to avoid repeating troubleshooting steps :)

Unfortunately, the old router was completely dead so I didn’t keep it (it wouldn’t turn on anyway, so I wouldn’t be able to test anyway).  I have reached out to Netgear as well.  But, you know how that goes - every company blames someone else and I just go in circles.

Userlevel 6
Badge +15

Understood - if you have another mobile device available with the Sonos app installed, it may be worth seeing if you get the same behaviour on a Hotspot setup.

To do this, you would need to Factory Reset the Arc, host a WiFi Hotspot on one phone, and then connect the second phone to the Hotspot, and use it to set up the Arc as a new system & test Airplay. (You may need to reset the Sonos app by going to Settings > App Preferences > Reset App in order to get the “Set up a New System" option)

Given that AirPlay was working with the Arc previously, if you’re able to perform this test and can consistently use AirPlay while the Arc is connecting to the Hotspot, then we can confidently say that there’s something going on with the router that’s causing this behaviour.

Let us know how you get on, and if you hear anything from Netgear regarding the issue :)

After multiple talks with Netgear, they said it’s Apple’s problem.  Apple did a diagnostic and said there are no issues they see on their end.  They said that the fact that I can AirPlay to my TV and not my Sonos speakers, makes it sound like a Sonos issue.  They suggested I escalate the issue with Sonos support for additional testing.  So, would that be through you?  Or do I need to call?

Userlevel 6
Badge +15

Hi @TNJGA, understood - thanks for getting back to us.

In that case I’d recommend you reach out to our Support Team via either live chat or phone call, as those teams have access to more tools for troubleshooting - feel free to provide them with a link to this thread to avoid repeating any steps :)

May I ask a couple of questions?

First, before changing anything, can you check in About My System which speakers have WM:0 next to them and which WM:1.

Are the Living Room Ones set up as surrounds to the Arc? 

Please ensure that the Arc is back on Enable WiFi, not Disable WiFi, whether or not the Arc is connected by Ethernet. 


Further thought.. have you tried with the Arc connected wirelessly, all three Ones as standalone speakers, and no Sonos device wired to the router?

If not, could you try that? You may need to reboot the router and Sonos speakers one more time to test this. 

If you have tried this already then I apologise for wasting your time.