why does Arc mic turns on and off on its on regularly?

  • 25 August 2023
  • 34 replies
  • 1240 views

Badge +4

I have an Arc and the mic turns on and off without warning at random times. It makes a tone every time this happens. It does it with music or the tv. I called sonos and got a replacement, but that didn't fix the issue. How is this happening with a capacitive touch button when nothing is touching it?
 

Is the device just designed horribly and there is no fix?


34 replies

I started getting this just about a week ago after no issue since January. I disabled Sonos voice control and it is gone now. No more ping pongs.

There is a hardware fault with a batch of units. Contact SONOS support.

Userlevel 7
Badge +15

@Trailscape

Imho that should not be the way to handle this known hardware issue. Normaly Sonos will send you a replacement if they had checked your device and are sure it’s that bug. I would try again to call support team. 

There seems to be no way to stop the speaker from tuning on the Mic.

I don’t like to thing someone could listen in to my home.

I called Cust service and was told there is nothing that can be done.

 

Down right irritating.

 

 

I just got the Arc yesterday and the mic is turning on and off on its own.

 

I am on hold with Sonos. Hopefully it doesn't take too long. Glad there is a forum here.

Userlevel 2

@Drew12: Same here. Solved! Just contact Sonos. They will replace the Arc. Read above.

I’ve added a port and turntable to my system (Arc, sub gen3, 2x era300’s) recently and when i play a record the microphone on my Arc keeps turning on and off even after switching it off physically. I’ve had to disable Sonos voice control on the app. 

Userlevel 2

As I stated in a thread elsewhere:

Microphone randomly turning on or off on new Sonos Arc (with Google Assistant AND Sonos Voice Control).

Tested with various set-ups and input-sources. Took me 1 phone call with Sonos on Friday 26 January 2024. Monday 29 January 2024 in the morning a brand new Arc was delivered (from Poland to Holland). Tested it and the issue did not manifest. Free shipping for returning the faulty Arc. Good performance Sonos!!! I am very satisfied and happy!

Case closed.

Userlevel 7
Badge +15

@withonen 

This could be accidentally I think… to be sure if your device is affected of the hardware problem or not, I would call Sonos support to check this. 

Same issue here on brand new Arc with Sub (Gen 3) on LG OLED CX TV. We have noticed it only occurs when playing PS5. When watching Roku on a different input of the TV, this problem does not occur at all. I just disabled Touch control (since we only use Roku remote or app on phone to adjust volume) and beeps stopped. Anyone else experience it only when on one particular input of the TV? 

Userlevel 7
Badge +15

@Nadezhda C.

There‘s a known hardware issue with some Arc devices as mentioned above. If you contact Sonos support as @Ken_Griffiths suggested I would point to this and probably they will prompt a replacement of your Arc. But they have to check this. 
In the meantime you can turn of hardware touch buttons in Sonos app settings to avoid the ping pong on off behavior. 

I have the same issue (Sonos Arc connected to an LG TV via HDMI eARC, and am using Alexa as my voice assistant).

The microphone goes on and off quite randomly, which makes voice control almost unusable. Disabling touch controls is not an option as I use them often to adjust volume. 

It is probably best to submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

I have the same issue (Sonos Arc connected to an LG TV via HDMI eARC, and am using Alexa as my voice assistant).

The microphone goes on and off quite randomly, which makes voice control almost unusable. Disabling touch controls is not an option as I use them often to adjust volume. 

I’ve also had this issue a few times now in addition to the voice control turning on and off repeatedly while making a ding sound every time.  Tech support did something remotely to “fix” the voice control but as soon as my kids started playing Xbox it started doing it again.  Hasn’t happened with the tv since the fix but the random high pitch sound while muting the tv randomly happened again tonight.  I’ve had this ARC for about 2 weeks with multiple issues.  A bit disappointed with the problems so far and working with tech support is a bit of a nightmare.  Going to try and get this new issue resolved and cross my fingers nothing new crops up.  

@Smart10 & @jmoose,

It is probably best to reproduce the issue, then submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

It appears that some users with this type of issue have had their Arc replaced due to a fault, but the Staff will likely need to check things with you first in case it’s just a software issue that can perhaps be quickly resolved.

I’m experiencing the same problem with a new ARC. The issue started right after I installed it. I’m using Google Assistant.

Just purchased Arc and have the same issue. The only way I am able to resolve this issue is to turn the touch controls off. What a shame we must eliminate a feature to eliminate a Sonos defect. 

The same thing happens to my Arc and apparently this is a very common issue with a frustrating workaround. Turning off touch controls fixes the problem, but I would like to use them. My wife keeps trying to convince me to send the Arc back. :(

Badge

Same issue with new ARC (white model, 1 day old). As soon as the Sub is added to the sourround set or the touch contol is disabled by app it works.  If touch in enabled (no one touch) the microphone will be disabled randomly by self. Used in the past BeamGen1, no issues.

 

Tried with some sticker on the touch sensor for the microphone but does not help.

Is it hardware issue or software bug ?

 

Diagnose ID 1850850345

I have an LG C3 65 connected to Arc and Amazon Alexa. The mic randomly keeps coming off and on. I have turned roofer, arc, tv etc off and on, reset and reinstalled everything and it keeps happening. Does anyone have a suggested solution?

Yes, it is  probably best to reproduce the issue, then submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

It appears that some users with this type of issue have had their Arc replaced due to a fault, but the Staff will likely need to check things with you first in case it’s just a software issue that can perhaps be quickly resolved.

I have an LG C3 65 connected to Arc and Amazon Alexa. The mic randomly keeps coming off and on. I have turned roofer, arc, tv etc off and on, reset and reinstalled everything and it keeps happening. Does anyone have a suggested solution?

Same here. Arc linked to Amazon Alexa for voice assistant. Mic enable/disable sound happens intermittently when listing to music. TV is powered off. 
 

Removing Alexa Voice assistant as a test and will report back. 

Hello there, same issue here. Sonos ARC turned the mic on and off randomly. Connected to Sony oled tv with eARC.  Played music on spotify (tv off). 
This happens one week after installation of the sonos system and today i used Trueplay. Before Trueplay no issue. Is this the cause of turning the mic on and off on the ARC? On the Era300’s all fine. 

 

Did you ever figure out this issue? I am experiencing the same thing. I have a Sonos Arc hooked up to an LG C1 TV via HDMI eARC, and am using Alexa as my voice assistant. When audio is coming from the TV, I hear the microphone turning itself on and off. It happens randomly, usually every few minutes though.

I have the same problem. Seems to be related to Google Assistant although when using Sonos Voice, you can hear Mic going on and off. Turned off Google and issue goes away.

Internet search suggests there are many with this problem!

Reply