Question

Sound cutting in and out on Sonos Arc after playing Dolby Atmos content on Apple TV 4K



Show first post

103 replies

I am having the same loud zip issue but no audio stuttering. I own a lg cx55 hooked up to the arc through earc and an Xbox one X in hdmi 4. I see Atmos turn on in the app and then the “zip” sound occurs. I did a lot of trouble shooting with choosing different sound settings in my tv, Xbox, and the Sonos app. The only time this sound would go away is if I turned the bitstream format on the Xbox to Dolby Digital… effectively getting rid of Atmos. Hopefully this issue can get resolved through an update from lg or Sonos, I doubt its the Xbox. I’ve only had the arc for a couple of days… sounds great! but this issue gets annoying.

TV: LG CX77

Streaming device: Apple TV 4k 
 

I’m having the same issues with sound stuttering after changing from Atmos to non-Atmos sound content, as well as the loud zipping sound when starting Atmos supported content. None of these issues are present when playing content on native apps on the tv, only when accessing content through the Apple TV 4K. Thanks so much for the updates on this issue, hopefully Sonos releases a patch to read LPCM sooner than later.

Badge

Add me to the list. This has been driving me crazy. I’m so glad I found the post. 
 

Sonos Arc, connected via HDMI2 / eARC to new 2020 LG GX TV, ATV4K via HDMI1.

TV firmware, Sonos firmware and ATV firmware all up to date. 
 

I get as per the OP, the sound stuttering every second, resolved the same way OP describes. I hear the “zip” sound from time to time changing between the TV built in Amazon Prime and the ATV. 
 

I am also seeing the Sonos or the TV randomly rebooting from time to time in the middle of watching something, or occasionally, the TV turns on and the wretched Sonos will not wake up from sleep without a power-cycle to start playing Audio. 
 

All in all, it’s a pretty wretched experience just wanting to watch something and never knowing if it’s going to work properly. I have noticed that the drop-outs have got worse with 3.10.43 on the LG. 
 

My ATV says “Auto, Atmos Available” under Audio Format settings. Audio mode is “Auto”. The LG “Digital Sound Out” is set to “Auto”

 

I may be crazy, but when the Arc was first released, I had virtually no issues with it for the first few weeks. This all seems to be deteriorating rather than improving. 

Badge

Ok, caught the Arc randomly rebooting mid-watching AppleTV. 
Diagnostics 1493524734 time of reboot was 21:08 local time (11:08 UTC).

I hope this helps the Sonos team. 

Same here - Arc/CX/ATV4K. Just waiting on software updates I guess 

I can also confirm having the exact same issues witch ARC/77CX/Atv4K. Sound drops in/out after playing Dolby Atmos content on AppleTV. And sometimes the loud “zip” sound when changing input.

Same issues, same gear. 
LG CX 77 / ATV 4K / ARC+Sub+SLx2

I use the restart TV method to reset audio signals too. But the other day trying that method to turn off TV to reset sound when switching playback from Atmos to Stereo nothing fixed like it normally does. Sound was still clipping even after TV restart. So I had to unplug ARC and then the audio reset. Seemed to be stuck from TV side and seems to be LGs issue IMO. Not sure...
 

Hope the firmware fix comes soon! 

Same issues here too - Arc/CX/ATV4K

Userlevel 4
Badge +8

And here LG CX 

zip sound , stuttering with Apple TV 4K and sound drop switching from various sources.

Userlevel 5
Badge +13

Hi folks, thanks for reaching out with the Sonos Community! Let me share these threads that may be helpful for some of you. 

https://en.community.sonos.com/troubleshooting-228999/no-dialog-through-arc-from-apple-tv-4k-6847888

https://en.community.sonos.com/home-theater-228993/did-ios14-tvos14-quietly-bring-atmos-audio-to-airplay-2-6848270

We will be adding Multi-Channel LPCM support to Arc as part of a future software update. We don’t have exact timing to share at this point and will update this thread as well when we do.

Please let us know if there’s anything else we can help you with. We and the community are always here.

I have the same setup and problem. 
Apple TV 4K/LG OLED CX/Sonos ARC

same zipper buzzing sound. Same muting every half second or so.

 

i’ve replaced all three components including HDMI cables the the problem still happens.

 

I was hoping that TVOS 14 would somehow remedy the issue but that did not happen. 

Well, I basically figured this one out. Apple TV 4K does not properly handle eARC output. 

Also, apple decodes the audio to uncompressed multi channel LPCM. There is an obvious handoff issue between the Apple TV 4K and the OLED CX. I have heard from others that this is a confirmed issue with the firmware for the OLED CX. 

This problem cannot be solved unless Apple comes out with an updated Apple TV 4K that can properly handle eARC or LG fixes the multi channel LPCM issues in its software.

At least none of us have to bang our heads against the wall trying to troubleshoot this anymore.

Userlevel 4
Badge +8

Well, I basically figured this one out. Apple TV 4K does not properly handle eARC output. 

Also, apple decodes the audio to uncompressed multi channel LPCM. There is an obvious handoff issue between the Apple TV 4K and the OLED CX. I have heard from others that this is a confirmed issue with the firmware for the OLED CX. 

This problem cannot be solved unless Apple comes out with an updated Apple TV 4K that can properly handle eARC or LG fixes the multi channel LPCM issues in its software.

At least none of us have to bang our heads against the wall trying to troubleshoot this anymore.

 

Same setup here, do you ever get audio dropouts when switching between sources, I get complete loss of audio occasionally when I switch between hdmi devices or exit the internal apps on the CX back to live TV.

Hi all. I don't own a Sonos product but stumbled across this thread while researching the identical issue as detailed above. I have the 77" version of the LG CX and just picked up an Apple TV 4k. I can reproduce this issue using the built in TV speakers. Just thought I'd mention that for those that want to rule out the Arc. 

Ok have just picked up an LGCX 65” and a Sonos Arc and I’m having problems with Atmos audio dropping out occasionally, but using the inbuilt Apple TV and Disney+ apps. 
 

I’ve just updated to the latest LG firmware and so far it has happened once while watching a film. Has anyone else tested the internal apps?

Hello all. First time here, and I am patiently waiting for my Arc to arrive but am worried seeing this thread. Seems most issues are with the LG CX. I have a LG 65” C7, and will be streaming via Apple TV 4K. My only choice will be using the ARC as my tv doesn’t have eARC. Anyone using this same setup and having audio dropout issues?

 

Thanks in advance!

Update for my issue with in built apps. I had digital sound out set to pass through. Putting it back to auto seemed to fix the issue.

Hi folks, thanks for reaching out with the Sonos Community! Let me share these threads that may be helpful for some of you. 

https://en.community.sonos.com/troubleshooting-228999/no-dialog-through-arc-from-apple-tv-4k-6847888

https://en.community.sonos.com/home-theater-228993/did-ios14-tvos14-quietly-bring-atmos-audio-to-airplay-2-6848270

We will be adding Multi-Channel LPCM support to Arc as part of a future software update. We don’t have exact timing to share at this point and will update this thread as well when we do.

Please let us know if there’s anything else we can help you with. We and the community are always here.

So does that mean in the next month or by the end of the year or longer?  Seems pretty unacceptable to not support the audio format of a MAJOR player in home entertainment such as Apple.  That’s a pretty big mess up.  It’s not helpful for us to hear sometime in the distant future we will have it fixed.  Especially when people are stuck at home during this pandemic.  It’s funny, Sonos has you wait for the equipment and then has you wait for the fix to make the equipment work.  Makes you wonder why you bought the equipment in the first place.

This couldn’t have been an unknown issue for Sonos.  I’m not sure why it wasn’t addressed at product inception.  

I’m getting the loud “ZIP” sound, along with an audio “gate” effect where the audio cuts in and out ever .5 seconds.

 

ARC / LG77GX / AppleTV4K

I just unboxed my new LG65CX. Connected my ATV4K and Sonos Arc up to it.

I immediately experienced the issue. Audio cuts in and out every second after playing Atmos content.

Looked up the issue on Google and found this thread. Ugh

Hey guys!

have anyone a solution on this problem?

I run Sonos arc > hdmi earc in my Samsung q60 qled 2020.

apple tv4k into hdmi 1 and my mac book in hdmi 2.

problem as you all seems to get is that the sound clip out every other second. 

I have updated my tv, sonos and Apple TV.

just unplugged power source and hdmi on my arc and now it seems to work for the second…. 

 

I’m having the same issue with ATV 4K and my new LG OLED CX 77. Sound cuts out every other second. Doesn’t always do it. Occurs after watching a Dolby Atmos program from the ATV and then switching to watch something else on the ATV. Doesn’t stop when I restart the ATV and the TV. I do have a Sonos Arc connected to the TV.  When it occurs it continues even if I totally disconnect the Sonos Arc from the TV and it continues if I switch the audio to the TV’s internal speakers. It does not occur when using the LG TV’s native apps (Hulu, Netflix, etc.)  I haven’t found anyway to make it stop once it starts while using ATV. However, when I’ve turned everything back on the next day, the sound is OK again. It recurs again after I watch a Dolby Atmos show.  Would sure love a solution. 

I’m having the same issue with ATV 4K and my new LG OLED CX 77. Sound cuts out every other second. Doesn’t always do it. Occurs after watching a Dolby Atmos program from the ATV and then switching to watch something else on the ATV. Doesn’t stop when I restart the ATV and the TV. I do have a Sonos Arc connected to the TV.  When it occurs it continues even if I totally disconnect the Sonos Arc from the TV and it continues if I switch the audio to the TV’s internal speakers. It does not occur when using the LG TV’s native apps (Hulu, Netflix, etc.)  I haven’t found anyway to make it stop once it starts while using ATV. However, when I’ve turned everything back on the next day, the sound is OK again. It recurs again after I watch a Dolby Atmos show.  Would sure love a solution. 


I am able to temporarily fix the issue by playing content that is in 5.1
For example, if you are watching a netflix show in Atmos, this will make the audio cut in and out. If you then play a netflix movie that is in 5.1 for a few seconds, this fixes the issue for me…...The audio returns to normal until I start playing something in Atmos again.

What I do now is just watch Atmos content within the built in LG apps until there is a permanent fix for this issue. I don't have the issue when using the built-in LG apps.

I can tell you that this is no way a Sonos problem.   I tell you because I own a LG 77GX with no external sound (using internal speakers only).  This is the only forum that I found on the internet that is discussing this issue.  That is why I joined.   

I am having the same exact problem where if I play something in Dolby A, and then go to some other app, it will do the one second sound on and one second sound off loop.   The only thing that fixes this is to go into some other app like Netflix and find a program in 5.1 (and I only found this solution by reading this thread, thank the Lord lol) and play this for a few seconds and then you can go back to the app you are trying to play and it will play fine.   Nothing else fixes this. 

I can recreate and fix this problem all day long by doing the above. 

Before this, I exchanged my cables (belkin high speed) and then after that exchanged the apple tv 4k and then the tv was exchanged since I have only owned this for under 2 weeks (this issue started from day one).  So, I’m still dying for a solutions but I’m so glad I found a temporary fix.   I hope this info helps you guys but I’ll be following just in case there is a permanent fix.  

Badge +1

I just ordered the Sonos Arc but it wont get here till mid November BUT, I can replicate this issue with my 77” LG CX, Apple TV 4k and Sonos Playbase. The workaround (until I want to play Dolby Atmos when the Arc arrives) will be to set the Apple TV to change format to Dolby Digital 5.1.

 

Replying to this thread to follow it later. Hopefully this gets sorted out by an update from either LG or Apple. 

 

It is pretty frustrating to spend the kind of money that this set up requires and have this issue. 

 

Edit: Still have the same issue after updating to the v3.11.25 version of the LG frimware. 

Reply