Dolby Atmos causing audio on Arc to "pop" then cuts out

  • 8 November 2021
  • 82 replies
  • 6507 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

82 replies

 

I apologize for the inaccuracy.

I don't have a problem with the sound popping, but only with sound interruptions/outage. On Apple TV, you can only select the option "change format" to dolby digital 5.1 or stereo. If you change to DD 5.1, everything is fine. The problem is only with Atmos sound! I have to say that this problem started to show up only after updating tvOS 15.0 or 15.1 and for Sonos probably 13.3.2. Before that, everything worked without a problem.

Hello,

I have got a same issue. Even after update tvOS 15.3 first beta and Sonos to 13.4.1. Problem is still there.

Maybe try switching off the multi-channel LPCM option on ATV and just use the DD+ (Atmos) codec on the device instead - it should hopefully prevent the popping that you’re perhaps encountering occasionally from time to time. Not entirely sure if this is a Sonos/Apple issue, but maybe switch back to LPCM after each device firmware update, to see if the issue is resolved/eventually goes away.

Hello,

I have got a same issue. Even after update tvOS 15.3 first beta and Sonos to 13.4.1. Problem is still there.

Just to add to this. 

I’ve experienced the audio issue with multiple apps (Netflix, HBO Max, Paramount+) only when Atmos is playing. 

TVOS: 15.1 Has happened with all TVOS 15 updates but even happened when i was running 14. 

Arc Software is the most recent 13.4

When watching through the TV apps no popping issues are present but I CAN notice a faint decrease in volume very quickly then it regains normal volume levels. It’s so faint that you can barley notice. Not sure if thats an issue with the TV or Arc but I eliminated the ATV all together so it seems there still an audio issue present. 

I also realized (as someone else mentioned) ATV only pushes Multichannel PCM instead of DD+. I’ve noticed that DD+ sounds better so I’ve been playing my content through the TV apps when available. Sucks that apple doesn't support DD+ (but thats another topic i guess).

 

Userlevel 3
Badge +3

Just to expand further on the above; I’ve noticed differences between my three test sources of Atmos content: Sony Bravia XH92, Apple TV 4K (2nd Gen), and PlayStation 5.

When viewing Atmos content on the Bravia, the “About my System” screen shows the encoding as Atmos (DD+).  (For reference; my settings on the TV are to use “Audio mode 1” and output as DD+).

The PlayStation 5, which is not a Atmos device, but can output the audio bitstream when watching Blu-Ray media shows (at least for Spider-Man: Into the Spider-Verse) as Atmos (True HD).

The Apple TV, however, is just “Dolby Atmos”, no brackets, no DD+ or True HD.

Not sure if that’s a contributing factor here — just something I noticed.

---

EDIT: Digging a little deeper, it seems that no brackets is Dolby MAT encoding, which appears to be LPCM with some Dolby metadata sprinkled on top.  Interestingly, it seems that Xbox Series X (which seems prevalent when searching for “Arc popping”) also uses Dolby MAT. 🤔 

Userlevel 3
Badge +3

Just tried this morning — left Shang-Chi on Disney+ running, and then moved onto Snowpiercer on Netflix.  No issues at all.  Both had dropouts in under 10 minutes previously.

The only changes I made in the last few days was upgrading Arc to 13.4, and rebooting everything.

My Apple TV is an awkward place to do a complete power down from the mains (as the initial troubleshooting step by the Apple CS rep), so I powerered everything off, and flicked the power switch at the wall that has the extension for all my AV devices in the Living Room.  Left it for 30 seconds, and powered everything back on.  Following the update to 13.4, I tried the “TV Setup” again option, incase it needed to announce it now supports DTS or something daft (Whatever this button actually does… 😅)

So maybe it was the Arc’s software after all…  Looking at the release notes, the Arc has had some minor revisions (13.3.x) over the last few week or so, and I have automatic updates turn on.  Maybe one of these introduced a bug for the Apple TV’s particular encoding of Atmos?

That said, I’m not actually in the room with the Arc at present, just keep popping in to see if the Arc has crapped out.  Might be that it’s cutting and fixing itself, and still an issue, but doesn’t feel that way…

Will have to check against actual Atmos content in situ.  Definitely worth a retest on your own devices though.

Userlevel 3
Badge +3

New tvOS beta and a Sonos system update. Wonder if the issue will still occur later on.

Worth a try.

Spoke to Apple yesterday, explained I only experience this issue with Atmos content on Apple TV; mentioned they didn't have a record of similar issues in their bug tracker but are going to escalate to engineering to get started.

Seemed to acknowledge that the Apple TV seems the, if not if, a contributing factor given the circumstances.

Will keep pulling this thread and see where it leads.

Might not hurt opening your own support cases to light a bit of a fire…

 

New tvOS beta and a Sonos system update. Wonder if the issue will still occur later on.

Userlevel 3
Badge +3

I've reached out to Apple Support and have a call with a senior advisor this afternoon, so we’ll see what's happening.

Unfortunately, seems the Apple TV 4K has no downgrade method due to no DFU mode 😔 

i had ZERO problems with tvOS 14.  I also did not have an issue with 15.0.  Seems the problem started during the 15.1 push.

Userlevel 3
Badge +3

Just attempted to watching Atmos content on Netflix on the aTV — pop! (< 10min)
Now watching an Atmos encoded Blu-Ray via PS5 (passthrough audio), nothing yet…

Half tempted to see if I can put the aTV in DFU and load tvOS 14 back on to it…

Userlevel 3
Badge +3

I was thinking about going to 15.2 to see if it would fix it, sucks to hear that the issue still exists. Hard to say if it’s an Apple issue, Sonos, or a mix of both at this point. I’d imagine that would be something for Sonos engineers to figure out and fix or report.

Quite possibly. It smells like the Arc struggles to recover after a decode failure, and that the Apple TV is having issues with the encoding. 

I was thinking about going to 15.2 to see if it would fix it, sucks to hear that the issue still exists. Hard to say if it’s an Apple issue, Sonos, or a mix of both at this point. I’d imagine that would be something for Sonos engineers to figure out and fix or report.

I’m encountering the error on all Apple TV apps the stream content with Dolby Atmos--Netflix, Disney+, Paramount+ and Apple TV+.

 

I’m using tvOS 15.2 beta release.  I switched to getting beta updates on tvOS in the hopes that the audio issue would be resolved quicker.  It has not.

Userlevel 3
Badge +3

Just to troubleshoot, what sources is everyone using? Disney+, Netflix, Apple TV+, or a mix if various?

It seems that this issue seems common amongst Apple TV and Xbox users; seemingly with Sony and LG TV sets.

What version of tvOS is everyone using? It seems that tvOS 15 has caused various audio issues not limited to this one…

I’ve experienced this twice, both while watching Dolby Atmos content on Apple TV like movie rentals. Just happened again today. Loud pop, no audio from ARC until I back out and play the content again.

LG C1 TV, eARC, passthrough

I’ve been experiencing the exact same issue for the past month. AppleTV 4K (2nd generation), television is Sony X900H, and the Arc. When playing Atmos content I will get a loud pop then all sound cuts out. I have tried every setting imaginable and the only thing I can do is turn off Atmos content on the Apple TV.

 

I have the Arc connected to two One SLs and the 3rd generation Sub as well.

Userlevel 3
Badge +3

Just tried running the same movie through the Disney+ app for Android TV built into the Sony TV itself. No issues for the first hour. Happened twice until this point.

Userlevel 3
Badge +3

Apologies if you already mentioned it but can't find it if you did – what source were you playing from (on the Apple TV)?

Userlevel 3
Badge +3

I experienced this very issue last night – nearly soiled myself thinking that I’d blown a driver.

Sonos Arc (with 2 One surrounds and a 2nd gen sub) connected to an Apple TV 4K (2nd gen) and a Sony XH92 – config not changed in over a year since purchasing last November.

Watching Shang-Chi on Disney+ via the Apple TV, no less than 4 interruptions. Fixed by backing out and entering again, or disabling Atmos entirely. 
 

I get the feeling it's an encoding problem from tvOS – this is the first Atmos movie we've watched since upgrading to tvOS 15.  We did upgrade the TV to Sony’s latest Android 10 firmware recently, but that has yet to be troubleshot. 
 

Next steps are to try for me:

Atmos content from Disney+ via aTV

Atmos content from other sources via aTV

Atmos content from Disney+ via the native TV app


See if the issue is Atmos itself with the TV/Sonos, or the Apple TV.

Reporting back. This issue happened again. It only happens with the Apple TV 4K. I’ve been watching Atmos content through the TV apps and its worked perfectly. Not sure what the issue is with the ATV and its a little annoying to switch back and fourth but at least I’m getting the full benefit of the Arc now. 

If anyone has had the same issue and they’ve fixed it please let me know. 

I reset the Apple TV again it applied an update that it didn’t do in the last reset. It seems (right now) that the Apple TV is playing the Atmos content fine. It happens intermittently so I’ll report back of the issue happens again. 

Userlevel 4
Badge +3

Assuming the TV is set to passthrough, earc enabled and plugged into the correct port from the Apple TV device it should be fine. Did you say you've tried a factory reset of the apple device ?

After playing content over both Apple TV and the build in TV apps it looks like its the Apple TV that is causing the issue. I had no audio cut outs yesterday. 

With that, does anyone know of any settings to get Atmos to consistently work over ATV? 

I’ll play some content tonight from the TV itself and see if Atmos is steady. It not extremely frequent so reproducing the issue will take some content watching. I’ll report back with my findings.