Sonos One (Gen 2) : Multiple issues with Google Assistant



i have replaced my SONOS play:1 with a SONOS One to get acces to Google Assistant commands.

After a succesful setup and adding my Google Assistant in the SONOS app and adding my Google Play Music premium account I though I was set. But apparantly there are major issues:

  1. The ‘OK Google’ Command works. After that, 95% of the commands stop working. The microphone just blinks ad thats it. I found a topic about that where a SONOS employee answered that it would be fixed and in a timely matter. This a thread of 4 months (!!!) ago. Is there ANY update on this (No Alexa or another speaker is not a option for me). How is this still an issue?
    Link to thread:
  2. When I use a music command that got accepted (very rarely) this happens:
    ‘Play number X by artist X’ 
    Answer ‘Ok playing song X by artist X on Google Play Music’ I’m sorry, I cannot help you with this’ 
    Why is this? I have heard that it should be a Google Account problem. I have someone else asking it with another account and there the response is :
    ‘ I cannot play this on this device, but I can on any other device’. 
    I have tried it on a nest mini speaker: Works like a charm. 
    I paid alot of money to have this functionality on a speaker I expect it to work.
  3. It isn’t possible play music from a Google Play Playlist? Or to Shuffle my playlist? I get responses that it it not possile to do that? Again why is that? Is there a fix for this?

I did not read the reviews after I bought the speaker and I have seen that there are multiple issues with this, so I would expect this is on the short roadmap to be fixed?
Any help or feedback is appreciated.






Best answer by Annazel S 16 January 2021, 21:51

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

18 replies

Userlevel 5
Badge +16

Hi @TomVandege.

Thanks for reaching out and for the detailed post.


When issues like this spring up, the more information we can gather will help us resolve the problem. 

We've been receiving reports that when issuing a command to Google Assistant via a Sonos One Gen 2, they get no audible response.

  • Kindly check if the issue you’re experiencing matches the above symptom.
  • To reproduce, please try the simplest command that appears to fail is "ok google, what time is it? " 
  • Observe the speaker processing the command and then no audible response.
  • Then, go to and check the corresponding activity if you will see an “unknown voice command” in the activity.
  • Please let me know the result, it will help me identify the issue and provide the appropriate resolution.


Voice assistants on Sonos devices are currently only able to play music from online music services that are compatible with the service. 

Your playlists are a mystery to the voice assistant as everything there takes place in the cloud, with no knowledge of what you have at home.

So far, Spotify is currently the only music service supporting this feature ( Plays created and curated playlist on Spotify via Google Assistant).

I think this feature would be very useful and I would be happy to pass this through the pipelines within Sonos as a feature request. 


I am looking forward to assisting you further from here.
If you have any other questions or run into any issues, please do not hesitate to reach out.

I see you didnt get a reply @Annazel S. I can confirm that I have theese symptoms very often. I dont use Google Music, but I use Spotify. My Google Home work just fine. It accepts and understands my commands. My new Sonons One Gen 2 however simply dont understand most of the commands. 

I ask a basic question or give a  basic command like “Hey Google, set a timer for 15 minutes”. 
When i prompt “Hey Googl”, the light on the Sonos birghtens up to indicate it is readey to take commands.

After I said my fraise the light blinks on the Sonos, but then nothing happens. When I check the activity in Google it says “Unknown voice command”


Very frustrating since my new Sonos speaker replaces my Google Home in that location and I used the assistant on my Home very much 

Userlevel 5
Badge +16

Hi @cwallervand.

Thanks for reaching out and sorry to hear about the trouble, let me see what I can do to help you.

Kindly reproduce the issue, then submit a diagnostic report through the Sonos app shortly after the issue occurs, and reply with the confirmation number. I'd start by reviewing your system as well as the status of the devices, it will help in identifying what's possibly causing the issue.


Looking forward to hearing from you soon.

@Annazel S  

I just reproduced the issue, prompting the assistant for the time: «Hey Google, what’s the time». Confirmation number: 1570088923

@Annazel S  

I have the same problem and am following this thread with interest. My Sonos 1 Gen 2 is a week old and set up with Google Assistant, At my first attempt, I managed to give 5 commands in a row with no problem at all. From then on, 1 in 10 /20 commands might get a response.

I start with “Hi Google” - Sonos chimes; I give my command, the light blinks (30% of the time it does not blink at all) but does nothing, then suddenly it works once and stops again. In Google Assistant, it says “unknown voice command”

Userlevel 5
Badge +16

Hi everyone. We appreciate your patience on this, and my apologies for the delayed response time.

At this point, it would be best to reach out to Sonos Support so we can take a closer look into this and continue working with you in real-time. 

I suggest contacting our phone team, for they have more resources available for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to perform any hands-on troubleshooting and testing as needed.


If you have any other questions or concerns, feel free to reach out.

Hi @Annazel S,

I’m experiencing the same issues as others on this thread. This is on a Sonos One Gen 2 with Google Assistant. 

I’ve worked with the phone support team, who have found no issue on their diagnostics but the issue is still occurring. We’ve tried ethernet instead of wireless, removing the assistant and reinstalling, factory reset, moving the device away from walls. But nothing has improved.

I have logged multiple diagnostic codes example: 1505470844. On the google activity page, there are multiple occurrences of the ‘unknown voice command’

Please could you provide some help on this? I’ve been informed by the phone support that I am not eligible for a refund as they do not deem the product faulty! I’ve only had this product for 15 days…

Hi there,

Happy new year! I am having similar issues. I ‘upgraded’ from my Google Home about 10 days ago and I’m very disappointed to see that 70% of the time Sonos fails to execute the command. To add to what others have already said, I thought I’d provide the following which may be useful (using Spotify Premium):

  1. The device registers the ‘Ok Google’ or ‘Hey Google’ command without any issues. However, the device does not always perform the requested task that follows. For example, if I ask ‘Ok Google, play [x] on Spotify’, Sonos will listen but then not play anything, even if I repeat the process multiple times. If I go to, these show up as ‘Unknown voice command’.
  2. The exact same command works if I use the Google Assistant app on my phone and the speaker will start playing. The command registered through the GA app also correctly shows up as ‘Play [x] on Spotify’ on 
  3. I have also noticed that a song initiated through the Sonos or Spotify phone app cannot be controlled through Google Assistant voice commands using the Sonos speaker. For example, if I start playing a song to the speaker using the Spotify or Sonos app directly, I cannot then use the command ‘Ok Google, pause music!’ to pause playback. The speaker volume decreases for a few seconds while it listens to my command but once again nothing happens. This time around, the activity registers on as ‘Used Assistant’ but no indication whatsoever what command it was. However, the same command through the Google Assistant app on my phone works a treat and the music pauses. 
  4. Changing the microphone sensitivity in the Google Assistant app does not address the issue, so this is not an ambient noise issue. I thought there could be an issue hearing my commands so I repeated all the above but with the ‘Hey Google’ sensitivity on maximum (+2),but the issue persists. To be clear, I am in a quiet room, literally stood over the Sonos, so ambient sound is not the issue here. 
  5. Factory resets don’t work. I have reset the Sonos device (despite it being brand new), re-added to my Assistant, re-linked to Spotify, etc. but still no luck.

I hope this helps. I’ve been super thorough and have tried everything at this point. If there is no fix soon, I may have to return the device because this is not the seamless experience that I was expecting from a £200 device. 


Looking forward to your response. 



Yes I am having the exact same issues.  I have a Sonos Beam and it works as I would expect with Google Assistant.  However the Sonos One appears to be sporadic in understanding voice and interacting with Google Assistant.

I have an ongoing support call with Sonos and will update the community as it progresses.

Same issues here on brand new gen 2 Sonos One. GA responds to simple commands like time, but very often it Just pings after the hey Google, but doesn't respond to the command itself. In the GA activitiy it is listed as unknown voice command. 

@Annazel S Is the best thing really for every customer with this issue to call Sonos customer support? 
I would argue that this will cause unnecessary traffic for Sonos support, especially since this is a very common issue, and an issue that has been here for a long time (a quick search on Google will confirm this). I am guessing this is a software issue and it needs to be fixed by Sonos (maybe in cooperation with Google). As of now the Sonos One speaker does not work as advertised. 


I bought the Sonos One speaker because of the Google Assistant feature (could have bought the SL instead) so it’s a shame its not working. 

Please bring this issue to the product owner for the Sonos One speaker and features!

Userlevel 4
Badge +6

Having the exact same problem here. And this has been going on for what seems like ages.

I have the same issue with a brand new Sonos one gen 2 with GA. I don’t know which to dump, the Sonos or google?  Very frustrating. 

Userlevel 5
Badge +16

Hello folks, due to the nature of this issue, it would be best if you can give us a call and work with a technician live, they'll start with checking the status of the device and go from there. Again, they have more resources available for advanced troubleshooting, and the tools our agents can use would be very useful in this case. A troubleshooting ticket will be created and the details that will be gathered can be helpful for further investigation.


If you have any other questions or concerns, feel free to reach out.

Same issue myself before I switched to Alexa voice service which has been 100% reliable.

I have the same issue. I tried anything suggestion I came across in regards of this issue but no solution yet.

Switching to Alexa is a no go as I will have to reconfigure all my appliances. 

this is very frustrating! 


After extensive troubleshooting with Sonos their engineering team agreed that there was an issue with some Sonos One Gen 2 models with Google Assistant and could not advise when it would be fixed.

Sonos have replaced my Gen 2 with a Gen 1 which works perfectly with Google Assistant.




I have my whole house Google home operated so I thought I'd upgrade my Sonos speakers etc to latest versions with Google Assistant incorporated but after only a week using them I can already notice 80% of errors after asking commands, severe delays in responding (even tested times against all my Google devices and there could be 40seconds or longer delay between Sonos One and Google response  - if it works. Sometimes the Sonos One will do the request (eg to boil the kettle) but will not respond. Other times I'll ask her to boil the kettle and she will do the command and then shortly after she'll say oopps there was a glitch (even though she ran the command correctly!) Other times eg I ask to play songs from the eg Beatles and the song will start to play, the Google (Sonos) will say found Spotify playlist from the Beatles and then start playing and then she gives me an error saying Sonos hhmm something's gone wrong, try again in a few seconds (even though the music is playing in the background and continues to play. )

Other times I could ask her the capital of a country and she takes so long I go to a proper Google home device and ask her and she comes back with the answer - 1 or 2 mins later Sonos will give me the usual hhmm something went wrong message!


I am well used to supporting Google home products and rectifing their issues but the Sonos One needs a software update badly! 

No WiFi issues, no network issues, no Google home account issues - if just needs patching. I unfortunately don't have time to contact support (hence sending this early in the morning) and I personally know others who have recently purchased the Sonos One with Google and ALL have similar issues - most were new to Google and blaming Google but this isn't a Google Home issue per-say, it's a Sonos issue that just needs patching.


Hopefully software update will be pushed to them soon (or my wife will kill me for swapping out some of the Google Home devices which worked all the time, for Sonos Ones (which work when she decides to)!