Google Assistant stops responding/working

  • 23 November 2019
  • 4 replies

Hi there, I am based in Singapore and since the launch I've had real problems keeping assistant working. After a few days it will stop responding entirely, meaning I have to remove the GA/Sonos link and reinstall. This fixes the problem short term but i have to repeat the process quite often.


Can anyone help please?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

I had the same issue.  Here is how I fixed it.

I used my Chrome browser to go to:

Make sure you are logged in with the correct google account.

On that page you see a list of all the commands you ever gave to your google assistant and browsing history.  To make it easier and only see assistant commands, you can press the Filter button and select Assistant.  It will only show commands.

The long history list seems to confuse Sonos.  So press the “thrash can” button next to the Today and all the other dates.  I had to press many times because it keeps the history day by day and there is no delete all history button.

After that, select the main “My Activity” menu on that page and select “Activity Controls”

Uncheck the two boxes in Web & App Activity.  It pauses google recording all your activity.

This fixed the problems and I could again have a meaningful conversation with my Sonos One.

For example a command like Volume 1 or Volume 2 did not work anymore at all.  Since I went through the above steps, these work again.

Despite the fact that I disabled “Include voice and audio recordings” in the “My Activity” section, it still seems to register all commands in the history.  So I may need to clear this in a month from now again.

It would be great if the Sonos team checks why this history is such a problem while it isn’t with other devices like Google’s own Home devices.

Thanks very much for your detailed reply, however I tried the steps and still nothing. I had to unlink and relink the connection to get going again.

Anyone else having the same issues with a different solution?




I have the same issue: GA tells me the weather etc. over the Sonos One but will not play from Spotify or any of my usual radio stations on myTuner or TuneIn. Very annoying as I have to issue commands to the Sonos One via Spotify app on my mobile.  The Sonos One is in the kitchen and I am often in mid-cooking when I tell it to change channel or volume or pause.

I notice this issue is often on Sonos Community over several years. Hey Sonos - let’s fix it ! Have a chat with your friends in Mountain View pleeeease!

In case the Google Assistant is still not responding to your voice commands, make sure to uninstall updates from the Google app. Or, if possible, uninstall the app completely and then install it from scratch. ... Tap Uninstall updates. Reboot your device and update the Google app from the Play Store.