Answered

Google assistant endless loop


Userlevel 2
I was excited to see integration with Google assistant, however when I try to add sonos, the following happens:
1) I go to voice services and add Google Assistant
2) this takes me to the Google screen where it authenticates me using the same email address that's on my sonos account
3) this then redirects me to the sonos authentication
4) after authenticating on sonos, it says I need to register my speakers to my account, so I click Go to Sonos App, and the process starts all over again.

This doesn't make sense. My speakers are registered to my account. When I go to the sonos website, and sign in with the same email address, I can see all of my speakers. Elsewhere in this process it says if I go to More > Settings > Account Settings and I don't see "Account" I need to update my sonos system. I do not see "Account" - I see my email address as the linked account and then I see Transfer account. Where is "Account"? I've also confirmed my app and speakers are all up to date.
icon

Best answer by Smilja 15 May 2019, 16:33

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

Moderator Note: This outage should now be resolved. If you continue to have any issues, please open up a new thread.

There's currently an outage affecting Alexa and Spotify Connect. GA might be afflicted as well.

https://status.sonos.com/

I am currently having this issue, have tried all the available trouble shooting options. Is there an un-reported service outage? If not, is there a potential fix?

using iOS 13, updated all the apps.
signed out and unlinked all services from sonos
No conflicting devices
cleared history/cache from browsers and rebooted everything

I'm following the steps to set up and I just get into an endless loop. After sonos opens GA, then GA takes me to the sonos login, I select select "ok" to allow access, then I get brought back to the attached image in GA and the Sonos app give the an error as shown.

Any insights?

Same issue here: I’m a first time Sonos (with a new Move) and Google Assistant user and adding the Google voice service sends me into and endless back-and-forth between the Sonos and Google Assitant apps.

Both apps downloaded today. Just updated to the new iOS 13.1 and still have the same issues. Also happened on iOS 13 before this.

Never tried on iOS 12 as I only got the speaker today.

Perhaps try installing the Sonos Device/Skill manually in the Google Home App first and setup your Sonos devices in the relevant rooms of your Google Home. Also ensure you set a default streaming music service. (Note the same music service account needs to also be installed in the Sonos App).

Then in the Sonos App, goto Settings/Services/Voice/Google Assistant and choose to ‘Add to Another Product’ and follow the onscreen instructions to setup your new 'Move' device.

Hope that helps to get your 'Move' up and running with the Google Assistant.

Moderator Note: This outage should now be resolved. If you continue to have any issues, please open up a new thread.

There's currently an outage affecting Alexa and Spotify Connect. GA might be afflicted as well.

https://status.sonos.com/
I am currently having this issue, have tried all the available trouble shooting options. Is there an un-reported service outage? If not, is there a potential fix?

using iOS 13, updated all the apps.
signed out and unlinked all services from sonos
No conflicting devices
cleared history/cache from browsers and rebooted everything

I'm following the steps to set up and I just get into an endless loop. After sonos opens GA, then GA takes me to the sonos login, I select select "ok" to allow access, then I get brought back to the attached image in GA and the Sonos app give the an error as shown.

Any insights?


Same problem for me.
Worked to connect when i used the app Google HOME instead of Google assistent 👏👏👍🏼
Same issue for me in sweden. Just looping when i try to connect Google Assistant to Sonos
Userlevel 7
Badge +26
Hi everyone, we're working on this issue and have some improvement measures in place. It's not entirely resolved just yet, but the error rates are significantly down, so it may be working for most people. As Smilja posted, you can follow the status on our website.

There's currently an outage affecting Alexa and Spotify Connect. GA might be afflicted as well.

https://status.sonos.com/
Guys, in which country do you reside? GA is available only in US till July.
United States
Same problem here too
Userlevel 2
@pcdangio yeah I saw that and also updated my address. No luck.
Following. Same thing for me too. Ugh.
Ditto! Was working fine when I first registered everything yesterday. Today it wouldn't play so I unregistered Google Assistant and started registration all over. Getting the same error mentioned:

You need to link speakers to your *********@gmail.com Sonos account before you can add this skill.
Moderator Note: This outage should now be resolved. If you continue to have any issues, please open up a new thread.

There's currently an outage affecting Alexa and Spotify Connect. GA might be afflicted as well.

https://status.sonos.com/
Same problem here.
Badge +1
Came here to post about this! Misery loves company.
Badge
Same problem here...Following
Same issue in Denmark
Same issue in Sweden.
Using The Google Home app did the trick. Thanks!
Userlevel 1
Badge +3
My system is back online and working again.
I'm still having the same issue that OP described.
Same issue here: I’m a first time Sonos (with a new Move) and Google Assistant user and adding the Google voice service sends me into and endless back-and-forth between the Sonos and Google Assitant apps.

Both apps downloaded today. Just updated to the new iOS 13.1 and still have the same issues. Also happened on iOS 13 before this.

Never tried on iOS 12 as I only got the speaker today.
Thanks Ken. This worked for me. Quite convoluted but I suspect something is broken on the back end.

I have no investment in either Google or Alexa so may try both to see which works best with Sonos.
Thanks Ken. This worked for me. Quite convoluted but I suspect something is broken on the back end.

I have no investment in either Google or Alexa so may try both to see which works best with Sonos.

Glad it worked for you. Both voice services have their advantages/disadvantages, so I have a mix of both around my home, but I think I prefer Alexa at the moment, because of its group control with Sonos devices, which works with Alexa Enabled Groups in the Amazon App, but it’s still ‘early days’ with Google Assistant on Sonos and things do tend to improve over time.
Having the same issue as we speak.