Answered

Cannot Connect Sonos to Google Assistant (register speakers)

  • 28 December 2020
  • 12 replies
  • 495 views

Badge

I can't add Sonos to Google's Home or add Google Assistant to my Move.

 

Both approaches fail after giving my Sonos credentials, telling me to register speakers to my account. I have 10 speakers registered to this Sonos account!

 

I used to have it all working, specifically allowing me to use my Sonos Port as the default speaker for a bike mini, in my kitchen.

 

This all broke, so I removed the integrations and started again. But it added my V1 Connect, not my V2 system.

 

So I moved my V1 Connect to a new Sonos account, leaving all my V2 stuff on the original account.

 

Now I get this issue when trying to add Google Assistant integration to my V2 system account.

icon

Best answer by mashton 5 March 2021, 10:13

I've fixed this.

 

Problem was that the domain ws.sonos.com was being blocked by my nextdns.io DNS filter.

 

Added that domain to the allowlist and we are back in business.

View original

12 replies

Userlevel 5
Badge +16

Hi there @mashton.

Thanks for reaching out, we’d be glad to help.

To better understand what’s going on, kindly replicate the issue, then submit a diagnostic report through the Sonos app shortly when it happens, and reply with the confirmation number. I'd start by reviewing your system and go from there, it will help in identifying what's possibly causing the issue.

 

Looking forward to hearing from you soon.

Userlevel 4
Badge +7

Sonos is having problems with Google right now. My Sonos One speaker pair spontaneously lost connection with Google, although everything else was fine - for example I could still play to Sonos from the Sonos app or from Alexa on my Echo Dot. The Sonos app showed no voice assistant on the speaker pair. I had to go through the voice assistant setup again from scratch to get Google Assistant back.

Userlevel 5
Badge +16

Hi @Doug Ames.

Thanks for reaching out, we’d be glad to help.

You can set up a voice assistant service on Sonos one at a time, choosing between Amazon Alexa or Google Assistant.

Which voice service do you prefer to use?

To check some data from your system, please submit a diagnostic report through the Sonos app and reply with the confirmation number. I'd start by reviewing your system to see the status of the devices and the associated service(s).

 

Looking forward to hearing from you soon.

Badge

Hi Annabel,

 

I have just tried this again, both from the Sonos App and from the Google Home app.

 

I either get the same error or it asks me to "update my Sonos App". I am running the latest version. 

 

I have submitted a diagnostic. Number 1463959939

 

 

Badge

Sorry. My phone auto corrected your name. 

 

Annazel.

 

Matt

Userlevel 5
Badge +16

Hi @mashton.

Thanks for your reply and my apologies for the delayed response time.

Upon checking on the diagnostic, all the players are not connected to our Sonos server, there’s no cloud connection. 

Try to manually reboot the players by unplugging the power and plugging it back in. This will force the player to attempt to reconnect to the cloud server.

 

Alternatively, it would be best to reach out to Sonos Supportso we can take a closer look at this in real-time and expedite the process.

I suggest our phone team for they have more resources available on their system for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to see what's going on.

 

​If you have any questions, please feel free to let us know.

Badge

I've fixed this.

 

Problem was that the domain ws.sonos.com was being blocked by my nextdns.io DNS filter.

 

Added that domain to the allowlist and we are back in business.

I've fixed this.

 

Problem was that the domain ws.sonos.com was being blocked by my nextdns.io DNS filter.

 

Added that domain to the allowlist and we are back in business.

Hey @mashton,

I am currently having the same issue, I keep seeing the message that I need to register my speakers. However I do not have set up anything like nextdns.io. Do you know how I can check if something is blocking the domain, and if so how I can fix it?

 

I have the same issue.

 

I have bought a brand new system consisting of Beam, Sub and 2xSL, and I had it up and working with Google Assistant (Alexa is not available in my country). I then added a new One speaker to an adjoining room. After first setting it up with Google Assistant in a separate room, I wanted to try to add it to the same room as the existing system, and I ended up resetting the speaker and disconnecting Google Assistant from Sonos. This didn't work, and I then tried to get the system up and running in separate rooms again.

 

Since then I haven't been able to set up Google Assistant. I get the same problem as described above. The Google Assistant setup flow redirects me to a Sonos login page, then to a page which tells me, I have to register the speakers. The speakers are registered in the app, and I am logged into the app.

 

Frankly, I don't understand the solution described by @mashton , and I don't know what a nextdns.io DNS filter is.

 

Is there a solution to this? Thanks.

 

Edit: I found these two recent threads that may be about the same issue:

Thread no. 1  

Thread no. 2

 

Edit 2: I just tried again after writing this post, and it spontaneously started working again. It'll be some time before I have the courage to change anything again.

I have the same issue 

It's broken. The app linked to is the old S1 App so this whole process clearly hasn't been touched whilst the rest of the exo system evolves.

All my speakers are registered and running S2 yet the Google Assistant setup flow does not work.

The process is clearly broken and somebody from Sonos and somebody from Google should work together to fix this.

I just purchased the Sonos Move and I have this exact same problem. I our purchased the Sonos move.for the Google Assistant integration and would hate to return it because of some integration issue as the speaker is fantastic.

Reply