Question

Anyone else experiencing sever APP LAG & slow loading/refresh with S2?

  • 2 January 2021
  • 7 replies
  • 148 views

Userlevel 6
Badge +3

Ever since we took the plunge for S2 (including upgrading/purchasing 6 new Sonos unit for S2 compatibility) it’s been a real mess (system stability and WiFi issues)! 

The iOS version of the S2 app is very slow to load, lags almost always, and has a terrible screen refresh rate compared to ANY iOS app we have in the household.   Now 20-40 seconds might not seem like long for an iPhone/Pad app to load/refresh, but if you’re trying to get some quick control over the volume or switching songs this is a STUPID amount of time! 

 

S1 was almost instant across all platforms and apps.  While I realize Apple can take some blame for issues with iOS apps, why is S2 slow on PC and Amazon Fire (Android) devices as well?  

I’m guessing I’m not the only one, but Sonos sure seem slow to address this no matter how many times I’ve reported it to support. 

Anyone else think this degrades the Sonos experience beyond the obvious annoyances (especially compared to the hundred or so other apps we use with NO lagging)? 


7 replies

I’ve got no lag, on my 18 speakers and 5 controllers, using S2. Which makes me think there’s a local issue in your system.

I’d suggest three things to you. First, review the wifi interference FAQ. There’s some potential that your system is troubled, perhaps by outside influences. Worth reading through and applying what solutions are presented.

Second, try a network refresh. Unplug all your Sonos devices from power. While they are unplugged, reboot your router. When the router comes back up, go ahead and plug back in your Sonos devices. 

Third, if neither of those work, system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.

Userlevel 6
Badge +3

Thanks Bruce for some good potential problem solving approaches.

However, I’ve been there done all of that and more - plus I’m working with top-tier engineers within Sonos.  They have admitted that there is indeed Application lag issues with S2 but not reported directly often so while they are aware it’s tied to the S2 application (all platforms/app versions), there are not enough data points (customer complaints/diagnostics submitted) to allow for a deep dive into what’s causing it.   Some blame may be placed on iOS 14.x.

To be clear I’m not asking about song/music/streaming lags to speakers, I’m asking about using the S2 app on your phones/pads/tablets/PCs.  When people OPEN their Sonos S2 app does it take 10-40 seconds to load/refresh?  Is it laggy when changing sources, volume levels? Do the graphics take time to load after the app has started?  

Again, this ONLY happened once S2 was download and installed on various platforms and Sonos is aware and have determined it’s NOT my system. 

We love our 17+ Sonos whole house audio system, but there are ongoing issues that cause a lot of annoyances and this is just one of them.

 

 

Badge

I’m experiencing the same thing as kassey22000

I dont have any issues streaming music nor operating the app from a PC.  My issue is just from the iPhone S2 app.  (Whatever OS is current on the iPhone as of 01/2021 - i know it just upgraded).
My issue appears limited to the iPhone app - and only within the last few months.  I have deleted the app and reloaded on the phone 3 times now - the latest just this morning and the issue remains.
It typically takes about a full minute+ for the app to load and sometimes it never loads at all.
No issue at all from multiple PC apps on the same network.  I may look into the diagnostics that Airgetiam recommended since reinstalling the app has had no effect.

 

It’s the best way to give any hard data to Sonos folks to look at, they’ve chosen not to expose much/all of that information to us users. Probably for privacy / legal reasons, especially in the EU sphere, but likely here in the US too. I don’t begrudge them the stance, but it does make it harder for us community members to speak with much authority, other than conceptually, since we can’t see the real data. 

Userlevel 6
Badge +3

Thanks Bruce,

Really this question is directed AT THE SONOS COMMUNITY - not support as you can probably tell from my postings. 

I’m asking if ANY other Sonos S2 users have experienced the Sonos applications reacting/launching/refreshing slowly compared to other iOS/Android apps and S1.

 

I do agree that it makes it tough when Sonos’ support has their hands tied with communicating broadly to the community. 

 

I am also experiencing this issue and have been unable to resolve it.
 

My network (Amplifi by Ubiquity) performs excellently in all other respects but I have done a full factory reset on all routers, mesh points and Sonos speakers but noticed no improvement. Airplay 2 picks up the speakers instantly but the Sonos app is often very slow. 
 

I too have tried all the steps in the FAQ with no success. 

Userlevel 1
Badge +1

Another thread about this problem.

Link.

 

Reply