Answered

Volume goes down on several devices

  • 27 December 2022
  • 10 replies
  • 4113 views

With no changes in the system for the last 2 years besides software updates, my beam and amp started to automatically lower the volume to a certain volume. 

All Voice and Touch controls are disabled. All devices were restarted and seem fine.

The beam does this with the tv input and audio streaming.

What can I do?

icon

Best answer by xponential 10 March 2023, 12:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

It might be the case you are unknowingly turning down the volume of devices with the hardware buttons on your mobile controller - goto the Sonos App ‘Settings/App Preferences’ and see if switching off ‘Hardware Volume Control’ helps to make the problem go away. Note too that different audio sources/codecs/recordings etc; can give out different volume levels aswell.

Hi Ken,

changes in Hardware Volume Control are not affecting the problem. I tried that already.

The Volume for the beam always goes down to 5 and the volume for the amp always goes down to 14. sometimes instantly, sometimes after a few minutes, but alway to the same value. The TV is already detached from the beam and there is no input connected to the amp.

Is this when playing music audio from the Sonos App, or are you playing from a different audio source? Can you describe the steps you take to reproduce the issue? It’s odd that sometimes the volume reduces instantly and then on other occasions, after a few minutes. 🤔

Mostly iOS-App, but also Mac-App. The source is always Apple Music or Audible.

 

I press play, adjust the volume (or the other way around), and volumes jumps back - instantly or later.

 

Other Sonos devices (Move, Ones) also self-adjust to always the same volume.

So is this the Sonos App with the built-in AM service, or the actual iOS Music ‘native’ App you are using? If it is the latter, can you confirm you are using Airplay2?

If you are using the Sonos App, it might be the case that your controller mobile device is having a problem with sonos ‘device’ discovery/communication and that some App controlling instructions are being delayed and sent through to the speakers not in a timely fashion.

As it’s Apple devices you have mentioned, I would first try switching off the following on your iOS device…

  1. Private WiFi address in the iOS network property settings. (See screenshot attached)
  2. WiFi calling
  3. Any VPN/Security/Firewall software running on the device.

Also, can you tell me if you are using a mesh-based WiFi system, or a central router? If it’s the latter, do you know what WiFi channels that are in use by the 2.4Ghz band?

And finally, are any of your Sonos products wired to the local network?

Sonos App, no Airplay2. The same problem for Sound from TV/AppleTV via HDMI-ARC.

Private WiFi address at no time was switched on

I tried with WIFI calling switched off → no difference

No VPN, security, etc is running.

Also no WIFI Mesh. I have (CAT7) wired unifi system with 4 APs with good coverage and very limited interference. Also no changes to the setup/configuration were made in the past 6 month. 

Channels 1, 6 and 11 in 2.4GHZ.

Only one device is wired at any time. I tried the amp and beam, but the problems remain the same.

 

 

As you’re using a Unifi setup, perhaps see if these steps may assist to resolve the matter…

  • From the Unifi Network Application interface, click on the Settings icon from the left side menu.
  • Click on the Network tab. 
  • Select the network Sonos is connected to. Click on the Default network name if there is more than one. 
  • Scroll down to Advance Configuration, and click on Manual.
  • Check IGMP Snooping and Multicast DNS. 
  • Click on Apply Changes and allow up to 3 minutes for the settings to update.

It was both checked. I unchecked it but the problem remains. 

It was both checked. I unchecked it but the problem remains. 

In that case when you next encounter the issues, it maybe best to submit a system diagnostic and note, or post, it’s reference back here and then contact/chat with the Sonos Support Staff via this LINK and see if they can perhaps discover what is causing the changing volume issue.

Installing Release Candidate Updates on the Main Unifi Switch solved the problem!