Unable to play song ‘song’ - the song is not encoded correctly. Issue since 15.2



Show first post

144 replies

Same story and I have seen this for months. At least half of all songs I try to play gives this error. It’s a real problem Sonos. You claim to support Apple Music, but not really.

Userlevel 7
Badge +18

Hi @spaceman_spiff 

I refer you to my earlier post:

Hi @The Etron 

Thank you for reporting the issue with TuneIn Podcasts - we were able to replicate the problem and are now investigating.

 

For everyone else, please note that there are multiple reasons for the “not encoded correctly” error occurring:

  • Apple Music used to (years ago) provide music tracks with Digital Rights Management (DRM), which results in Sonos being unable to play them. Re-downloading those specific tracks would be the only way to fix this. Other sources may have done the same.
  • Failed WiFi transmissions can also cause this error. Our support team can identify if/where this is happening and assist.
  • Actual errors in the files themselves can also cause this error - if this is the case, the same files will produce the error each time, and probably at the same point. Again, replacing the files will be the only way to resolve. Most likely to be seen with Music Library rather than with music services.

I recommend each of you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Edit: I should add that if there were an issue with our software rather than encoding/transmission issues, we would also need to you get in touch to have the issue documented and investigated.

My reply immediately before yours was in reference to @alfonsoluis’ report of seeing the encoding error with Amazon Music, therefore the most likely (but, technically, not only) explanation in that particular case is interference. In your case (looking at your even earlier posts), the most likely explanation is Digital Rights Management encrypting the contents of your older music files (for which, Sonos does not have the decryption key).

This thread relates to Apple Music/iTunes downloads in spirit, but technically it’s title shows it to be about the error message itself, so whether Amazon Music and TuneIn Podcasts are off-topic or not isn’t easy to say, but it is making the thread a little confusing, to be sure. So, please don’t be frustrated - I am not gaslighting you, I am just giving the best-chance-of-being-correct advice to particular people based on what they report. For you, the error would indeed be 100% reproduceable, and nothing to do with interference.

I hope this helps.

Not yet. I’ve only just started trying to look into it. I will do this and open a support ticket or whatever they have.

It is totally a Sonos S2 app issue. I bought Sonos because of it’s integration with Apple Music and my library of 16,000+ songs.  This needs to be addressed and fixed asap.
 I can play the “wrongly coded” songs air playing to the Sonos system speakers from Apple Music.  I can play them on Apple Music directly on my computer, iPad and phone. In my case, I first noticed this issue on a purchased album in my library from iTunes called B.J. Thomas the Living room sessions.  I purchased it maybe 5 years ago and It is no longer available thru Apple Music, so I don’t have the luxury of deleting it and re-downloading it again.  It is stored in iCloud.  It played fine on the S2 app previously, so somewhere along the line, one of the Sonos updates has screwed this up, or failed to address something that recently changed with Apple Music.  Apple Music still plays those songs thru my Apple Music app, and airplays them to Sonos speakers without an issue, but I want to use the Sonos S2 app as I did before.  
I wonder if there is a way to go back as many Sonos updates as possible to see if any of these wrongly encoded songs will play again.  

The title of this thread is “Unable to play song, the song is not encoded correctly since update 15.2”.  That is when I believe my issue popped up.  Some posters in this thread lumped in with an older DRM issue, which possibly also gave a “song doesn’t play because it is wrongly encoded” message, but this is a new issue.  The S2 app played all these now “wrongly encoded songs” perfectly from when I bought the system 2 years ago until fairly recently.  

Userlevel 2

I’ve found a work-around YMMV.
The ‘not encoded’ error occurs when sending to any Airplay-enabled speakers. In my case this is all my speakers other than a stereo pair of PLAY:3s.
Context: I have a stereo pair of PLAY:3s, 1 Move, and 2 SYMFONISK Bookshelf speakers
    1    Ungroup all speakers (I left the stereo PLAY:3s in stereo config)
    2    Source of music: My Library (iTunes catalogue)
    3    Send the music to any of the Airplay-enabled speakers, encoding error occurs
    4    Send the music to the PLAY:3s - success
    5    Add in one of the Airplay-enabled speakers, now the music plays to that/those speakers as well
    6    Drop the PLAY:3s, music keeps playing to the Airplay-enabled speakers
    7    Stop all music
    8    Try to play that same album, direct to an Airplay-enabled speaker - works
    9    Try to play another ‘My Library’ album directly to Airplay-enabled speaker, fails, back to step 4

Here is a quick video showing steps 2-6:

 

If I had to guess, the album that worked on step 8 was cached locally in a way that worked with all speakers.  Switching albums reset the cache and you are back to where you started.  What this does confirm, though, is the issue is likely on Sonos’ side, not Apple’s.  If you were able to play the album on a non-Airplay speaker, and even trick it into playing on an Airplay speaker after, then it’s something about how Sonos is interacting with the content, not Apple.

I wish there was a way to revert whatever update was sent to these speakers.

Really annoying this. Half the songs on my Apple Music playlists won't play due to this error.

I'm moving from Sonos, too many issues. Disappointed.

Here is my experience. I am on 15.5 and just experienced (or at least noticed) this issue. Got the improperly encoded issue today for the first time with songs in Apple Music. I even got the error with the songs when playing directly (not through a playlist). For example, any song on Adele’s 21 album gave the error. We normally use my wife’s Apple account to use her playlists, but I tried switching to my Apple account and the songs from 21 played fine. Then I switched back to my wife’s Apple account and the songs work. Not sure if that’s a solution for others but thought I’d share in case it helps someone else. 

I’m having a similar issue attempting to play podcasts from IHeartradio. This makes me think it’s not an apple issue, but an issue of some missing codecs in the latest version of Sonos’ updates.

Badge

Same issue but not with apple music, but with TuneIn Podcasts.

Here's how:

  1. In the Sonos app I search for: Nora Pure (new search method)
  2. I open recent shows and select: Nora En Pure - Purified Radio
  3. I click the three dots and add this to My Sonos.
  4. From this screen I can click on a podcast and it will start.

The above is fine, but there is an issue here:

  1. Kill and start the Sonos appication 
  2. In My Sonos I see my added podcast of Nora En Pure
  3. I open it and select the same postcast to start as before
  4. Here comes the error: Unable to play - the song is not encoded correctly.

If I do the search again, I can play the same podcast. This has been an issue for a long time.

I found a solution that seems to work.  As mentioned before, you can search in the Sonos app for the artist/album/song and play that way instead of going to your Library.  Or the fix I discovered consists of the following steps on my Mac.

Go into the Music app and:

1 - Right click on the artist or album and Remove Download

2 - Right click and Download again

3 - Find the artist/album folder in iTunes -> iTunes Media -> Music

4 - Copy the album folder somewhere else temporarily

5 - Back in the Music app, right click the artist/album and Delete from Library

6 - Go to File → Import to Re-import from the previously copied folder

7 - After it has synced with iCloud (will show down arrows for each song, may take several minutes) test in Sonos to see if it plays now

8 - Delete the copied album folder

 

Hope this helps!

Userlevel 2
Badge +3

Well, 15.4 didn’t resolve the issue.  I used airplay to stream a playlist to one of my zones, and it worked fine. I then opened the Sonos app and chose the same zone, and it showed the music I was playing through airplay. When I went from song to song through the Sonos app, it was fine as it recognized every song. It’s only when I choose the playlist in the Sonos app that I get the encoding error and it starts skipping songs.  But any of the songs skipped due to an encoding issue can be played through the Sonos app by going to the album or just the song.  Very odd.   

Userlevel 2
Badge +2

Happening to me as well. Apple Music playlist initiated from the Sonos App. I find numerous songs skipped for the reported “encoding error”. 
 

Sonos can’t figure this out and provide a fix? Disappointing. 
 

Edit: Starting the playlist from Apple Music and Airplaying to the Sonos speaker appears to overcome the problem- at least with the one song I’ve tried this far. I hope Sonos isn’t satisfied with this as a solution. 

They have no intention of solving this IMO. 

Userlevel 5
Badge +6

Still a problem with 15.3

It’s very frustrating. It’s a problem with music I’ve bought on iTunes because it’s not on Apple Music - and doesn’t play in Apple Music as Lossless…. (another frustration for another day).

This is not just an apple issue. I'm experiencing the same exact issue using Tidal on a Note 20. Really disappointed I gave Sonos all this money and I can't even listen to my music. 

Userlevel 2
Badge +3

After emailing the CEO, I was contacted by an L3 Engineer.   He said it started with 15.2 but is telling me that it’s a network issue and it a problem with the group I initially started with.  Of course, it’s not a zone grouping issue and it’s not a network issue - I have a solid Orbi network that hasn’t been changed in years and I have a Sonos Boost.  I think they have no idea how to fix the issue.  Seriously, I may order the Nakamichi Dragon and find another way to listen to my music in different rooms. 

Any talk of networks is BS. I’m a network engineer and my home network is all Ubiquiti hardware with most Sonos devices hardwired. I’ve got a range of Sonos, old and new. The workaround of adding an older non-airplay Sonos into the group works 100% consistently for me (in my case it’s an old connect). There is no way it can be network. I have literally tested everything in depth on my network. Music source is Apple Music btw.

All of a sudden this week , the Radio Station (Talk Radio) started sending error messages Music not encoded properly. Unable to listen to the radio. Radio station is WSB 95 in Atlanta, 97.5. What happened? 

I don’t quite understand the delete from your library and redownload fix. With iTunes Match in the Cloud, I rarely have these songs locally at all. Like on my iPhone, I have very few of the Beatles songs downloaded. Some of them play fine on Sonos from a playlist I created, but some have the encoding error. I can even start playing from the Sonos app on my Android phone or Mac or ChromeBook and have the same problem and none of them have these songs downloaded. Am I misunderstanding something?

It’s not a delete / re-download. It’s a delete from your library and re-add to your library. And have fun doing that on all your albums. 

I updated to version 15.5 a day ago (06-22-2023) and I am am the same issues with encoded issues. Hopefully this is corrected soon. Wondering if there is a way to down grade to previous versions to avoid the error's message?

Userlevel 1
Badge

I have much the same problem. I use Apple Music but also have albums that I have purchased from apple over the years in my library and also CD’s that I own that I have put in my library. Many of these songs, but not all, have this issue. I have entire albums that will not play and others bought and downloaded on the same day that will play. Some of the purchased albums part play, with certain random tracks ignored by the Sonos app with others on the album playing fine.  My system is a mixture of early speakers (Play 1’s and 3’s) and newer stuff, Sonos Ones, One SL’s, a roam and 5’s that are all air play compatible.  Here’s the thing; all the problems are with playing stuff on my newer speakers. The songs that will not play on the newer speakers all play directly from the Sonos app to the Play1 and 3’s! I can even start these songs off on a Play 3 and then use the Sonos app to group the Play 3 with the newer air play speakers and they then play fine.  I note from this and other forums that numerous different streaming services are also affected. This surely must then point to a problem with the software trying to play the music, i.e. the Sonos app?  As for contacting Sonos support, I will but I know from previous contact they are unhelpful and lacking any real technical grasp of the issue.

Have you rebooted both your speaker and router? What service are you using to reach this station? 

I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.

Userlevel 4
Badge +2

I have Play 3 and I just have my library of MP3s on OneDrive. Only a handful of songs work. Has there been any overall update on this?

Sonos has never been able to play music stored on the OneDrive cloud system. 

Reply