Question

Unable to download update, unable to login as “owner”


Userlevel 2


Unable to login as the system owner. I’ve had the same devices on the same internet, under the same profile, for four years.


79 replies

I just got my first sonos product (a beam 2) and thought it was because it was refurbished and linked to another account before. Glad I’m not crazy and just have terrible timing with setup.

Same problem, what is going on? 

I have the same problem 😰

Same here, messy this update and seems to have knocked me off all my devices

Same here. I’m currently in a long wait to customer support 

Userlevel 1
Badge

Hi

 

Same issue here !!

  • Verified account and devices - Only have this one account since 2011
  • Even tried shutting off all Sonos Devices (12), took one device and did a reset to setup as new system - Same issue
  • Before updating to the new App, verified all Devices was updated
    • After New App, verified again if any update was available
    • All up to date - and then
  • Unable to use the Sonos System

It´s quite here !!!

Userlevel 1
Badge

Hi again

 

Managed to get around this, uninstalled the App (iPad) and then the cached Data gets deleted to - Reinstall and connected again

Wondering this might be an issue when having multiple Systems under one Account - Guess some Sonos users do have this, eg when having a Cottage, remote Garage or whatever reason. Having 1 account for all System and the option to choose between the Systems is a must - Know this has been a thing in a long time - Even having more than one System on the same Network, SSID and thereby vLAN.

Apart from that, nice and snappy layout for the new App - Still not found the option to add a Spotify played number to a Spotify Playlist - Used it a lot since I go Spotify-Radio from a number and then wauw thats a good one; add it to Spotify Playlist.

Having the option to create individual “Quick Tasks” would be a mighty great feature ;-)

Best regards, Christian

Hi again

 

Managed to get around this, uninstalled the App (iPad) and then the cached Data gets deleted to - Reinstall and connected again…

Best regards, Christian


I had to uninstall the app and factory reset my Sonos Roam and only then could I get it all to work.

Now I want to install Alexa, but I have to confirm my COUNTRY in my profile, WTF, how do I do that, as I already have my full address and country on my user profile?! 
 

Sonos just pissed people off with this unpolished and featureless new app and having owned 5 of their speakers, I am NOT going through this pain again!

Same s*** here, just both Sub to my arc, afterwards update, stuck at this, couldn’t connect it back after reinstall and resetting all the devices, when it looked promising again a I got the System update message … Sonos you really making life difficult - translate it in very p***ed language.

 

Recommend it to anyone ? never ever … enough to have issues all the time with it, once set don’t update don’t buy new stuff nothing …

 

Moderator Note: Modified in accordance with the Community Code of Conduct. 

I just bought 2 new Sonos Fives and spent an hour trying to get through this same issue. Pretty frustrating spend of $1000 on a pair of speakers and can’t even hear them because of the app.

 

I managed to add one speaker to the system and but it doesn’t show on the system. Then it says I need to update and the first time the update failed and now I just get this same “sign in as the system owner” message EVEN THOUGH I AM SIGNED IN.

 

I’ve tried reinstalling the app and factory resetting the speaker with no luck.. Anyone figure out a fix?

Guys some good news it looks as only ios app is broken over samsung phone i was able to add all of my sonos stuff to app. Then I have opened the ios app and Joined existing Sonos system and now it working again

I was able to install the update still using the macOS app.

Same issue. Had to factory reset to connect to my new wifi network, then ran into this issue. Device is now essentially bricked, even ARC is not working now.

This totally sucks. I just bought these and likely taking them back. I have same exact issue and cannot resolve. 

 

Userlevel 1

Does anyone have any other suggestions? I tried uninstalling app and factory reset and still bought in the loop. 

Spent an hour and a half with a live chat rep with no success. Tried uninstalling and reinstalling the app, logging in and out, factory resetting the device, using different ios devices (no android) in various sequences. Nothing worked.

Userlevel 1

I am having the same issue. I have updated my profile, verifying that I am the owner of the system, but the new app does not recognize me as the owner and I’m frozen out of the system. I was in the process of factory-resetting the Amp, the Move and the Ones, when Sonos wouldn't let me continue as the owner.

I actually have two systems, one for a small house in the states and one in Costa Rica, one with two Roams and a Beam, and one with an Amp, one Move and three Ones. However, Sonos only recognizes one system, with all of them bunched together as one. Ugh. The old app worked so well; this one is causing me nothing but hell.  

Userlevel 1

Not that it’s a solution, but I’m just glad it’s not me!! Tired of banging my head against the wall!!! Sonos better come up with a solution before they loose me and more customers. 

Userlevel 7
Badge +4

All this (justified) frustration...just remember folks, if Sonos was sorry about this, then 1) they would have apologised and 2) they’d have rolled the app back.

 

They haven’t done either.

Had the same issue setting up the beam 2, what fixed the issue was disconnecting it from the HDMI, factory resetting the soundbar, deleting the sonos app, redownloading it and starting from 0 again. And plugging the HDMI back in only AFTER I finished setting it up.

Badge

Hi all, 

 

I am having the same problem. Just bought recently the Move 2 and now I can’t listen to music. Not happy that I spent £449 for a device that is not working. It started when I went to play music through Spotify last Friday (10th May) and it wasn’t showing up the speaker, after turning of and on multiple times.

Decided to factory reset it. again multiple times, spent more then 1h trying to connect, but again nothing happened. I would reset to factory and I got always the same message: “Move 2 has been added, but may not appear in the System tab. Turn it off ...” 

Turn it off, again, nothing. In the system setting it would say that my system not found. Try to set up new system nothing happen. Reset my wifi, nothing. 

I then got the prompt to do the Software Update, which it would encounter to another error message saying I am not the owner after logging in. This becomes of a loop without an end, repeating the same process, over and over again.

In conclusion, I have a brand new speaker collecting dust with no use if @Sonos doesn’t fix it. Attached are the screenshots to show the current journey and the loop. 

 

 

 

Userlevel 1

It’s clear we share the same problems with the app and the system...Sonos has been so good in the past…odd that they are letting this happen..Has anyone actually spoken to SONOS? Is there a real solution? I am going to delete the app and redownload it, but I have no optimism that that will work. 

Userlevel 1

I tried calling and chatting but there was no one available to chat and no one available to call. I tried several times within the hours that they were supposed to be available. I hope they fix it soon what a hassle. 

This seems to be happening to people at the same time this is absolutely pissing me off tbh! I can’t return mines as my warranty has ran out! 
 

has anyone found a way round this 

Do you think it’s a bug? Whatever it is if enough of us complain on X twitter or whatever term you like best complain to Patrick spence he will have to sort it 

Same issue here. Glad I’m not going mad. 

Reply