Question

TV Setup issue


Since the app released, my playbar tv setup will not work. It no longer can see the connection to my tv via the optical cable. I have factory reset my playbar numerous times and nothing works. Also, my gen 2 sub continuously disappears which requires factory resetting it and the playbar only for it to disappear again a couple days later.

Please fix this broken application or roll it back to the stable app. I work in software development and your level of testing before release of the new app failed miserably. Roll it back or look forward to consumer action and significant loss of customers moving forward!


11 replies

Just noting this has also happened to me, the only variable being the new app.

Don’t factor reset your playbar.  That rarely fixes any issues and removes in logs that could be useful to fixing the issue.

Are you able to stream audio to your playbar at all?  Perhaps it’s obvious, but in the Sonos app, is your playbar set to play audio from the TV source and not from a streaming source?  Also, the TV is set to send audio through the optical output?

I cannot comment to the other users experience but I have not changed anything. All settings are identical, the playbar simply does not play tv audio even if tv is selected as the source.

Don’t factor reset your playbar.  That rarely fixes any issues and removes in logs that could be useful to fixing the issue.

Are you able to stream audio to your playbar at all?  Perhaps it’s obvious, but in the Sonos app, is your playbar set to play audio from the TV source and not from a streaming source?  Also, the TV is set to send audio through the optical output?

I am able to get tv audio through my playbar as this setup has been setup for about a year. If you look in the app there is a step called TV Setup that I was trying to redo post reset (I can’t remember what exact functionality this provides) but when I try that step post app upgrade it does not see the optical connection.

 

it appears Sonos did another update on the new app 2 days ago and it made my gen 2 sub disappear again like when the new app came out. The only way I have been able to get the sub working again was to reset both playbar and sub and then add them again. I did not want to factory reset but that had been the only way I have been able to get the app to see they exist!

Same issue I had no choice but to update then lost playbar with optical connection to TV.  Touched nothing. 

Playbar issue, optical not recognized but audio works🤷‍♂️ have reset the playbar multiple times have other playbars x3 and all work fine. Audio streaming (Spotify not working on playbar ) works on all other units. This all started with the new app, at a loss here 

Userlevel 1

I have the same issue with an older Samsung TV using an optical cable to a playbar.   I called technical support and after working with them for about an hour, they said I needed to call Samsung as it was an issue with the TV. 

 

it worked fine for the last six years until the new app was released 

I also purchased an inexpensive sound bar from Amazon. Connected it with the optical cable and ot played fine. 
 

the issue is with the soundbar and SONOS program.  I am very disappointed in what is happening. 
 

any suggestions on what else to try ? 
 

 

Same issue. App updated.  TV audio no longer works. The playbar will only play music. 
 

8 years not one issue until now. 
 

 

Same as everyone one else since the update the rest of the speakers won’t work with my sound bar when watching tv , I plugged the hdmi cable into my beam and I can get  all with  working sound  with the tv that way , strangely I can play music from  any app on all speakers not a problem , I’m sure if you play films or tv using your phone and connecting to airplay via tv and speakers that will also work , admittedly only if you have an airplay tv and airplay speakers ect , I was in love with Sonos until now , I also have spent a fortune on them over the last 5 years , I’m sure they have covered themselves legally but I would be interested how the consumer act would work for us all , my speakers are also all hard wired Ethernet cables and still got the same issues 

New app and I still can’t get get my tv set up again roll it back plz

I had my technical people look at this issue. They confirm the above and are as frustrated that Sonos has not, as yet, taken the lead to repair the problems with their upgraded application 

Reply