Trouble Connecting to SiriusXM

  • 27 December 2019
  • 17 replies

For the past few days I cannot reliably connect to SiriusXM on any of the apps (Phone, iPad, Mac desktop).  When I browse for SiriusXM channels I get messages like “unable to connect..” and sometimes “unable to play.. not encoded correctly” or “digital rights management … encoding not supported”.   On a couple of occasions the music will start and play for a few seconds, then the “connection lost” message will appear.


I have rebooted the Network and killed/restarted the Apps. I have also removed and then re-added the SiriusXM account to my Sonos - none of these have fixed the problem.


I checked the on-line Sonos status - and that shows that SirisuXM is up and running with no problems.


I don’t have any problem playing SiriusXM from their native App on my phone - so this problem appears to be limited to Sonos.


Any advice?


Best answer by Jeff S 27 December 2019, 00:21

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

Userlevel 7
Badge +20

@Nmiller001 Hi there, we’re currently investigating an issue with SiriusXM on Sonos. You can keep an eye on our status page for updates.

@Nmiller001 Hi there, we’re currently investigating an issue with SiriusXM on Sonos. You can keep an eye on our status page for updates.


Jeff, the status page indicates Sirius XM is operational, however, this issue still persists. Any solution forthcoming?

I am having this exact issue right now while the status page say operational.  I can verify login to XM in settings, but get this message with any XM channel

Crazy wasn’t working for about an hour and when I went to recreate the issue for diagnosis it worked.  Sent diag anyway in case it did capture the issue.   

Same problem.   Cant submit a Diag Report, it keeps failing part way through. 

Failing to submit a diagnostic suggests an issue with your speakers being able to reach the Sonos severs, where the data is logged, and could certainly be an indication of why you’re having issues connecting to SiriusXM.

The first thing I’d suggest is a simple reboot of your router, followed by a reboot of the speakers. If that didn’t clear either issue, I’d be looking at any firewall or virus protection programs that might be blocking the connection.

Turned off 5ghz on the ISPs router, changed 2.4ghz channel to 6 from auto, set Sonos to channel 1, seems to have solved the problem. 

It seems like this issue has popped up again even though the status page seems to not reflect that. Continually getting a message about digital rights management when connecting to siriusXM from the Sonos app on MacOS

This is a problem again for me too, playing from an Android phone.

I am having the same problem today.

Userlevel 5
Badge +14

Hi @DavidGerontion.

Welcome, thank you for reaching out to Sonos Community, We appreciate your time and effort in posting your concern here in our community.

Since there's no posted outage so far for Sirius XM under

I’d be tempted to do a network refresh, by unplugging all Sonos devices, then rebooting the router. When the router comes back up, plug back in the Sonos devices wait for 1-2 minutes, and test it again

Let us know if it works. If you need help with any other information, please be sure to let us know.

I did exactly that and everything (including SiriusXM)is working again. Thanks!

Userlevel 5
Badge +14

Hi @DavidGerontion.

Thank you for reaching out to Sonos Community.

Glad it's already working with you.

You can also check our site for a known outage with music service.

If you need help with any other information, please be sure to let us know.

Ever since I decided to subscribe to your Sonos HD Radio service, which I’ve now cancelled, I have issue after issue with your system and SiriusXM and a reputed DRM issue.  I’ve now decided that issue and message are bogus.  I fought this for about week and finally removed and reset all of my speakers and then re-added SiriusXM, which is my “goto” music service.  It worked OK for a week and a half and this morning I’m back to “can’t connect to SiriusXM service with unsupported DRM system.”  SiriusXM connection works fine direct with the same credentials Sonos now rejects.  Likewise WQXR and my personal music library work just fine with Sonos, just not SXM.  I can come to no other conclusion than some update you’ve issued to your Sonos system is interrupting the SXM.  It’s just mental to reset Sonos again.  It work fine with all except SiriusXM.  

You need to come up with a solution to this quickly before I abandon Sonos in search of some reliable system.  It’s a separate issue, but your HD Classical offerings are just not as advertised.  Your Full Symphonies, are just not that at all, just snippets.  All yo’re doing is pushing junk as a diamond.  That’s why I cancelled.  


[Moderator edit - removed some inappropriate language]

Userlevel 6
Badge +15

Hi @srqrob, welcome to the Sonos Community!

Given that you’ve gone through the basic troubleshooting as well with no improvement, I’d recommend reaching out to the Support Team via live chat or phone call, so that they can take a closer look at what is occurring and possibly try a test account.

It sounds like this may be an account issue on SiriusXM’s side, however the support team should be able to get a better idea of what is going on with some troubleshooting and checking with a test account.

Regarding the Sonos Radio HD selections, I’ll be happy to pass this on to the team :)

I just don’t see any logic in suggesting this is a SiriusXM connection issue when I can connect flawlessly to this service in both my car and direct connection from my computer with credentials that you reject are flawed.  Credentials work everywhere else.

Userlevel 6
Badge +15

I understand it’s a bit counter-intuitive, however when you provide those credentials via Sonos, it is SiriusXM that validates or rejects them, as Sonos has no knowledge of your SiriusXM account credentials. Sonos will also be taking a different path in connecting to SiriusXMs servers than your computer or car are, so it’s not unheard of for credentials to work with one system, but flag an erroneous error with another. 

As mentioned, I’d encourage you to reach out to the Support Team so they can do some further investigation, and if needed pass your account details on to SiriusXM to check on their side.

Hope this helps :)