Synology DS218play as music library Error 900

  • 23 September 2020
  • 5 replies

I am not tech but have read some of the threads regarding problems setting up a Synology as the music library and have changed the lowest level of SMB to SMB1.  My Sonos controller is on a Mac and I’m using the file path //nameofsynology/shared/music.  This doesn’t work - get the error message “unable to add the shared folder //xxxx/xxx/xxx to your music library (900)”.  I’ve tried all combinations of file path.  I don’t input a server name and password because I don’t think I have to??  My previous Synology NAS worked fine (until it died).  I’ve updated Sonos to S2 (have removed an incompatible Bridge in the process).  What else can I do????  I’m just an average computer user, don’t understand most of it!  Help please..


Best answer by John B 17 October 2020, 11:45

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Can you browse to the directory OK? Have you tried using the IP address rather than a name?

I share amun’s thought process, and have an additional question. Does the name of your Synology contain anything beyond simple alphanumeric characters? Things such as hyphens, slashes, commas etc can sometimes cause issues. 

I too am having the same issue:

Ive tried using the name (no hyphens, slashes - just letters)  //drivename/music and the IP // and both return that same 900 error

I’ve set up a specific user name and password and made sure it has access to read the folder

I’ve checked the firewall setting is not enabled

SMB is enabled

I am using a MAc and am able to upload / download files to the drive no problem. 

I am using the S1 version of the app on Anddroid.

Any other suggestions?

I use the standard shared music folder on my Synology.  The path it answers to is //DISKSTATION/music.  Worth a try?

Note: I use a Windows PC and in Explorer the Synology appears under the name ‘DiskStation’.

You say SMB is enabled but you don’t say specifically SMB v1, which is necessary, despite some security concerns.

Okay thanks - I didn’t notice the “Advanced” button in the SMB section and there are options so I set them all to SMB1 and looks like that did the trick. Much appreciated.