Answered

speakers keep disappearing and coming back

  • 11 September 2023
  • 30 replies
  • 2170 views

Userlevel 1
Badge

When I open the app on my iPhone sometimes it only shows one of my roams saying the other is powered off.  But it doesn’t show the other speakers, arc. woofer, 2 rear and 2 move.  Sometimes they’re there, sometimes not. I spent over an hour on chatting the other day, so long that my phone needed charging. It was working but a few hours later it isn’t. The tech wastes your time plugging and unplugging and reregistering and other nonsense.  But a day later the problem is back. The speakers come and go.  I can play music on the Roku tv which uses the arc, sub and back speakers but on the phone they’re not there.  It is getting to the point where I have to admit that I wasted almost 3 thousand dollars on a system that is unreliable and sonos can’t fix it.  Unplugging some of the speakers, which the tech makes you do, are behind heavy couches. I’m and old man and its hard to move these big heavy couches and harder still to get the plugs back in. Used to love the system but now it sucks . The trouble seems to have started when I bought my second roam. Very frustrating and I can’t  really afford to replace the whole system...

icon

Best answer by Brenda3456 13 September 2023, 09:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

I had a similar problem, where one of my speakers would randomly disappear on my iPhone. this would happen only on my iPhone, never on my iPad or Mac. Turning off “Private Wi-Fi Address” in the iPhone’s WiFi settings resolved the problem for me.

I’m having the same problem. i”ve been using Sonos for many years and never had a problem. Now, almost daily I’ll lose entire “rooms”. As with the John, they just seemto come and go. I haven’t changed anything with my wifi setup.

Userlevel 1
Badge

I think I’ve submitted 2 diagnostics to SONOS.  Currently it’s working.  Seems to be more reliable with the iPad.  I’ll keep you informed. Thanks.

Userlevel 1
Badge

Still iffy. Sometimes both iPad and iPhone show all the speakers, sometimes one, sometimes none. It seems that its either all the speakers or just the roams.  But maybe sometimes the arc+ and moves are visible without the roam. But usually if anything is missing its the move and arc stuff (arc plus rear speakers and one woofer.  I can’t say for sure but I don’t think I had all these problems before I bought the roams, which I got one at a time.  Maybe they’re the problem and I should just put them away and go back to carrying the moves outside, but they’re pretty heavy.

I think there’s a problem with the sonos app.  All my devices are set to automatically update whenever there is an update.  Sonos needs to figure this out and send out an update.  Techs always want you do a bunch of stuff that you’ve probably just done and didn’t work. Yes we restart our devices. I don’t unplug the back speakers and woofer unless I have to since I don’t enjoy moving heavy couches around.  And in my experience there is never a time when the arc is missing and the rear speakers and woofer are not also missing and vice versa so I don’t see how unplugging them helps, but I’ve done it at the instruction of the tech more than once. Same with the Move speakers. Either both are there or neither. The roams were sometimes only showing one but I figured out that the wireless charger wasn’t working and replaced it with the original plug that came with it.

The wireless charger is a joke, don’t waste your money, no advantage. Placing the roam on the base is not easy, putting the wrong end down is easy to do (especially for my wife) and plugging them in is not hard. 

I figure I’ve got about $3,000 invested in these speakers. They should work flawlessly.

Userlevel 1
Badge

Today I had all the speakers showing in the app. Later only the roams.  At some point listening to the roams my iPhone lost control of the speakers and I couldn’t pause or control the volume. Right now the app only shows the roams. I think sonos has problems. Fix it or I’ll need a refund.  

Userlevel 1
Badge

I discovered today that the wireless charger I bought from Sonos stopped charging.  Using the wired charger fixed the problem.  Do not waste money on the wireless charger. 

I had a similar problem, where one of my speakers would randomly disappear on my iPhone. this would happen only on my iPhone, never on my iPad or Mac. Turning off “Private Wi-Fi Address” in the iPhone’s WiFi settings resolved the problem for me.

This seems to solve the problem. I have both android and iOS devices, in my iOS, speakers seems to randomly disappear. Tried turning on off the WiFi on device, turning on off the device, but problem persisted. When I turn off the Private WiFi Address on settings, automatically all devices appeared. 

Userlevel 7
Badge +22

Really it isn’t rocket science, if you can log into your router you can do it with a few clicks.

On the other hand it is a good reason to invite a grandkid over for cookies and computer support.

Userlevel 7
Badge +15

Hi @etgeary,

I’m having the same problem. i”ve been using Sonos for many years and never had a problem. Now, almost daily I’ll lose entire “rooms”. As with the John, they just seemto come and go. I haven’t changed anything with my wifi setup.

Even if you haven’t changed anything in your network, it is still possible for changes, such as controller or router updates, to introduce new issues or bring forward unseen issues that were previously there.

As mentioned with @johnrf4321, the most common cause of rooms vanishing and re-appearing in the Sonos app is that the controller being used isn’t seeing the speakers. This could be caused be a lot of issues, such as being on a different access point, subnet, the controller swapping to 4G, or even wireless interference.

I recommend you submit a diagnostics when the speakers vanish from the app then reach out to our support team for further assistance on this issue.

 

I recently switched internet providers from Astounde to T Mobile. The problems predate the switch.  I tried my iPad ear and all the speakers were there. But they all show on the phone sometimes.  Most of the rest of your stuff I don’t understand. 

I would think that since the iPad can see all the speakers but the iPhone can’t, would mean the problem lies with the iPhone. Make sure your iPhone is running the latest iOS, the Sonos app is up to date, and make sure the Sonos app permissions are set correctly in your iPhone settings.

If you follow those steps and still have issues, then please reach out to our support team for further assistance.

Userlevel 1
Badge

I sent them during a chat with support at the request of the support agent.  

 

Userlevel 7
Badge +22

Ubiquity gear and Sonos need a bit of care to work well together.

How to configure your UniFi network for Sonos

https://github.com/IngmarStein/unifi-sonos-doc

Thanks for the post, I already setup everything properly years ago. Also the issue started to happen recently, the night after writing my post the group of speaker came back and it still here...

John, are the speakers/rooms still missing if your IPhone is close to your router? Since the last update, rooms go missing if I’m father away from my router even though my wifi coverage is decent, but not great. about 110 Mbps. 

Userlevel 1
Badge

Doesn’t matter how close.  No difference.  

Userlevel 1
Badge

I recently switched internet providers from Astounde to T Mobile. The problems predate the switch.  I tried my iPad ear and all the speakers were there. But they all show on the phone sometimes.  Most of the rest of your stuff I don’t understand. 

I have the same issue now for several days out of nowhere. All devices had been fine for years. This is not a phone or ipad issue. I checked also with the PC app and its the same. The speakers themselves cannot connect to the network or something and flash white lights constantly. Rebooted everything, all speakers powered down/up, router rebooted, phone rebooted same problem exists. Something in my opinion changed at Sonos.

Submitting does nothing unless you call Sonos Support directly to discuss it. Read the thread Diagnostics - How do they work?

Wasn’t clear from your post, glad someone was looking at them. 

I am having the same issue with my arc since a month now... Already have a fix ip, no idea how to solve that

 

 You can try restarting your phone and Sonos speakers. Force close the Sonos app and then reopen it.

Fixed IP for the router, or reserved IP for the Arc? There is a difference.

You may be best off if you were to submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it. While it’s often a duplicate IP address, it certainly isn’t always the case.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

On my router I set the IP of the Sonos manually based on their Mac address.

Also, neither my iphone or my pixel can see the arc (and the 5.1 related speakers) but home assistant is still able to control them…

It keeps happening and the solution is to reboot the whole 5.1 speakers... This never happened before, it started a month ago.

My network setup is pretty simple, I have a udm se and a thew AP u6-lr. All the speakers are on my main wifi where is my phone.

Userlevel 7
Badge +22

I fought similar Sonos issues and resisted the Community suggested solution for far too long. Since it only took a few minutes I finally gave in to frustration and tried it. Fixed my missing Sonos and several other issues and they have stayed fixed.

Go to your router’s DHCP page, set static/reserved IP addresses for your Sonos. Power them all down, reboot the router and controllers, power up the Sonos. Even if it doesn’t work you have at least eliminated one possibility.

I also solved my Sonos plugging/unplugging issues with a few of these. There are several sellers/options available, pick the best deal.

https://www.amazon.com/gp/product/B07KFMNJLH/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&th=1

Perhaps you could  submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

 

Userlevel 1
Badge

Yesterday I used different sonos speakers during the day using either iPhone XS or iPad.  Phone was iffy. IPad worked consistently.