Answered

speakers keep disappearing and coming back

  • 11 September 2023
  • 30 replies
  • 2771 views

Userlevel 1
Badge

When I open the app on my iPhone sometimes it only shows one of my roams saying the other is powered off.  But it doesn’t show the other speakers, arc. woofer, 2 rear and 2 move.  Sometimes they’re there, sometimes not. I spent over an hour on chatting the other day, so long that my phone needed charging. It was working but a few hours later it isn’t. The tech wastes your time plugging and unplugging and reregistering and other nonsense.  But a day later the problem is back. The speakers come and go.  I can play music on the Roku tv which uses the arc, sub and back speakers but on the phone they’re not there.  It is getting to the point where I have to admit that I wasted almost 3 thousand dollars on a system that is unreliable and sonos can’t fix it.  Unplugging some of the speakers, which the tech makes you do, are behind heavy couches. I’m and old man and its hard to move these big heavy couches and harder still to get the plugs back in. Used to love the system but now it sucks . The trouble seems to have started when I bought my second roam. Very frustrating and I can’t  really afford to replace the whole system...

icon

Best answer by Brenda3456 13 September 2023, 09:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 7
Badge +22

Ubiquity gear and Sonos need a bit of care to work well together.

How to configure your UniFi network for Sonos

https://github.com/IngmarStein/unifi-sonos-doc

Thanks for the post, I already setup everything properly years ago. Also the issue started to happen recently, the night after writing my post the group of speaker came back and it still here...

I had a similar problem, where one of my speakers would randomly disappear on my iPhone. this would happen only on my iPhone, never on my iPad or Mac. Turning off “Private Wi-Fi Address” in the iPhone’s WiFi settings resolved the problem for me.

This seems to solve the problem. I have both android and iOS devices, in my iOS, speakers seems to randomly disappear. Tried turning on off the WiFi on device, turning on off the device, but problem persisted. When I turn off the Private WiFi Address on settings, automatically all devices appeared. 

I have the same issue now for several days out of nowhere. All devices had been fine for years. This is not a phone or ipad issue. I checked also with the PC app and its the same. The speakers themselves cannot connect to the network or something and flash white lights constantly. Rebooted everything, all speakers powered down/up, router rebooted, phone rebooted same problem exists. Something in my opinion changed at Sonos.

Were your Sonos speakers powered down while you rebooted your router?

Have you submitted a system diagnostic within 10 minutes of experiencing this problem, and called Sonos Support to discuss it?