Answered

Sonos was unable to add the music folder. Reason: Unable to add the shared folder "\\COMPUTER\Music" to your music library (1002).

  • 27 January 2024
  • 8 replies
  • 4047 views

Userlevel 2

I have been getting this message when I add music locations on folders that have say 100+ or more albums in it.  I do not get the error when I link file paths that are smaller (less than 100 folders/albums) so i don’t think its any find of firewall issue.  All the music files are on a secondary internal hard drive (not on the main ‘C’ drive).  Seems like some kind of timeout issue

I am using the S2 app on a Windows 11 machine and have a variety of speakers connected (Era 100, Play1, Sonos One). 

icon

Best answer by Ken_Griffiths 27 January 2024, 21:22

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

See if this link (albeit the example given refers to windows 10) may help to resolve the issue…

https://support.sonos.com/en-us/article/configure-windows-10-network-and-security-settings

 

Userlevel 2

Thanks for the reply.  I tried the steps in that article but does not work.  All sonos apps are checked as both private and public to pass through the firewall. 

Thanks for the reply.  I tried the steps in that article but does not work.  All sonos apps are checked as both private and public to pass through the firewall. 

Is the computers network connection set to Private though, that’s the important bit?
(Note Windows does default to ‘Public’).

 

Userlevel 2

Under “Firewall & Network Protection”  I have the following:

Domain Network - Green checkmark and firewall is on
Private Network - Green checkmark and shown as active in parenthesis
Public Network - Green checkmark and firewall is on

I also checked under Control Panel \ Network and Internet \ Network and Sharing Center
-For active networks, it is saying it is a “Private Network”.

Is there any other locations to check?

I still think it is strange that it does not have trouble if I only link less than 100 folders at a time.  Seems to just be with the larger subfolders (over 100+ folders/albums).

It’s the current wired or wireless network profile connection you just need to check… see if this link will perhaps assist you…

https://thedroidguy.com/change-windows-11-network-1159766

Just to say too that the Sonos app can support up-to 65,000 tracks in the local shared library. It does not sound like you’re anywhere near that limit with your shared library, but it should add the library path in any event, but may not index the library if there are any limits exceeded. In your case it might be the path to the library - maybe try not using the computers netbios name, but use its IP address instead. If that works you can then add/fix the computers IP address in either the local network adapter settings or/and the routers DHCP reservation table. The latter is recommended, rather than changing the local PC adapter ‘dynamic’ settings.

So (just as a fictitious example) the shared library path will change from something like this…

//My Computer/Music Library Share

to something like this…

//192.168.0.72/Music Library Share

 

Userlevel 2

So when I add folder locations through the desktop S2 app,  When browsing, I select my internal spare harddrive (Q:\Music\Rock in this case) It contains 22,553 Files/tracks and 1,535 Folders so it shouldn't be a issue.  I tried to paste the ip address as you mentioned above but the “next” button becomes grayed out.  How do i tell the app to show the ip address of this PC vs letter drive? 

I will also add that as a test, I added just one album folder, about 10 tracks to this same location and it worked fine.

Userlevel 7
Badge +22

You want to use the shared name of the host and the shared path there to your music share.

In my case the name is //pi-server/music  or if by IP 172.16.0.30/music

Note that the share path is not the same as the path on the host.

in my case the host’s path is  /mnt/ssd-music   

This is configured in your smb.conf [the smb configuration file.

My config looks like this:

[music]                                                                                 
Comment = Pi shared folder                                                              
Path = /mnt/ssd-music   

 

If this isn’t working send a diagnostic after trying it again and call Sonos Support who can see your hidden internal data.