Sonos steals my music when I'm on the road


Badge +1
  • Trending Lyricist I
  • 28 replies

I play Spotify from my iPhone 14 on my Sonos 5 and ERA 100 at home.  Then I leave and play Spotify through a bluetooth headset (Sena 30K0 on my motorcycle.  I’m happily riding along and the tunes stop.  When I can check the phone, I find that Spotify has switched to Sonos.  I switch back, but a few minutes later it happens again.

 

I’ve made sure I have the latest update of the Sonos and Spotify apps, closed the apps, and powered off the phone, but it still happens.  Any idea what is going on and how I can stop it?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

66 replies

Badge +1

If you want to waste that time and effort every time you leave (or might leave) your house in order to avoid a problem that shouldn’t exist, then good for you.  I’m sure you and your phone will be very happy together.  The rest of us would prefer that the problem be fixed so we can enjoy our very expensive speakers without gymnastics.

As stated earlier, it’s a Spotify issue and Sonos fixed it for their own customers by adding the ‘End Session’ button in the App - I often end the session that way, but there are other methods to end/replace the session, as previously explained.

I can’t see Sonos changing things, as the discussions have been had in the past on this topic. You can always raise the matter (again) with Spotify CS though, I guess.

I have, but I’m just one user.  If Sonos asked Spotify to fix the problem, it would have a LOT MORE WEIGHT.

What you call a “fix” is not a fix.  The best it is is a weak work around.

I have, but I’m just one user.  If Sonos asked Spotify to fix the problem, it would have a LOT MORE WEIGHT.

What you call a “fix” is not a fix.  The best it is is a weak work around.

I would have thought those things would have been discussed between them a long time ago, which in turn led to the ability for the user to ‘End the Session’ in the Sonos App - I don’t see it as a workaround. It was added to the app for that specific reason, so that users can break/interrupt the session. The previous ‘workaround’ (as you term it) was to play a different audio source to the room.. so this was the fix.  
personally speaking, I don’t have an issue with ending a Spotify session, as I often use Apps to start/stop the music playback anyway. It’s just two clicks to end a Spotify session when in the App. 

Some users choose to use Alarms to end their session before they leave for work. Others use 3rd party Apps, like Soro etc. I just find it easier to goto the now playing screen and end the session there and it’s become a thing I simply do routinely.

Badge +1

I have, but I’m just one user.  If Sonos asked Spotify to fix the problem, it would have a LOT MORE WEIGHT.

What you call a “fix” is not a fix.  The best it is is a weak work around.

I would have thought those things would have been discussed between them a long time ago, which in turn led to the ability for the user to ‘End the Session’ in the Sonos App - I don’t see it as a workaround. It was added to the app for that specific reason, so that users can break/interrupt the session. The previous ‘workaround’ (as you term it) was to play a different audio source to the room.. so this was the fix.  
personally speaking, I don’t have an issue with ending a Spotify session, as I often use Apps to start/stop the music playback anyway. It’s just two clicks to end a Spotify session when in the App. 

Some users choose to use Alarms to end their session before they leave for work. Others use 3rd party Apps, like Soro etc. I just find it easier to goto the now playing screen and end the session there and it’s become a thing I simply do routinely.

After searching the user searchable areas on both services’ web sites, I see NO evidence that Sonos or Spotify have acknowledged this problem, much less discussed it.  It is clear they have not fixed it.  Again, “End Session” is not a fix, especially since it doesn’t work when you are away from home.

I guess that’s why some users choose to end their Spotify ‘direct’ session with an alarm. I have remote access to my home Sonos system anyway, so can access it outside/away from the home as my NAS has a VPN server, but the easiest method is to get into the habit of manually ending the session after using the Spotify App, or maybe switch to using the Sonos App instead with the built-in Spotify service. as that eliminates the API session. 

Userlevel 5
Badge +6

I’m not convinced this is a SONOS issue.  My wife has the same Spotify behavior between her work computer and car, neither of which is connected in any way to SONOS.  

Badge +1

I guess that’s why some users choose to end their Spotify ‘direct’ session with an alarm. I have remote access to my home Sonos system anyway, so can access it outside/away from the home as my NAS has a VPN server, but the easiest method is to get into the habit of manually ending the session after using the Spotify App, or maybe switch to using the Sonos App instead with the built-in Spotify service. as that eliminates the API session. 

Another option is to choose a speaker that works correctly.

Another option is to choose a speaker that works correctly.

 

Good luck finding one.  As stated above, this is a Spotify thing, not a Sonos thing.  And as to Sonos having “a LOT MORE WEIGHT”?  Sonos has NO WEIGHT.  They neither pay Spotify, nor does Spotify pay them, for their service.  You pay Spotify, so the WEIGHT is all yours. 

I guess that’s why some users choose to end their Spotify ‘direct’ session with an alarm. I have remote access to my home Sonos system anyway, so can access it outside/away from the home as my NAS has a VPN server, but the easiest method is to get into the habit of manually ending the session after using the Spotify App, or maybe switch to using the Sonos App instead with the built-in Spotify service. as that eliminates the API session. 

Another option is to choose a speaker that works correctly.

You will certainly encounter the exact same issue with any/every manufacturers speaker if you continue to use the Spotify ‘direct’ API connection, like you’re doing now at Home.

Some users will use Bluetooth, others use Apple Airplay, Google Cast, or the Sonos App wireless connections instead… it’s only when you use the Spotify App ‘direct’ API connection that you will come across this issue. It’s their issue and to help their own customers, Sonos added the option to end the Spotify session.

You may find other speaker manufacturers do not offer that ‘escape’ option. So you either need to switch the type of connection, or App, that you’re using instead, or if thats too much for you to switch away from the Spotify ‘direct’ method, then you will need to find a way to end their session, no matter which brand of speaker you decide to use.

Badge +1

I guess that’s why some users choose to end their Spotify ‘direct’ session with an alarm. I have remote access to my home Sonos system anyway, so can access it outside/away from the home as my NAS has a VPN server, but the easiest method is to get into the habit of manually ending the session after using the Spotify App, or maybe switch to using the Sonos App instead with the built-in Spotify service. as that eliminates the API session. 

Another option is to choose a speaker that works correctly.

You will certainly encounter the exact same issue with any/every manufacturers speaker if you continue to use the Spotify ‘direct’ API connection, like you’re doing now at Home.

Some users will use Bluetooth, others use Apple Airplay, Google Cast, or the Sonos App wireless connections instead… it’s only when you use the Spotify App ‘direct’ API connection that you will come across this issue. It’s their issue and to help their own customers, Sonos added the option to end the Spotify session.

You may find other speaker manufacturers do not offer that ‘escape’ option. So you either need to switch the type of connection, or App, that you’re using instead, or if thats too much for you to switch away from the Spotify ‘direct’ method, then you will need to find a way to end their session, no matter which brand of speaker you decide to use.

Other speakers tend to use more standardized connection methods, which makes them more reliable.  I guess that is why Sonos is slowly adding those methods to their products.

Other speakers tend to use more standardized connection methods, which makes them more reliable.  I guess that is why Sonos is slowly adding those methods to their products.

Not actually relevant to using/ending a Spotify ‘direct’ connection to a speaker, as Sonos’ primary connection has always been via their App (remote) and WiFi playback from the audio source to their speakers.

Airplay2 had been there since its launch by Apple and Bluetooth audio added in more recent times. Just Google Casting is not onboard, but there are ways to achieve that in some instances, but these things are irrelevant to the Spotify ‘direct’ connection and ending its session. Other brands of speakers will still continue to have the same issue if you adopt that direct method of playback, at least until Spotify resolves it for their customers. I suspect there are technical reasons for not doing so, but it’s still helpful that Sonos have added the option to ‘End the Session’. I’m grateful for that feature, at least.

Badge +1

Other speakers tend to use more standardized connection methods, which makes them more reliable.  I guess that is why Sonos is slowly adding those methods to their products.

Not actually relevant to using/ending a Spotify ‘direct’ connection to a speaker, as Sonos’ primary connection has always been via their App (remote) and WiFi playback from the audio source to their speakers.

Airplay2 had been there since its launch by Apple and Bluetooth audio added in more recent times. Just Google Casting is not onboard, but there are ways to achieve that in some instances, but these things are irrelevant to the Spotify ‘direct’ connection and ending its session. Other brands of speakers will still continue to have the same issue if you adopt that direct method of playback, at least until Spotify resolves it for their customers. I suspect there are technical reasons for not doing so, but it’s still helpful that Sonos have added the option to ‘End the Session’. I’m grateful for that feature, at least.

Airplay (all versions), Bluetooth, and line-in are all methods other speakers have had for a while, and it is good that Sonos is getting around to adding them.  The first Sonos speaker I bought I had to send back because it wouldn’t work with Spotify at all.  I got these new ones because they claimed to work with Spotify.  Turns out they only SORT OF work with Spotify, as noted above.

So, no one has spoken of the real solution; how do I get Spotify to use Airplay instead of the broken direct connect?

“End Session” is kind of a no-op given that playing another source does the same thing, but I’m glad you like it.

@Acuff

The Airplay and Bluetooth methods of connection are in the same areas of the iOS Spotify App or of course you can use the Sonos App to start a direct WiFi audio playback from the in-built Spotify service… none of these methods will affect (steal) your playback when outside/away from your home using your Spotify App, unless someone at home (or elsewhere) starts playback using your Spotify account, that is.

Badge +1

@Acuff

The Airplay and Bluetooth methods of connection are in the same areas of the iOS Spotify App or of course you can use the Sonos App to start a direct WiFi audio playback from the in-built Spotify service… none of these methods will affect (steal) your playback when outside/away from your home using your Spotify App, unless someone at home (or elsewhere) starts playback using your Spotify account, that is.

Now that is a solution.  Not ideal since it takes more clicks, but it should work to avoid the root problem without having a big burden of having to perform a complex operation every time I leave home.

Userlevel 4
Badge

I connect via Bluetooth to a Sonos one and to house-wide Sonos system from there, listening to Spotify but have Sonos app running to control volumes etc. Later, I switch to AirPods via Bluetooth. And the Sonos keeps hijacking the signal. The AirPods stop playing. I close all apps, reboot the iPhone, and it still does it. This is a big problem for me. 

I connect via Bluetooth to a Sonos one and to house-wide Sonos system from there, listening to Spotify but have Sonos app running to control volumes etc. Later, I switch to AirPods via Bluetooth. And the Sonos keeps hijacking the signal. The AirPods stop playing. I close all apps, reboot the iPhone, and it still does it. This is a big problem for me. 

 

Sonos One has no Bluetooth capability.  You must be connecting some other way.  

Badge +1

I connect via Bluetooth to a Sonos one and to house-wide Sonos system from there, listening to Spotify but have Sonos app running to control volumes etc. Later, I switch to AirPods via Bluetooth. And the Sonos keeps hijacking the signal. The AirPods stop playing. I close all apps, reboot the iPhone, and it still does it. This is a big problem for me. 

I suspect you aren’t connecting via Bluetooth, but via the “Connect” path that caused the same problem you describe for me.  Try using “Airplay” instead of just selecting the speaker from the list that pops up when you hit but speakers button in Spotify, then select the speaker.  That way, it will connect via Airplay and not have the problem.

If you are having the problem, the only way to fix it is to go into the Sonos app and select another source or “End Session” from there, but you have to do that at home, so if you are away you are screwed.  Supposedly this is a Spotify problem so you should complain to them, and ask Sonos to support your complaint.