Sonos sees my playlist, but I can't find it in source Music Library

  • 27 March 2021
  • 6 replies


I have half a dozen playlists, originally made in iTunes, that disappeared when we transferred the music library onto a separate storage unit (NAS).

The funny thing is that Sonos still sees them and we can play them by choosing them in ‘imported playlists’. The NAS music library is the only source for the Sonos, and yet we cannot find these playlists on the NAS ourselves!

What I really want to do is to find these playlists on the NAS, so that I can re-import them back into iTunes.

Can someone clever please point me in the right direction, all my online searches on this topic only throw up irrelevant results for this situation!

Thanks in advance!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Hi.  A few questions:

  1. Have you reindexed (updated) the Sonos Music Library?
  2. What folder path(s) is/are shown in the Sonos Music Library set up?
  3. Whichever folder(s) that points to, do they or their subfolders contain an xml file called iTunes Music or iTunes Music Library?
  4. Are the original iTunes Music files still sitting anywhere on the system, e.g on the computer itself rather than the NAS?

Hi there,

Thanks for your interest, here are the answers:

  1. It is updated automatically once a week.
  2. It is NAS/music
  3. Yes there are two in fact, one from 2017 and one from 2018.
  4. Yes they are, and we have already searched them for the playlists, but with no luck.

I have a couple of questions you may be able to help me with:

  1. Would the playlist xml file be inside the itunes music library xml file, or separate from it?
  2. Is it possible that the Sonos has saved the playlist information into its controller? This seems like the only possible scenario seeing as how the music library is updated regularly and we know that the playlist is no longer in that music library. I should reiterate that the playlist in question is an imported one, and not a Sonos one.

Thanks for any ideas or help you can offer me!



One thing I can absolutely guarantee is that nothing is being saved in the controller app.

There is no playlist xml file. Playlist information is stored in the iTunes Music Library xml.

I am not sure what you are expecting to find when you are looking for the playlists?

My best guess is that you have moved your iTunes location and with it the xml file, which still points to the playlists in the original location. That would explain why Sonos continues to find and play the playlists. 



You might want to try the following experiment. Pick a track that is in one of your playlists. Delete it from your NAS music library (or rather move it somewhere safe).

Update your Sonos Music Library.  

See if the track has disappeared from your Sonos Music Library. 

Then play the playlist that contains that track and see if it is still there. 

Please then post back 


Hi there,


Just to say that I intend to try this, but life and lockdowns are catching up with me, so I haven’t gotten there yet. Thanks again for your interest in helping.

I have the same issue.  My itunes library is on my Mac.  Separately, I have a NAS where I save a copy of my iTunes (now Music) music and playlists which is where Sonos looks for my music (I don’t use Apple Music).  This setup has worked for years.  I last updated my NAS music/playlists in August 2020 (which worked).  

When I tried to update it again (May 2021) the playlists show but I receive an error saying that Sonos can’t find the music.  Specifically, it states “Unable to play ’(song title)’ - the share //ReadyNAS/Music does not exist.  In fact my music is under /ReadyNAS/Music/Music, (which is where it has been for years - there are reasons I’d prefer not to just put the music up one folder level).  Historically, Sonos would figure out where the music is located based on my iTunes Library file (my iTunes Library.xml file is in the /ReadyNAS/Music/Music folder).  Something changed since last year and it’s frustrating.

All of the music is found and things like albums can be searched and played.  It’s only the playlist which is not working.

Any help is appreciated. - Thanks