Sonos controller for Mac failing to update with Mac OS Ventura 13.2.1

Userlevel 3

After updating to Ventura 13.2.1, the Sonos Controller Application tries to update, but fails repeatedly. Is this a known issue? If so, what is the solution?


Best answer by LordAttilas 31 March 2023, 22:20

View original

48 replies

Userlevel 1
Badge +4

I had the same issue for some time in MacOs. Yesterday I found that you need to authorize the “Sonos Installer” under System Settings → Privacy & Security → App Management. Once I allowed it I was able to use the auto update from the Sonos app itself.


Previously I was uninstalling and installing the new one from the website.

Thank you, I was finally able to update mine


I created an account to let you know this resolved my issue after a loooooong time

I had the same issue for some time in MacOs. Yesterday I found that you need to authorize the “Sonos Installer” under System Settings → Privacy & Security → App Management. Once I allowed it I was able to use the auto update from the Sonos app itself.


Previously I was uninstalling and installing the new one from the website.

You're the BEST! Thank you for posting this answer. This worked for me.


Same issue. This has been happening to me for the last four updates yet when I go to sonos support there is no information on this issue or how to fix. I find it unfortunate that it is the community that has to solve a products issues for other users rather than the company I paid a lot of money to for the product. I will be selling my sonos system as I find it to be a complete failure. It is slow, it is glitchy, it constantly needs updating that never works. It uses tune in for radio forcing me to listen to yet more adds, all in all a total waste of money and a terrible product.


Tried the LordAttilas “fix”. Didn’t work.    Instead of putting up a not now option only just add one that says, “This is a MAC and the crap doesn’t work, no thanks.”  


Thank you! I wish Sonos would make Best answer by LordAttilas an article that can be found by searching their support website. Instead, their instructions are to uninstall and then install again, which is cumbersome.

Tried all of the suggestions listed above and finally just installed the latest download over the existing app and no more updates needed.

I have never been able to get the Sonos App to update on an iMac.


Now to figure out the channel issue, system keeps dropping out on me.

On the Mac, you should  authorize the “Sonos Installer” under System Settings > Privacy & Security > App Management.
Or, just delete the current file, and download a fresh copy from Sonos, making sure to ‘Connect to existing system’ when prompted.

The former is a much more permanent solution, the latter will work this time, and you’ll need to continue to repeat that process for each subsequent update.


I had the same issue for some time in MacOs. Yesterday I found that you need to authorize the “Sonos Installer” under System Settings → Privacy & Security → App Management. Once I allowed it I was able to use the auto update from the Sonos app itself.


Previously I was uninstalling and installing the new one from the website.

finally the solution I have been waiting for so long - THANK YOU!!!!

MacBook Pro 2018 with Ventura 13.6.1, tried LordAttilas solution of granting access in App Management. It didn’t work for me. I had to Delete my existing Sonos app and download the new one. That worked very well. First time I opened it it had all my Sonos system information.

I didn’t realize there was an Uninstall program in the Sonos App. I just deleted the app manually in the App folder. I couldn't find on Apple Support where the uninstall program for an app might. I had to go to the Apple Community pages. Looks like Sonos has the same attitude towards current assistance -- Go ask the community. Anyway, thought I’d share what I learned. Here’s what the Uninstall looks like:



Userlevel 1
Badge +4


I, too, have this problem and have added the Sonos app to the relevant list in MacOS App Management Settings, but this does not fix the problem.

I see plenty of references here to adding the Sonos Installer to this list, but this app does not appear in the Applications Folder on my Mac.  Am I missing something or does it go by another name?

I am reluctant to uninstall the Sonos app for fear of losing some part of the existing set-up e.g. Favourites, Sonos Playlists etc, which we would not be a welcome by-product. 


Userlevel 1
Badge +4

Just downloaded the latest Sonos app (v15.11) and update problem is resolved and I retained all my Favourites, Playlists etc,  However, I still do not have any app called Sonos Installer in my Applications folder and therefore expect to have the same problem when the next update come through.

Can anyone clarify what I am doing wrong and/or where I can find Sonos Installer to add it to the App Management whitelist in System Settings.


I went through the same thing. I couldn’t find the uninstall for Sonos so I just put the App in the trash and downloaded the App again. I was relieved that my existing system and all the related stuff was still working with the updated Sonos app installed.

I don’t know why Sonos doesn’t make it easier and point out things like where the uninstall is located.

Click on Sonos in the top menu line. Uninstall is in that pull-down menu. There is not a separate install/uninstall program. The install is simply that notice in the .dmg package that you download that says to drag the app to the Applications Folder. 


Just as a note, uninstalling the app is not an issue. All of the settings for your system are stored on the speakers, not in the app. If you feel the need to delete and reinstall, just make sure that you choose ‘join existing system’ when presented that dialog.

Userlevel 1
Badge +4

Hi Ken,

Thanks for your reply.  In my case it was not a problem of being unable to find the Uninstaller, but more that I could not see how to update the App Management list in Settings to include the Sonos Installer.  I have successfully added the Sonos app itself, which I selected from the Applications folder.  However, since there is nothing called Sonos Installer in that folder, you cannot grant it the permissions that MacOS seems to demand.

Other responders to this and similar topics have shown the Mac Settings with both apps appearing in the list, but I’m damned if I can see how they did it.  I did read that the Sonos Installer is a temporary program only appearing for the duration of the update.  That's sounds plausible, but if it is the case, I still cannot see how to get it to appear as an app permitted to delete other apps.

Quick  update - just before submitting this post, I decided to check the Mac App Management settings and Sonos Installer now appears in the list, albeit not enabled.  I certainly did not add it, so how it got there is beyond me, but I guess that should now solve the problem for future updates. 

Hi Bruce,

Thanks for that last paragraph. I checked my Apps Management and there was the Sonos Installer. It wasn’t there yesterday. I enabled it, we’ll see if the next update to Sonos works or if we still have to delete and reinstall. Either way, at least it works. 

Apple drives me nuts with changing how things work, having to grant permissions to websites, having to find out to make things work that requires going to Apple Community to find the fixes and having to go to forums like this for non-Apple apps to find out how to fix them so they work.

Userlevel 1
Badge +4

Well, Ken, I literally just checked my wife’s Macbook Air, running the exact same version of MacOS, which I updated at the same time as my own, but her Settings do not show Sonos Installer.  Only Sonos is in the list.  Work that one out!

The only difference between the two Macs was that on the MacBook Air I did not reinstall the Sonos app.  The update seemed to work perfectly straight away.  I assumed that was due to the fact that the Sonos update had already been installed successfully elsewhere in the network, but, frankly, who knows?

Only Apple, I’m afraid. But I think it takes a moment or two for the Sonos Installer ‘app’ to be registered appropriately in the Mac OS…or that’s my working theory, right now ;). If you had a Sonos controller from before Sonos started using that feature (due to, as you say, the vagaries and complexities of Apple’s app requirements), then it likely wouldn’t be there. I think you have to delete the current controller first, then reinstall the controller for that ‘app’ to appear. 

If I’m correct, not well messaged by either Apple or by Sonos, but I think we’ve got it finally nailed down.  If the installer doesn’t show up, delete your current controller, and install fresh. Select ‘join existing system’ when prompted, and then wait a couple of minutes before going to look for the ‘installer’ application to authorize it to run when necessary. 

Sonos Installer is inside /Applications/ - or is there after one failed install attempt.

Go to Applications, right click and select Show Package Contents.  Then find Contents/Resources/Sonos and add that to App Management.

I hate when I have to delete and install the new software over and over on 4 Mac-devices… I expect from a company like Sonos to have this repaired...

Doing what the post before yours, by @stuta , should resolve that. 

Userlevel 1

Been frustrated with this for months. Via Chat today I’ve been told that the Sonos in app update option is not supported in Mac OS 13 and 14. Hence it fails and the uninstall / download option is the only option.

It would really help if Sonos made this clear on the Mac OS software download page. It was suggested that I contact Apple to try and get them to resolve the issue.

Very disappointed with Sonos here.

I had the same problem (Mac running Ventura).

This is what worked for me after multiple tries

Went to Privacy and Security settings, then Full Disc Access settings. Made sure “Sonos” had full disc access, but did not see the “Sonos Installer” app listed. I did see “installer” listed which had a terminal icon next to it. I toggled that on and I tried again, but Sonos would still not update, but when I went back to the Full Disc Access settings, the “Sonos Installer” was now listed. I toggled it on, and then tried again with SUCCESS! I don’t know if this is coincidence or not, but it is worth a try.