Sonos Amps not registering - Crashing app

  • 15 May 2024
  • 7 replies


While trying to setup a new Sonos Amp in the new app, it won't register.  Then, you go to settings to manually register, and the app crashes….every time.


App is current version and iphone running on latest IOS.


This new app is absolutely horrible.  You made unnecessary changes to an app that was already easy to use and show customers how to use.  Completely unnecessary to overhaul this like they did.  If you want to give it a cosmetic refresh - fine, but this is just horrible.

7 replies

Userlevel 1
Badge +2

Same problem exactly. Latest iOS. Latest Sonos app. Tried on both iPad and iPhone, no difference. 

Existing Sonos system so I know it works.

Amp has been in my system before so I know it works. 

Steps leading to crash:




Userlevel 1
Badge +2

Not an easy or great fix, but this worked for me.

Go into the controller app and choose to transfer ownership of the system (settings/manage/transfer system ownership), putting in your account as both old and new owners. 


Will give that a shot and report back.  Thanks for the help!


Guys, I’ve got the same problem. My Sonos Amp isn.t registering because the app keeps on crashing. I trief it on IOS and Android. Transferring ownership didn't work. App keeps crashing. 

Badge +2

has anyone solved this yet?

ive got the same issues, connect and connect amp are all doing this now. i get to the fix to register part but then pops up the codes. this is wireless or wired same issue. i have these both showing on my account online. and ive factory reset many times, still shows in my account online from years ago.

No guarantee but you can try using the desktop app. It’s worked in some scenarios where the new app falls down. 

Badge +2

ok thanks. i did get it working not sure how but this is what i did-

i went to my pc and tried opened desktop controller(windows pc/ no app) it showed an update was available, i clicked update it sat for 3 mins maybe then finished, but i could not see any speakers on the left choice area. i closed controller and updated again and same thing stuck no speaker choices.

i then went onto my android app thinking it updated and it did not at first-but i went through process of checking for update in settings and it suggested update and then finally after pressing fix to add to account- it went through and completed adding my connect.


my 2nd connect amp i factory reset and went through the standard add speaker setup on my android. that this time worked ok.


i still dont know which or what worked but i know the older sonos stuff needs- im guessing- new firmware before a usual update and/or even adding to my account- even if previously added.

my 2 connects were on the older s2 app with same wifi password and never showed in phone recently- but my last powering was 2 years ago, and this is why i had to go through all this.


i love sonos but when they send out the next quiz email -will you recommend? i still have to say not really. i love sonos but this new app is causing problems even the techiest guys are struggling with just too quirky. thanks.

and i didnt mention the last 6 speakers, older 1s and 3s i had to first get on the s1 then factory reset before adding to new app. the upgrade to new app from s1 didnt work either.