Libby - “unable to browse music”

Userlevel 1

I’ve been trying to install the Libby service for the last 24 hours with a consistent issue: I kept getting the error message, “unable to browse music.” I keep removing and reading, giving it awhile, then checking. Same result. Any ideas? I’ve tried to unplug speakers and plug back in.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

54 replies

Userlevel 1

Please complain directly to both Sonos and Libby! They need to know that this is a widespread problem.

Userlevel 2

Welp it looks like its working now. Did nothing on my end. Just a solid week of going into sonos and trying over and over again.  Soooo guess complain a few times in here and it magically works?

More likely a configuration change on Libby’s servers, of some type. 

Userlevel 1

*Sigh*  On the same day that Apple Music started working again, Libby stopped working.  I am now also in this dreaded “Unable to browse music” - Reauthorize loop.  Hope this gets fixed.  Anyone else having trouble?


Same issue here, too.

Userlevel 2

I too have the issue of “Unable to browse music” when trying to use Libby.  It worked on Oct 1st when I finished a book.  Went to start another book Oct 3rd and it wasnt working.  Ive done the whole dance. Removed libby fully.  Added it back.  Tried reauthorizing at least 10 times. It even asked me to reauth once and I got hope it would work then but nope.  Tried rebooting every device (which is a chore in itself, if this is a troubleshooting step they should make a reboot function in the app cause getting to the power on some devices is hard).  Tried rebooting network router.  Im on sonosnet using a boost, that was rebooted as well.  Tried on iPhone, MacOS, and Windows apps same deal.  Nothing. 


Have to airplay via libby (so the app works just fine I am using it to listen to the book) out to my one sonos One that I have grouped to everything else but thats honestly not ideal.  The libby integration does kinda suck (where it sometimes restarts at the start of a chapter without warning) but airplay is not great either and Id rather not have to use two apps one to play and  one to control volume of each speaker. 


Kinda disappointed. I do wake up every morning and check thinking maybe something got fixed over night but nope.

It’s most likely due to a server side issue at Libby, so the folks at Sonos have little to no control over the engineering resources at Libby. The best they are likely to be able to do is merely pass on your concerns to someone at Libby. 

You may be better served by directing your comments directly to Libby, rather than Sonos. And yes, I know they told you to contact Sonos. But Libby likely uses a different server to service the Sonos connection, and it would be less ‘exposed’ to a normal CS person. 

Sonos wrote the API, Libby added the API to their server software, and maintains the data. All Sonos does is play what they are handed by the Libby server. And if that data is incorrect, there isn’t much that Sonos can do. 

I’m sorry you felt as though the comment was unhelpful. 

Let me reframe the issue. Sonos is, effectively, a TV set for the ears. Like your TV set, they aren’t (with minor exceptions) responsible for the content they play. Just like Samsung, LG, Vizio etc isn’t responsible for the content on HBO. 

Sonos functions by pointing their ‘channel’ at someone else’s server stream. They don’t do any processing of that stream, they just play what they are handed. All streams use the exact same ‘type’ of stream to play, as defined in the Sonos API, which is installed by the streaming company on their servers. 

So, if there are any issues, unless it is on every stream on the Sonos system, it is most likely an issue with the server at the other end, since Sonos isn’t involved in maintaining that data. 

I’m not a huge fan of CS departments as a reliable source of server status, in my work experience, they are often either the last to be told, or the first to be informing the development team, but have to toe the line and say there isn’t a problem, and point the finger elsewhere. Either way, the CS folks are put in a bad way, and it just isn’t their fault. 

Yes, I’d agree that Sonos CS has had some issues over the last several months, as they released several, at least, of the community team, and perhaps of the CS team as well. But that doesn’t alter the way the software works, it just is frustrating. My recommendation is to press both sides, as it’s possible that Sonos has some inside contact at Libby who is less willing to just point the finger, and willing to look at the issue without prejudice. And in the meantime, in order to ensure the issue isn’t one in your local network, I would refresh it, by unplugging all my Sonos devices, then rebooting the router. When the router comes back up, plug back in the Sonos devices. But that’s just precautionary, I’m not convinced at all that it will resolve the issue, as I continue to consider it an issue with the way Libby is ‘sending’ data from their server that they have for Sonos. 

Userlevel 1

Just chiming into say that I’ve been trying to get Sonos and Overdrive to help me since May.  Every few months I email customer support from both companies and I get a generic email telling me they still haven’t worked out the problem. I’ve never once been able to play Libby content through my Sonos speakers, although I’ve paired/unpaired, uplugged/rebooted endlessly, and spent many hours on the phone with customer service. “Unable to browse music.” I have tried library cards from multiple library systems to no avail. “Unable to browse music.” Meanwhile I spent all this money on Sonos speakers and they can’t do the MAIN THING I WANTED THEM FOR, which is to play audiobooks for my kids.



Userlevel 2

Really wish this would somehow get resolved.  Been about a week now since I could use it. Now I guess I get what I paid for in this service (ie free) but airplay sucks. Its dodgy at best.  I still open the app and check daily, sometimes a few times a day, to no luck.

After similar issues and troubleshooting, I was able to get Libby to work by opening the audiobook in Libby then go into Sonos app and browse via Overdrive/Libby and the title I opened was there and worked. I am not able to see my full loans list but maybe that'll help someone.

Userlevel 1
Badge +1

I almost always receive the "unable" message when I try. It usually pulls up my books on second try... until today. Nothing is different and I have rebooted samsung s21. Will try iPad pro 10. Nope. This is either Sonos or Overdrive.  PLEASE figure this out. 2 years!

Userlevel 1

Did you try forcing a reauthorization? That seems to be the root of all the problems.

What did Sonos say, when you submitted a diagnostic, and called them?

Userlevel 1

This appears to be a Libby reauthorization problem. As has been attested to elsewhere, the Libby service on Sonos wants frequent device reauthorization, sometimes weekly, sometimes daily. It is fairly random. When this happens, if you Browse to Libby, it will have no content available. What I just did now when the playback bug happened is go to the Libby settings in the Services & Voice section, and did a reauthorize. After completing that and returning to the Sonos app, it still complains, but then I again Browse to Libby, and the content shows up, and I can start playing the book again.

So maybe, at least in this case, Libby wants reauthorization, but neglects to display the dialog for it, and so trying to play the book fails.

This state does sometimes disappear. Sometimes if I wait long enough, like a day, Libby will work again. And the state can be generated by just pausing playback, then attempting to play again. I suppose the reauthorization may not be enforced while a book is playing.

So yet another Libby bug, along with the constant reauthorization requests, and not updating the current position 50% of the time, which could be a reauthorization bug as well.

Userlevel 1

Yep, I’d done those things, as has been suggest on numerous other posts, and it doesn’t solve the issue. Guess I’ll have to try to call, unless anyone has a better option...

Userlevel 1

I spent about 2-3 hours on the phone with Sonos customer service last night to resolve this issue. They had me reboot my Wifi and speakers several times… uninstall and reinstall both Sonos and Libby apps… Unpair and re-pair Sonos and Libby apps… Nothing has changed the error message: “unable to browse music.”


I got this follow-up email today, which makes me think that if you’re having this problem, you should call them, because they’re not aware that it’s a widespread issue:


Hello Tamar,

My name is Matthew. I'm a supervisor on the Sonos Customer Experience team. 

We don't have test accounts for the Libby by Overdrive service, so I can't test right now if the issue is isolated only to you. I tried creating an account of my own, but none of our local libraries are using that service.

I can see the error in the logs of the Sonos app. The Sonos app is receiving a very generic error from the server managing the content. The Sonos app can't even get to the point where it tells the speaker to play, because the app is unable to access the data from wherever it is hosted.

There are more than 80 services that can play to Sonos. I'm going to have to find out internally what kind of visibility we have into this service, and what contact, if any, we have with the company that provides it.

Matthew G

We are getting this error too ever since the new app came out. Libby can’t connect using either Sonos1 or new Sonos app.


I have the same problem. I’m reluctant to call Sonos and spend 2 or 3 hours with them as I find they are often going on a script and it’s a circular experience if they don’t know the answer. 

Has anyone found a solution?



Yes. They told me to contact Sonos...

I’m now having the problem as well…. anyone have aa solutions?  I have an upset 7 and 9 year old...Help!!!

Userlevel 1

I just began receiving this error again 3 days ago for seemingly no reason. When I posted initially, the issue resolved itself when I removed one of my several library cards within the Libby app. I actually took it down to just one library card, and then one-by-one added them back. Going to try that again and will update, but…might be worth trying.

I did get this message from the support people at Overdrive ( 8 days ago after doing a round-about again where they told me to talk to Sonos support and I mentioned this thread here:

“I'm sorry for the trouble you're having. I believe the issue is on our end. I'm investigating this issue, and I'll let you know as soon as I have more information. 

Thanks for your patience!

OverDrive Technical Support”

I wonder if it be possible for someone from Sonos support to talk to the people at Overdrive and post an update here so we don’t waste anymore time than is necessary? I tried including both on my emails to support and that gets me nowhere. 

btw, I only have one library card. I reauthorized it multiple times within Sonos. I also completely deleted the Libby app (why not?), and reinstalled it and reauthorized it yet again. Didn’t help me. I also reset my router, turned off all my Sonos devices (see above).

Those of you who are also having this trouble may also wish to contact the Overdrive support people, if you haven’t already: - just to let them know about the scope of the issue. 

Userlevel 1

I would like to second the request that someone (perhaps you, @Rowena B. ?) at Sonos needs to connect with the folks at Overdrive.


For all of you following along, I have multiple library cards spanning different libraries on my Libby account. I resolved the issue (sort of...) a couple days ago, as I did in the spring, by removing the cards one by one until my Libby had zero cards -- then adding them back in. When I did this in the spring, I was able to add back almost all of the cards before it jammed up again; two days ago, I was only able to add back one library before getting stuck again. I add back one card in the Libby app, then go check the Sonos app to see if my audiobooks are appearing.


Given that the issue has been the exact same, and solved the same way both times, that seems like maybe a lead…? Could other people who’ve had this issue try removing your cards and adding them back. Maybe, if other folks get the same result, Sonos and Libby can finally figure out what’s happening. @MMMWWW @Sbridgeo @SquashTime @bfeley @THA 

Userlevel 1

@bcstahl01 To be clear, what worked for me was removing MY LIBRARY CARDS WITHIN THE LIBBY APP, and then ADDING THEM BACK IN WITHIN THE LIBBY APP. Not removing and readding the app itself. Just wanted to clarify—thanks!