Error when trying to play Audible books from Sonos app

  • 30 November 2020
  • 2 replies

About a month ago I started having a problem playing Audible books through the Sonos app. When I try to play a book I get an error message saying “Unable to play ‘Opening credits’ - the song is not encoded correctly”. It quickly tries to play the next 4 chapters with the same error message before it fails and stops.


I have the seven Harry Potter audiobooks through Audible and I had listened to the first two books with no problem. I would start the book in the Sonos app and then use Alexa for playback controls. With this I only use the Sonos app once in the beginning of a book and not again until I need to start another book. When I went to start the third book, that was when I noticed the problem described above. I tried playing both of the first two books that worked before, but both had the same error. I then tried two Audible Original books and those had the same error. With that it seems that it is unlikely to be a problem with an individual book.


My setup is two Play:1’s as a stereo pair and a single Sonos One with Alexa enabled. The error occurs whether I try to play a book on the Play:1’s or the One. I use an iPad with the S1 app along with the Audible and Alexa apps. All of this is connected to a home WiFi network. The services I have connected to the Sonos app are Spotify, SiriusXM, and Audible. Spotify and SiriusXM still continue to work fine as they did before the problem. I can play the books on the Audible app through my iPad, but if I try “Connect to device “ to play it through my Sonos speakers it skips through the next few chapters and then stops playing.


Since I last was able to start a book through the Sonos app, there has been a few iPadOS updates that I don’t know what effect that has had. Otherwise nothing of my setup has changed. I do have a baby monitor camera in the room with the speakers that if plugged in the wireless signal to the monitor interferes with the speakers operation. That affects all services evenly including Alexa. When unplugged everything works fine except for the problem I described above. The camera was in the room before the problem started.


I have reauthorized my Audible account, removed and added both the Audible and Alexa services. I have restarted my cable modem, router, and all 3 speakers with no change in the problem. These were all done with the above mentioned camera unplugged so there would be no interference. The only thing I haven’t tried yet is deregistering my speakers from amazon and reconnect them.


I’ve tried just about everything I can think of and find online. I’m hoping this post and the diagnostic report will shed some light on the problem and lead to a solution.


Diagnostic number: 166610410


Thanks in advance to anyone that reads my post and/or tries to help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 5
Badge +16

Hi @newskis.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue as well as the step(s) that you did, let me help and try to figure this out.

Upon checking the diagnostic report, it shows a transport error that indicates playback failure and symptoms indicative of interference has been detected on one or more Sonos components running on the WiFi. Wireless interference can occur when two or more wireless devices compete for the same WiFi space. You may check this article that will help you reduce wireless interference around your Sonos products. 


If you are using a local WiFi network with more than one WiFi hub or access point, I recommend that you can try to switch your system to SonosNet by wiring just one standalone Sonos device to your primary WiFi hub or router, that begins the WiFi network. Attempt music playback, or any other activity to Sonos that was previously failing, and see if the problem will be resolved.

Wait for about 3 minutes, then submit a new diagnostic report and reply with the confirmation number so I can check if there will be changes.


Let us know how it goes and if you have any questions feel free to reach out, we’re always here to help.

First off, thank you for helping me with this.


I tried as much as I could to reduce any kind of interference. I took the wireless to out of the room just in case it could still send a signal while unplugged. I also connected an Ethernet cable to my One. It is connected to a switch connected to my router because a direct connection would be difficult. Both Spotify and SiriusXM continue to work with no problems. However attempting to play an Audible book still results in “unable to play -the song is not encoded correctly”. All of those are through the Sonos app. I also made sure the sonosnet channel was different from my router’s WiFi channel.


Here is my new diagnostic: 2055930604