Answered

Can't access music library on router usb drive

  • 11 August 2023
  • 8 replies
  • 198 views

Hi I am having issues connecting to my music library on USB connected to my router. I get error codes 900/1000/1001 using S2 app on android and on the Windows app.

 

I have just changed my router to Draytek 2766ac - I have been through every setting on the router but still cannot connect. What am I missing? 

Its driving me insane because had no issues doing this with last router. 

Thanks

Tony.

 

 

 

icon

Best answer by Lotis555 15 August 2023, 11:33

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

How sure are you that this new router allows you to treat a USB attached drive as an NAS? Not all routers provide that function.

The routers online user manual is here (see below link) - I would search and look at the entries on USB SMB file sharing and setup the users/passwords etc. for file sharing access and see if that perhaps works for you.

https://fw.draytek.com.tw/Vigor2766/Manual/DrayTek_UG_Vigor2766_V1.2.pdf

I would use SMB v2, rather than v1.

If no joy, then you are perhaps best to speak to DrayTek customer support.

https://www.draytek.co.uk/support/contact-support

Hi thanks for the rapid replies. 

Yeah as I said I've tried every setting on the router and I've read the manual over and over. 

I've been in touch with Draytek but they couldn't help either. 

No problem connecting to the usb drive in Windows. Sonos just doesn't seem to like it. 

I'd tear my hair out if I had any! 

Thanks anyway. 

Tony. 

Definitely not SMB v1 with an S2 controller, I’d be using SMB v3

 

Remember, Windows connecting to the drive is a completely different thing than the Sonos speakers connecting. You can’t equate them. 

Userlevel 7
Badge +18

Hi @Lotis555 

Welcome to the Sonos Community!

We are aware of an issue whereby Sonos is unable to play files from a USB drive connected to a router and are investigating. There is no ETA for a fix, however.

Contrary to what has been said above (sorry, chaps) we do in fact recommend in this case that you try configuring your router to use SMBv1, if you have that option.

Otherwise, the cheapest ways to get your drive working with Sonos is to either connect it to a macOS or Windows computer (which would have to be on whenever you wanted to play), or to a SBC (Single Board Computer) like a Raspberry Pi.

I hope this helps.

Hi Corry

Thanks for the update. I've gone back to my old Asus router and USB is working flawlessly again. 

Before the Asus I had a Netgear router which worked great as well. But no-go with the Draytek. 

I found an old post on a different forum a while back which mentions changing a setting in Draytek setting to make this work but they failed to say what setting it was annoyingly! 

I know Draytek routers have a ton of security built in. I'm certain that's the issue.

Manual say it uses smb1 and smb2.

Thanks

Tony. 

Userlevel 7
Badge +18

Hi @Lotis555 

Thanks for updating the thread, and I’m glad to hear you got things working again. It does indeed seem to depend on the router used.

If the Draytek is switchable between SMB versions you should find that forcing it to ‘SMB1 only’ gets Sonos through the indexing scan, and you can then re-enable SMB2.