Answered

Alexa Skill Can’t Enable in Canada

  • 11 March 2023
  • 8 replies
  • 243 views

Userlevel 2

I’m trying to resolve an issue with my Echo and just disabled my Sonos skill. When I try to re-enable it I can’t because it says it’s not available due to geographical reasons. The Sonos site says that it is available in Canada so I’m not sure what to do. Please help.

icon

Best answer by Ken_Griffiths 12 March 2023, 17:32

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Check you have the correct Country settings in your online Sonos Account here:

https://www.sonos.com/myaccount/user/profile/

 

Userlevel 2

I’ve checked this and my profile Country is set to Canada already. I changed it to something else and back again and it’s still giving the geographical error. I also checked my Amazon location and it too is set to Canada. Any other ideas?

Yes, maybe consider trying a reset of the Sonos App in ‘Settings/App Preferences’ and on reopening the App, accept the T&C’s and choose to connect it back to the ‘existing’ Sonos system and then give Alexa another try.. ensure that you have the Amazon Alexa App installed on the device and that it’s logged into the primary Amazon account. (If you have other Amazon Apps then see what happens if you temporarily uninstall those on the mobile device and just leave the Alexa App installed).

Do not use a desktop controller Sonos App to install Alexa and just ensure the mobile device you are using meets these stated requirements:

https://support.sonos.com/en-us/article/sonos-app-requirements

Userlevel 2

No change. I deleted the Amazon and Amazon Prime apps from my phone, rebooted, reset the Sonos app, reconnected to my system and the Alexa Skill still won’t install. If I ask Alexa to enable the Sonos skill she says I’ve previously disabled it and asks if I’d like to re-enable it. I say yes and then she says I’ll need to link it with my account but it doesn’t actually enable it - it still shows that it’s not installed and when I try it says it’s not permitted due to geographic restrictions. 

Userlevel 2

In case this matters, I am using the S1 App because my devices are not supported on S2. 

If you set aside the Sonos App for a moment, have you tried manually disabling and re-enabling the Sonos Skill in the Amazon Alexa App? Goto ‘More…/Skills & Games’ and select ‘Your Skills’ to manage the Sonos Skill and give that a try and then return to the S1 App to install the Assistant on your voice capable speaker which I assume is either a Sonos One or Beam (Gen-1) 🤔?

Userlevel 2

I think you may have misunderstood the problem I’m having. It has nothing to do with the Sonos app and everything to do with the Alexa app. I cannot enable the Sonos Skill - that’s the whole problem. I already disabled the Skill and now I can’t enable it because it says it’s not available due to geographical reasons. 
 

what I’m trying to get help with is enabling the Skill. Sorry for any misunderstanding. Also, my speakers are Play 1, Play 3 and Play 5. Nothing is voice enabled. I do voice commands with an Echo Dot 3rd Gen. Thank you. 

Ah okay. It sounds like you may need to seek help from Amazon Support with your account in that case, as you will need to be able to first install the Sonos skill - it’s quite possibly a Home address/location setting on the Amazon side of things.