I can't reauthorise my spotify account.

  • 13 June 2015
  • 4 replies

I can't reauthorise my spotify account. I have tried switching off, resetting controller but still won't work. I can log into my spotify app with facebook

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 6
Badge +16

Have you tried removing the account and then authorising it again?

Manage > Settings > Services > Click on 'Spotify' > Remove > Remove
Now you should click add, find Spotify and authorise your account.

Tried that with no success I'm afraid. Thanks for the advice though!
Userlevel 6
Badge +3
Hi User216314,

Is your system still unable to reauthorize your Spotify account? If not can you send us a diagnostic? Please reply with the confirmation number.
Here is a FAQ showing how to submit a diagnostic.
I'm having this same problem. Here is my confirmation number for the diagnostic: 2108400390

It's happening on both the Sonos desktop and iPhone apps. I can play on Spotify and connect to my Sonos using Spotify connect, but I can no longer play Spotify in the Sonos app.