Sonos Beam - No sound on random streaming shows

  • 3 February 2021
  • 14 replies
  • 156 views

I have a Sonos Beam connected by HDMI to a Sony TV (XBR65X900F). I have had this set up for about a year and have had no issues. Then a couple weeks ago for some reason when I would try to reduce the sound with the TV remote it would only increase the volume. I corrected that but last week all the sudden certain shows stopped having sound. This happens on Disney+ plus amazon prime. I read one question that said if you adjust the DD+ to DD, but that did not seem to work. Thanks


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

Userlevel 7

Have you tried unplugging your TV and Beam from power for about a minute?

I tried the unplug Sonos but not TV - not easy to unplug :)

I have now unplugged both and still have the issue. I played with it a little more TV sound works, the remote functions make sound and Disney+ works when I watch a Dolby Vision show. When I watch an older show like Gummy Bears no sound.

Userlevel 7

Are you streaming from your TV’s internal apps or from an external media device?

It happens from my TVs internal apps. I just checked though my fire stick and everything works. Must be something with the tv.

Userlevel 7

Is your TV still set to Dolby Digital and not Dolby Digital Plus?

Tv is set to Dolby Digital Plus.

Userlevel 7

Set it to Dolby Digital and test the internal apps again.

For fun I hooked my Xbox and it will not play sound through Sonos at all.

Userlevel 7

You probably need to adjust the audio settings on your Xbox.

I switch it and no thing happens. But, when I go back a second time it still says it is Dolby Digital plus

All of this has worked for the past year and then a week ago just starting acting weird like this

Userlevel 7

Maybe try a different HDMI cable?

Well, I think it is something with the TV at this point since the fire stick works fully. thanks for the help though!