Problems adding S2 while keeping S1

  • 4 January 2021
  • 1 reply

I have half a dozen S1-only Sonos devices. I just bought 2 Fives. I understand those are S2 only and I’m prepared to have a split system running both S1 and S2.

I ran into a problem trying to follow Sonos’ directions for adding S2 devices to an S1 system.  They say to first remove S1 devices through the System Tools section of the S1 app.  My problem is, there is no “remove device” button offered to me in that section. 

I’ve read past threads where some other users had this issue but it fixed itself when they updated their system.  But my Sonos is already up to date, plus I’ve tried rebooting my router, etc.  “Remove device” is not being offered to me.

I’m wondering whether I would create problems if I went the other direction, and set up my S2 Fives as though I was setting up an entirely new Sonos system for the first time, and leave my Sonos 1 system as is.  Could that work?

Any advice you can offer would be much appreciated!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

You’re on the right track. Install the S2 app and set up a new system containing the Fives. Leave all the S1 players and controllers exactly as they are. 

I can see no reason why the S2 controller should be confused by the presence of the S1 devices on the network, but if it does then temporarily power those off during setup of the new system.