Answered

Play:1 connection

  • 22 December 2020
  • 9 replies
  • 229 views

Hi, if anyone has any suggestions to my problem I would be most grateful. I have spent literally around 10 hours over the last week trying to sort this out with Sonos and Vodafone. I am struggling to add my play:1 to my WiFi network. When I add the product it asks to connect to a temp Sonos network which I do so that means my existing network doesn’t show. I manually enter name and password and Sonos says unable to connect? I have a beam and a one which have both connected fine. I have had new broadband and had my settings changed accordingly however my device was fine on the network until the last week. I am at a loss? I have resorts factory across all my products and added them again but this play:1 is causing me the problem. Sonos recognises the device but just will not connect to my network which is 2.4 and 5ghz. Would appreciate any suggestions. Thanks :-) 

icon

Best answer by Slb705 5 January 2021, 19:38

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

If using an Apple iOS device - there are a couple of known issues with Apple’s new security feature called ‘Private Address’ which may not work well with some routers. I would switch that feature off during the Sonos  ‘accessory’ setup ...goto your iOS network connection in device settings and ‘force’ the ‘Sonos’ accessory network to connect manually, having switched off ‘Private Address’ which you will find in the properties of the connection, or another (perhaps much easier) alternative option is, you could ‘temporarily’ wire the Sonos device to your router for the setup process.


Hope the above helps you get the Play:1 setup ...and if necessary, try factory resetting the device before you start the process.

Hi Ken, thanks so much for your reply. I have tried the wired route, all sets up fine until I remove the Ethernet and the speaker disappears from my system. I will try your other suggestion. I do see now my home WiFi has a new toggle on iOS saying private. Are you saying to take that off? On the Sonos connection of I select manual it asks me for an IP address. 

Hi Ken, thanks so much for your reply. I have tried the wired route, all sets up fine until I remove the Ethernet and the speaker disappears from my system. I will try your other suggestion. I do see now my home WiFi has a new toggle on iOS saying private. Are you saying to take that off? On the Sonos connection of I select manual it asks me for an IP address. 

If it sets up fine when wired - then all you need do is goto ‘Settings/System/Networks/Wireless Setup” in the Sonos App and enter the SSID and password for your WiFi’s 2.4ghz band before you remove the cable between the device and router… unless the Play:1’s WiFi card is faulty 🤔?

If going the wireless route ...In the Sonos ‘hotpot’ ad-hoc connection, when it appears in the ‘available networks’ list during the setup process, toggle off ’private address’ in its connection properties and then go back select it in the list to connect. See attached screenshot.

Hi Ken, thanks so much for your help. I have taken privacy off mine and the Sonos network but no luck still. I have set up wireless during the wired connection too but as soon as I unplug my speaker disappears. My personal network doesn’t show in the WiFi list when adding the play 1. I really don’t know 🤷🏻‍♀️ It was fine up until a week ago. 

Hi Ken, thanks so much for your help. I have taken privacy off mine and the Sonos network but no luck still. I have set up wireless during the wired connection too but as soon as I unplug my speaker disappears. My personal network doesn’t show in the WiFi list when adding the play 1. I really don’t know 🤷🏻‍♀️ It was fine up until a week ago. 

If the Play:1 works when wired and you are sure you have entered your ‘case sensitive’ 2.4ghz WiFi credentials correctly and it falls over when the cable is removed, then it might (just might) be the WiFi adapter inside the speaker is faulty.
 

I would certainly try a factory reset one more time, by powering off the speaker for a minute and then (with it wired to the router) power it back on, whilst holding down the play/pause button until you see the status LED flashing amber.

 

Having then let go the play/pause button, the flashing amber LED should go onto change colour after a short time and begin to flash green. 

Now just ensure your iPhone is connected to the routers 2.4ghz WiFi connection before doing the next steps.

 

Fully close (slide off screen) the Sonos App and reopen and undertake the speaker setup again (via ‘add product’ in the App ‘settings/system’).

 

Post setup, double check and reset/re-enter your WiFi credentials again in "Settings/System/Network/Wireless Setup"

 

Give it 30 seconds and uncable the speaker… if it drops and disappears from the App then do the following:

 

Cable the speaker back to the router again and wait for it to reappear in the Sonos App and then submit a Sonos diagnostic report and post it’s reference back here.

 

With a bit of luck a member of staff from Sonos will check your report and let you know if you need to get in touch with them - in any event I would contact them after 24 hours or so, via this customer care LINK 

 

Hi Ken,

thanks for your suggestions. I’ve actually spoken to someone at Sonos now and it’s been resolved. They checked all of my router settings and it was a simple toggle off and on of the plug and play feature on the router settings. It’s solved it and connected straight away. Hopefully it lasts now. Thanks so much for your replies and help and also thank you to Sonos for great customer service. Have a good Christmas :-) 

Sib705,

Great to hear you got it sorted, thanks for popping back here and providing the solution/outcome and Merry Christmas to you too.👍

Hi Ken and community,

Just to update on the issue I had connecting my play 1. Despite my speaker connecting it quickly dropped off. I was assigned a rep from Sonos who was just brilliant. They did several more tests and concluded that the problem was with the built in antenna in my router which meant that my RSSI signal was very weak and non existent upstairs in my house which is where the play 1 is located. My broadband provider did a test too and sent out a new router which I’ve received and installed today. Sonos checked the signal again and it has doubled since the last check and thankfully all of my speakers are now connected. If your WiFi network is not showing in available networks it may be a sign of a weak RSSI signal. I am told 70 is a good signal but mine were 15 or 0 on the one which wouldn’t connect. Hope this info helps others. 
Thanks

Sarah