• 12 December 2020
  • 91 replies

Show first post

91 replies

Since updating to the latest Merlin firmware, I’ve noticed an uptick in my disconnects--I’d say once every other night--though hard to know if that’s due to the new firmware or some other source of interference. I will say that Sonos is the only wifi device I have that drops its connection like this, so in my mind, the glitchiness is ultimately due to Sonos, not the router. 

Unlike the “bad old days” when I first got my AX-86U, I don’t have the issue with repetitive dropped connections any longer, where I’d no sooner reconnect after rebooting everything, and a half-hour later it would drop again. Now if it drops, I reconnect by just switching the router off and then back on, and I’m good for at least a day or as long as a few weeks. Not perfect, but it doesn’t drive me crazy. 

If you have not done so already, have you considered reserving the Sonos IP addresses in the routers  DHCP reservation table?

Also, maybe try a different ‘fixed’ non-overlapping 2.4Ghz WiFi channel set to a channel-width of 20MHz, with any SonosNet channel (if using) set at least 5 channels away from the chosen 2.4Ghz channel. 

See if that perhaps eliminates your intermittent audio/device dropout issues.

We had this same problem. We rolled our firmware back to:


No update yet on my RT-AX82U, last one was Feb and still has the issue! Downgrading to November update fixes the issue.

I'll give this a try hopefully this weekend. I wonder if setting that 2.4GHz channel is really what's important. Sounds like it might be the key to at least getting merlin working dependably. Thanks! I'll let you know how it goes.

Userlevel 5
Badge +16

Hi there @charlesnyc.

Thanks for posting and sharing with us what you did to figure this out.

We highly appreciate your time and effort working through this.

Surely, it will benefit those members that might encounter the same issue and look for answers here in the community.


If you have any questions,  feel free to reach out.


Userlevel 7
Badge +18

It does seem that a factory reset is required on some Asus routers after a firmware update is installed.

Thanks, everyone, for sharing!


Besides, disabing the Guest Networks and turning off 802.11ax/ Wi-Fi 6 modes for both 2.4Ghz and 5Ghz, I also have the following:

SmartConnect disabled

QOS disabled

Airtime Fairness disabled

Universal Beamforming enabled - some people have said to disable this, but I’m not sure.  Disabling didn’t seem to do anything.

Control Channel set to Auto

With these settings, my Sonos devices stay connected.  Do any of you have the Guest networks enabled?  I will try this weekend to enable the Guest Networks and Wi-Fi 6 and set the channel to 6 and see if it works.

Userlevel 5
Badge +16

Hi everyone. Thank you for your patience in this. It will be helpful to submit a diagnostic report on the Sonos app after a few minutes when the issue happens and reach out to Sonos Support, as we can take a closer look and discuss it with all of you individually in real-time. 

I suggest contacting our phone team, for they have more resources available for advanced troubleshooting, and the tools our agents can use would be very useful in this case, there can be an advantage if they need to remote into the controller to see what's going on.


If you have any other questions or concerns, feel free to reach out.

Userlevel 2

I can confirm that I have had almost constant connection to Sonos for over 2 months now with the following enabled:


WiFi 6

So I would cross these off the list of settings that might be causing problems. 

Userlevel 1

I never thought this would solve it for me, but it did, once I disabled QOS, straight away both disconnection issues stopped (i finally managed to register my Sonos Beam) and google assistant worked again! Hopefully It’ll stay this way.



I have upgraded my router to RT-AX86U too and was having a lot of problems. 

  1. Sonos disappeared / cannot be found randomly
  2. Lost control on music playback, unable to pause/skip, then it lead to point 1
  3. Reboot usually bring back online but same problem repeat 

My setup: Asus RT-AX86U as main router, 2 x AIMesh nodes using RT-AX92U.

After trying everything listed here - QoS turned off, and Airtime Fairness is Disabled, it seems to bring back the streaming playback capability. However, when I performed TruePlay tuning, it kept having errors stating Speaker problem”.

Anyone of you having same problem? 

Seems like Asus RT-AX86U with AIMesh doesn’t really work well with Sonos.

Hey @Evielwine, the only way I managed to get things working again is back to the old firmware ( Version ). No issues every since. Unfortunately the changes I made above only lasted a few days before things disappear again.


Here is the link to the Bios.

Thank you @altyz, I purchased this router mainly because of the AIMesh function, I really don’t feel like downgrading firmware where all other things are working well except Sonos… I guess as interim every time when I want to use Sonos, I just have to reboot first… :(

Userlevel 7
Badge +23

Why is anyone in this thread still trying to use these Asus routers? Get a router from an actual network company, eg AmpliFi, and quit wasting your time with these terrible Asus devices.

I had been trying to solve this issue for a few weeks, applied most of the suggested setting changes suggested with mixed success. The factory reset was the solution

 I have had 2 weeks of no drop outs on Sonos 1,3 and 5. 

The QoS was disabled by the factory reset, leave it that way

My other settings of note on the 2.4 GHZ Wireless: 

wiFi 6 mode enabled

Bandwidth 40MHz

Channel 1 (sonos ch 6)





I have the AX86U, using the latest firmware For me to get things to work with my Sonos speakers, I have to turn off the guest network and the 802.11ax / Wi-Fi 6 mode for both 2.4 and 5 ghz.  I’ve been working with Asus since the version broke Sonos to try and get this fixed.  They can’t seem to figure it out.

Userlevel 2

darkelf, I’m not sure that what works for the Arc will necessarily work for the Beam, but Merlin is easy to install. Here’s what I do on a Mac, which may/may not be the same if you have a PC. First, download the latest release firmware here, which is version 386.2.0 :  You’ll end up with a folder that contains four files. 

Next, login to your Asus router. At the top center of the Network Map screen you see first upon login, click on the firmware version number you currently have. That takes you to the firmware upgrade page. About mid-page, you’ll see Manual firmware update, and click on “Upload” next to it. That will allow you to navigate to the folder you downloaded. Click on it to open to the four files. Then click on the file that begins with the router model in the file name, then click on Choose for Upload. That’s it. Then wait until the upload is finished and you’re good to go.