AirPlay cuts out on pause

  • 3 August 2019
  • 95 replies

Userlevel 2
I just got a Sonos One (Gen 2) after reading that Airplay was finally working well with it. I was hoping to use it as my speaker when streaming video from my MacBook Pro, but have been hounded by audio issues–even with it connected via Ethernet to my Airport. The audio cuts out if paused for more than a few seconds. The easiest fix has been to go to Volume in the Menu Bar, switch the output device to something else and then back to Sonos. It's a pain to have to do this over and over. The audio comes back without much delay.

I noticed that there is a substantial delay when I go to unpause music that's been paused for a bit as well, but not as bad as when unpausing Netflix or Youtube. The audio also cuts out in minute drops every now and then, which probably just comes from AirPlay sucking up my shitty wifi's bandwidth as I've read in other posts.

Given all the other unresolved issues I have read about and the hassle that was setting this up over the phone since the app's automated setup didn't work, I am thinking I am probably just going to return my speaker. I would rather have a cheap Bluetooth speaker that I don't need to run an additional application for or even have plugged into the wall all the time.

I feel mislead. I don't get the hype for this thing.

95 replies

Userlevel 1

I noticed the same problem.

My setup:
MacBook Pro 2017 (macOS 10.15.2) <-- WI-FI 5GHz --> Router MikroTik 952Ui <-- Wire --> Sonos ONE <-- SonosNet --> Sonos ONE SL 

I submitted my diagnostics:
Your confirmation number is: 1132744257.


Steps to reproduce:
- Using macOS
- Connect to Sonos speakers using AirPlay (in sound preferences, under the volume adjustment icon)
- Go to using Chrome (84.0.4135.1)/Safari (13.0.4) browser
- Start playing a video (any video will do)
- Stop the video for say 30 sec or more
- Start playing the video again
- The video is played without sound for about 40 seconds
- After about 40 sec the sound plays synchronously with the video

The interesting point is that there is traffic to Sonos after starting playing a video but the sound comes after some time:


Userlevel 1

I am having the same problem and it drives me crazy as I pause a lot. 

Userlevel 1

It is officially a Sonos issue now.  I just rejigged my home theater with a Yamaha receiver.  Airplay on it works absolutely flawlessly.  Like it should.  Sonos just hasn’t implemented Airplay right and has a ways to go. 

Hi everyone,

When using AirPlay 2, this shouldn’t be an issue, however a lot of apps through the MacBook Pro will use AirPlay 1 which can have this behavior. I’d be happy to pass some extra information along to the team to look into this further, in case there’s something else going in. If you can get this to occur regularly, can you recreate the issue, then submit a diagnostic and let us know the confirmation number in here? Let us know what device was sending the AirPlay stream, and what software the stream was coming from. Thanks!

Ryan, with all due respect, this is not an “issue” that you’d need someone to submit diagnostics for, this is design which you (as in Sonos) can easily test by:

  1. Using macOS
  2. Connect to Sonos speakers using AirPlay (in sound preferences, under the volume adjustment icon)
  3. Go to e.g. using your favourite browser
  4. Start playing video (any video will do)
  5. Stop the video for say 30sec
  6. Start playing video again

Anyone using Mac in your team can do these diagnostics, this is caused by design not by user-end issue.

I have not been able to figure this problem out either. HOWEVER I do have a fix. I have been trying to figure out what the issue was and why it might happen. Sitting here watching a podcast and then it hit me. What if your computer told your Sonos something was always playing but no audio was actually playing.  Boom - play this video when you connect and minimize the tab. 


Enjoy only connecting to sonos once….now if only we can have a default to Sonos audio feature

Hi Sonos Management team,

This post appears to be going on for over 8 months now and I just purchased brand new Home Theater - 5.1 Surround Set and experiencing exactly the same issue with both, Beam and ONE SL’s. 

Unfortunately, this is unacceptable for $1,300 speakers set to not be able to play Apple Music for longer than 10 minutes without glitches with disconnecting/pausing and requiring re-connection that takes few minutes to play music again.

Can someone please review this issue ASAP with Airplay random pauses and advise how to resolve it? It just appears to be embarrassing to return such a great home set for this simple but major issue.

Thank you,

Alexander Sivokho

Userlevel 7
Badge +18

Hi all.

This was brought to my attention on another post - thanks @joycean 

I have done some investigating and found out the following:

  • AirPlay 2 requires that a buffer be filled prior to playback. Airplay 1 does not. As live system sounds cannot be buffered (you’d need time-travelling software code), when AirPlay-ing from macOS system settings AirPlay 1 is always used.
  • AirPlay likely times-out if no data is sent (ie. silence), though I cannot find a figure for this period.
  • AirPlay 1 is not supported by Sonos, but tends to work. Therefore, if you are using AirPlay 1 and sending all system sounds to Sonos, it works, usually, but may have issues like those described here. As AirPlay 1 is not supported by Sonos, we will not be addressing these issues.
  • macOS Applications (like Safari, Apple Music and Spotify) do support AirPlay2, but you must initiate the connection from that application, not the Mac’s settings. The media stream can then be buffered to the speaker and synced for playback.

In our own testing, we were unable to produce this issue when using AirPlay 2. If you experience these issues while using AirPlay 2 (initiated at the application level rather than at the system level), we would very much like to hear about it. Please get in touch with our technical support team if this is the case, as this is something that we would want to resolve (be it a networking or software issue).

It would be interesting if any of you could recreate the issue as you have before, but while having one media paused (YouTube for example), start something else playing over the AirPlay 1 connection - when you restart the paused media, does it play through Sonos immediately? I suspect so, as the second media playing will have kept the connection to the speaker live. I suspect @eldiets1’s fix of having a minimised window does exactly this.

I hope this information helps you all to use your Sonos speakers with your Apple products in a satisfactory way.



Thanks a lot @John B and @Corry P for your inputs. I hope you understand the frustration it produces in your customers to join the Sonos family in pursue of great audio and connectivity, only to find the simplest of use cases doesn’t really work all that well.

Maybe supporting AirPlay 1 in full would help, judging by the comments above… just a suggestion! :)

Looking at immediate solutions, I’ve just found in a Reddit thread a third-party solution: Rogue Amoeba’s Airfoil. It’s a bit pricey, but well worth the $ considering it gets the job done and supports a ton of audio targets beyond Sonos.

Same issue here with a Sonos Beam+Sub. Pausing the audio stream interrupts the AirPlay 2 connection somehow and i have to deselect/reselect Sonos as AirPlay target to reestablish the connection every time. Very annoying. Streaming source doesn’t seem to matter much, but in my case it’s mostly Audible on an iPhone.

I’m pretty sure there’s a timeout in the AirPlay 2 protocol, but I’ve not done the research that you have….yet.

I have the new SONOS Port and it also tells Airplay to timeout during pause for any length… This thread is 6 months old, why has SONOS admin not piped in yet?  This is a big annoyance to have to change output device away and back again to reset each time I hit pause.  Why cant pause have a timeout delay or not even disconnect?

I abstained from writing a post in the community for so long. I have been facing this horrible problem for more than two years. I did not even talk to Sonos because looking at the state of affairs in the community forums, it seemed to be a futile exercise. It makes me sad that such a high end, costly product has these petty and stupid issues which must be a hygiene factor. 

With all respect, community managers from Sonos only scratch the wounds by asking members to recreate the issue. This is the limit. There are tens of threads where people are so desperately looking for solution to this. Do you really think they are all making this up.  

Userlevel 1

@Sonos , do you have any update on this?  I still like my Sonos Beam, but this problem is well documented by now and there are tons of people who would appreciate a workaround or a fix! 

Userlevel 1

I have 2x Play 1SL and experiencing the same issue with Mac OS 10.14 and 10.15.

It is very frustrating and destroys the good experience of using the speakers.


@Sonos you must provide some response after years of reporting on the issue.
It’s a major bug!


This itself, makes me reconsider my opinion about the brand and I am not recommending it to a friend.

I have not been able to figure this problem out either. HOWEVER I do have a fix. I have been trying to figure out what the issue was and why it might happen. Sitting here watching a podcast and then it hit me. What if your computer told your Sonos something was always playing but no audio was actually playing.  Boom - play this video when you connect and minimize the tab. 


Enjoy only connecting to sonos once….now if only we can have a default to Sonos audio feature

It’s slightly disappointing that this thread is now over 7 months old, there has been no Sonos response and this hack is still the only thing that ‘fixed’ the issue

Count me in, have same problem.

MacBook Pro 2017 playing any Youtube or something from browser over Airplay. Go and pause. after 2 minutes try to resume. No sound for more than 30 seconds but Video continue playing 

Userlevel 1

Same here.  Pausing for more than a few seconds cuts out the Airplay and it disconnects.  I use the overcast app for my podcasts and I do pause.  A lot.  Same for not finding Airplay when I walk into the room after a while.  I have to switch my iPhone to Airplane mode and back, to find the speakers again.  This is bad, Sonos, and needs an update, pronto.  Especially since the problem is quite replicable. 

I have not been able to figure this problem out either. HOWEVER I do have a fix. I have been trying to figure out what the issue was and why it might happen. Sitting here watching a podcast and then it hit me. What if your computer told your Sonos something was always playing but no audio was actually playing.  Boom - play this video when you connect and minimize the tab. 


Enjoy only connecting to sonos once….now if only we can have a default to Sonos audio feature

this dirty fix works like a charm 😂

It is so incredibly silly, that this is required for a high-end sound tech.


Just to want to add I’m also having the same issue when streaming via airplay 2 to an amp. 

Macbook Pro (Mojave) > Netgear Nighthawk AC1900 Router > AMP

It’s super annoying having to disconnect / reconnect to Sonos every time media is paused. The weird thing is that it seems the device is still connected via airplay under network settings, but there’s just no sound. The amount of time that something is paused in order for this to happen also seems irregular. Sometimes I can pause for a minute or two and everything is fine. Other times I pause for a few seconds and then have to disconnect/reconnect (also it seems the reconnection process takes longer to happen once the problem has been triggered, than it would when starting a fresh connection via airplay.)

Hello Corry,

in the documentation article about Airplay it is clearly being stated by Sonos to use systemwide sound output on a Mac.

Thank you for bringing this to my attention. The text in that article will be altered soon but as we’ve been advising this usage for a long period, we’re now planning to investigate deeper into this usage case and the associated issues.



Also when switching to my grouped speakers, the mute on my One SL is being lifted. This speaker is muted to activate an Airplay group with two Play:3s but not to play itself.

Do you have a solution to this issue? 

It seems a software engineer has made the assumption (probably long before AirPlay support was introduced) that a speaker being added to a group wouldn’t be added to a group if it wasn’t going to play, so is automatically unmuted. I will feed this back to the relevant team for consideration. Thank you again.

Hey Corry P,
Thanks for engaging in this community discussion.

I’m happy to add some troubleshooting/test notes.
I suspect it’s an AirPlay issue and wish I could connect to my Sonos Amp via Bluetooth instead.
I have several other sets of Bluetooth speakers connected to my Mac Mini (Jabra conf speaker w/mic, Sony earbuds w/mic, even a massage chair with speakers).
The responsiveness (how long it takes from when I press pause/play/next to when the speakers stop/start playing is better over Bluetooth connections vs AirPlay).

Bluetooth start/pause delays: ~0.8 sec / no noticeable delay (android sonos app/amazon music service)
Airplay start/pause delays: ~2.2 to 6+ seconds / ~0.8 sec (amazon app on mac and on chrome - similar delays)

Apple has a history of issues with ‘sleepiness’ and impact on devices. I use a mac mini and sometimes the video display (I use a wall mounted TV) gets to an unusable state after a long sleep. I work from home (who doesn’t these days...) and often let my mini sleep overnight. Most days the display wakes up fine. I’ve tried quite a few work arounds including energy settings (no display sleep).

Alexa even seems more responsive, but you have to give verbal commands which isn’t nearly as convenient or expedient as pressing pause/play/next on the keyboard. Plus, having the visual music interface adds to the experience.

Like several others, a longer pause can fail to recover and play again (no sound, but Sonos device still showing selected). It’s as if AirPlay forget’s to send the sound signal to Sonos. If I toggle between other output devices, the sound immediately plays. When I toggle back to the Sonos Amp it sometimes will start playing again. I’ve had scenarios when I had to toggle several times to get sound over the Sonos Amp again.

What I haven’t determined is how long you need to wait after a pause, but pause to take a phone call and come back, likely you won’t have sound; or the delay is so long, you think the connection is no longer working.

Decided to do some pause tests.

configuration: using amazon music app (v8.0.0.2229) on macOS (v10.14.4 mojave)

Test steps:
1. play song in amazon music app
2. press pause
3. wait target time
4. press play and start timer
5. wait & listen

Below are pause and sound continuation times:
30 seconds / ~7.5 second delay to continue playing
60 seconds / 16+ second delay
90 seconds / 22+ second delay
120 seconds / 29+ second delay
180 seconds / 6+ second delay (hmm, though I was still doing stuff on the computer)
300 seconds / 1:19 second delay (this time I walked away from computer during the pause)
300 seconds (retest, for fun) / 1:04 second delay (again I walked away from computer)
600 seconds / 2:28 second delay (I almost gave up)

AirPlay is delaying sending signal to Sonos product after a pause (Amp in my case).
Longer pause → longer delay until signal is sent.
Continuing to use the Mac during pause time impacts the test; delays are not as long.
When I use a Bluetooth connection I simply don’t get these delays.

Suggestion, allow Sonos devices to be discoverable and connect like other Bluetooth sound devices. Don’t depend on Apple to “fix” the issue with AirPlay.

Hardly reasons for you to be sorry, juls07. This has come to be expected normal Sonos behavior; disregard, and disawow, responsibilty for issues they ought to make an effort to fix, when they can blame outside factors/events.
But hey - new colors!

yep same issue here. i have to deselect sonos speaker and then reselect it after a pause.

I am also having the same problems outlined by @rigoli.mail. I’m using a Sonos Beam, Version:13, Build: 62186220.

A quick search revealed others are also having similar issues:

 @Corry P, thank-you for being active on this thread. :)

Hey! Wanted to share my experience. So.. I bought a One less than a week ago and have had most of the issues on these forums haha, still love the sound and looks, so won’t be returning it and would love to eventually have a 5.1.2 system. 

Anyway, I’m having the same issue with AirPlay. I didn’t see some of these posted, so might as well share some tips:
-Pressing play/pause with the touch controls usually makes the audio go through in a few seconds.

-Using the Sonos app or a plug in like Siri, Yonomi (free) or Soro for Sonos ($5.00) on iOS, you can play/pause and it seems to have the same effect.

-Airfoil ($29.00), if the setting to disconnect after 5 minutes of no audio is not activated, then no issues here even after 20-30 min. So in essence, it totally seems like its an integration issue.

Please keep in mind that I understand some of these options are not ideal, but at least while Sonos engineers come up with a solution, these seem to work.

My hardware (for context and for engineering):
-2012 Macbook Pro with Catalina.

-2017 iMac with Big Sur. 

-iPhone XS

Userlevel 7
Badge +17

Why not play using the Sonos app? In my experience this is a more stable connection and you can still pause from the Mac app.

I am using MacBook Pro (2016) to Sonos One (Gen 2).

One work-around that I’ve come up with, inspired by the 10 hours YouTube video, is to create an HTML-document that plays a sine wave that is inaudible while the web page is open. One benefit over the YouTube video is that this runs forever. You don’t need to think about restarting the video.

<title>AirPlay fix</title> <script>const audioContext = new AudioContext(); const oscillator = audioContext.createOscillator(); const gainNode = audioContext.createGain(); oscillator.connect(gainNode); gainNode.connect(audioContext.destination); gainNode.gain.setValueAtTime(0, audioContext.currentTime); oscillator.start();</script>

Save into a .html-file using TextEdit, make a bookmark for it in your browser, create a separate window in your browser, open it from the bookmark, and have it running in the background in that separate window.

Hope this helps!