Turntable Line-in drop out with Sonos Port

Badge +1

Hi––I’ve had my Port for a few weeks now and am experiencing the kind of drop out that is described in many other discussions. I’ve tried many of the suggested solutions with no improvement. Would love some help. This is pretty frustrating. Many thanks!

Diagnostic = 1460156327




This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

See this thread about changing the Line-in source name to increase the buffer size

It may even work with the line-in audio uncompressed if you make the recommended changes.

Hope it sorts things for you.

Badge +1

Thanks, Ken––I’ve tried that one already with no luck. 

So the Airplay buffer didn’t work? Have you tried compressing the line-in audio in ‘Settings/System/Compressed audio’ aswell as using the AirPlay buffer? I’m assuming the dropout is happening on the Port connected speakers and not on other Sonos products ‘grouped’ with the Port. 

Badge +1

Correct––I have have the input set as Airplay Device and also have compressed audio selected. The dropout happens with my Sonos 1 –– it’s stable coming out of the Port.

If it’s dropping out when playing to your ‘one’, first try increasing the ‘audio delay’ in the Port room settings. There are several options 75ms, 113ms, 1.5s and 2s… see if any of those resolve the matter starting with the smallest delay and increasing it. If you still get dropouts after exhausting those, then I would perhaps go onto look at network interference issues, such as using a non-overlapping 2.4ghz channel on the router and if using SonosNet, then set that channel so it is at least 5 channels away from the chosen router channel.

But perhaps see how things go with the audio-delay adjustment(s) first.

Badge +1

Sadly––delay doesn’t seem to solve the problem. It may hold on longer before dropping but ultimately it drops. Seems like trying to solve for network interference is next. :grimacing:  I’ve dug into this a bit already but there must be a remaining issue.

Are any sonos devices wired to your main wifi router and are there any other wireless access points, hubs, extenders etc?

Badge +1

I’ve got the Sonos Port and an Apple TV both wired to the router. No hubs or extenders.

Then I would perhaps set your routers 2.4ghz channel to either 1, 6 or 11. Use a channel width of 20MHz if you can set that and then just ensure your SonosNet channel in the Sonos App ‘Settings/System/Network’ is set at least 5 channels away - so if your router is set to channel 6 for example, then set the SonosNet channel to either 1 or 11.

Also, as long as you are not using a Sonos ‘Move’ speaker within your setup, whilst you are in the App network settings, goto ‘Wireless Setup’ and reset/remove any WiFi credentials you have stored in the App (if relevant). The WiFi credentials are not required when running your devices on SonosNet. 

Also try to ensure your Sonos Products are at least 2-3 feet away from any other WiFi device including the router itself.  

See if that improves your dropout issue, if not, then my thoughts are to then submit a System Diagnostic Report immediately after a dropout occurs and post it’s reference back here. Then see if staff here will step in and take a look for you, if no luck from staff within 24 hours after that, I would then perhaps contact them here through this LINK


Badge +1

Thanks, Ken. Will dig into this further. 🙏🏼

Badge +1

So after going back in to check I can confirm all my settings matched your recommendations––so kind of back to square one.

The diagnostic I originally posted should still be accurate 1460156327 if anyone from Sonos can take a look. 

Userlevel 5
Badge +16

Hi folks,

@Ken_Griffiths, thank you for your assistance. We really appreciate it. 
@crompsy, thank you for reaching us and for providing the diagnostic. Let me help you with this.

Upon checking, there's a communication problem between your Sonos speakers and your network. To correct this, the next step is to perform a sequential reboot of your network devices, all your Sonos products, and force close mobile controllers to refresh the connection.

A sequential reboot means that we need to do this in order.

  • Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
  • Once the router is back online, unplug all your Sonos devices from the power. Please wait 15 seconds before you plug back them back in.
  • Force close the Sonos app from your iOS or Android device.
  • When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.

If after performing the steps above and you're still experiencing the same, please submit another diagnostic report to further check on this.

Let us know how you get on with the advice above. We'll wait for your reply.

Badge +1

Thanks, Rowena. I will follow these steps tonight and report back! :fingers_crossed_tone2:

Badge +1

:disappointed: Sadly the problem persists. Diagnostics: 557011970

Userlevel 5
Badge +16

Hi @crompsy, thank you for your response and for submitting the diagnostic. Let me check it.

Upon checking the report, the error from the previous diagnostic did not clear up after performing a sequential reboot. I see there's a failure sending broadcast from your speakers. I really appreciate the time and effort you've spent doing all the troubleshooting steps, and it would be best for you to continue working with us over the phone to expedite the process. 

To further assist you on this, I recommend contacting our Sonos Customer Care support to remotely access your device to check what's going on. Also, please provide your full network setup including the make and model for each device when you contact them.

If you need help with any other information, please be sure to let us know.

We're here to answer any further questions you have.