Answered

system disappearing after app 80.04 update


Userlevel 2

After updating my system with the latest app (80.04) my system has vanished, including arc and surrounds, every room that had a speaker isn’t showing up. Even when I try and add an existing speaker I get an error. 
 

after using the previous app for years it has been very stable and these issues popped up right after update, not sure if anyone else is seeing these issues. 

icon

Best answer by Vincen_t 8 May 2024, 20:09

View original

57 replies

My system disappeared after the update as well. It would be nice if we were given the option to choose when to (or even whether to) install disastrous updates when they’re posted. Just in case any Sonos people feel this is a small handful of isolated instances, that’s not accurate. Higher level, the new update seems to be all pain and no gain. I’m really dreading the next one.

Android over here. On the off chance it helps somebody else, I turned Bluetooth on and then unplugged my Sonos for ~2m. After plugging it back in the system returned and was accessible. No router reset was necessary. Good luck out there.

Userlevel 1

I did:

-factory reset app

- factory reset boost. Was detected after few seconds and successfully added. But no information in parameters like network connection this is my first concern. I see boost device in sonos info with same IP in my LAN

- factory reset my old play 1. Searching device few minutes... And discover the speaker. Try to add with noise détection then approved temporary wifi then error after few seconds. Application suggest retry and asked me to press button on the Play 1. And after few minutes speaker added! Yeah 

- go back to devices list nothing. Restarted application and same empty device list.…

My boost and play 1 is in the same room and used an Android pixel 

 

Userlevel 1

Come on, Sonos! You can do better! Many of us are affected by this prematurely released ‘update.’
 

PLEASE give us a roll back option!!

Your customer base is heavily invested in your products, and this app upgrade has left your products useless. Gives motivation to change brands if you can’t get this issue fixed expediently. The lack of communication from Sonos on this debacle is inexcusable. 

I was relieved to discover in this thread that I am not losing my mind, and that SONOS has stuck it to their customers with a non-vetted update. 

I finally got some music to play (Pandora) but the screens in the app are weird, my speakers are randomly dropping in and out, and when I open the app it says “Playback Activity - no connected products” but the music is playing on three speakers (out of seven) - WTH? My groups are gone, and I can’t find my list of Pandora playlists anywhere. 

I don’t have time nor energy to empty shelves and move furniture to get to all my speakers to reset this system.  There is NOTHING wrong with my router, network or device that I use to run my system, these are all problems caused by SONOS to my system that was operating perfectly before this “update.” 

These are expensive systems - we all have a lot of money, time and effort invested and SONOS needs to fix this nonsense!!! 

I have the same issues. This is so frustrating. Sonos needs to fix this asap. Who has time to do a factory reset on every single device.  I’ve got over 10 devices in my home. 

For me the solution was to ‘deactivate’ the Sonos Boost!

After that all my devices where back.

Any thoughts on when we can reinstate the Boost ?

 

I think my wifi connection is strong enough, because the moment the system works also without the boost.

I haven’t tried to put the boost back in

The question is whether that is still possible at all, think that a conflict will arise again.

Badge

This is the reason I wait for Peter Pee to approve updates before I install them...after the 14.12 update mess.

Same problem here. I have an older Play:3 and with the new app it keeps disappearing. I’ll start playing music, and then come back to the app while the music is playing and it says there are no devices on the network.

 

I tried doing a factory reset but I can only get it to work with the speaker connected via ethernet, and when I do that there’s no way in the new app to switch it back to wifi! (because of this issue 

) When I try to add the device over wifi the app “finds” it, but then can’t connect to it.

 

It was a little flaky with the previous version (S2?) but now it’s just unusable.

This is the reason I wait for Peter Pee to approve updates before I install them...after the 14.12 update mess.

Who is Peter Pee?

So I can also wait until he approves.

Badge

look for him on YouTube

look for him on YouTube

Found him, Thanks!!

Sharing my experience, in case it helps. I had the same problem after the latest update. All devices disappeared except my two roams and all services disappeared. Sonos’ solution was, as others have said, to individually reset each device and add it back (extremely cumbersome if you have many devices). Also, it wasn’t working easily with some of the devices. The Sonos solution then was to connect those via ethernet cable - again, extremely cumbersome and frustrating. After a lot of effort, I got a couple Play 1s connected and then went to the playbar, which was the only device that was connected via ethernet cable. Once that was connected, all the other devices came back online. The services did not - I had to add those one by one. One other thing - for this last update, it just sort of happened on its own. My recollection for other prior updates is that I was prompted to update the system.

Hope Sonos fixes the app and makes it usable soon! The devices are great. The app, well, sucks.

I have the same problem after the IOS update. This is only with the updated device. All the other devices IPhone, IPad that are not updated are still working. Also iT seems to be a problem with the app update.

I'm also having lots of problems with my system after this useless update.

SONOS are very quiet about this pathetic disgusting issue. Terrible customer service

Is there any way at all to get rid if this update and use the previous version?

 

 

 

Am having the same issue. System lost after app update. Never been impressed with Sonos. I rue the day I opted for this system. All I want to do is listen to some music but with Sonos it is never simple. Staggered at the amount of time you have to update the system before you can do anything. 

Userlevel 4
Badge +1

Thousands of customers are having the same issue. Join the lawsuit

 

Thankyou, that is good to know. Let’s hope they roll back soon.

Same problem here!!! I changed my router and managed to add my Beam and Play 1’s. Just about to add my Roam, when the App updated. Went through the motions of adding the Roam only for it to disappear!!! Tried about a dozen times before I gave up. 😡😡

I’m at my wits’ end with the new app.  I am only a little tech-savvy and am unable to add my system or get the radio.  Every time I try to add my speakers, the product either can’t be seen or something goes wrong and I am asked to try again.  I feel like there’s no way out! There is a 55min wait for an adviser on the phone so I am now trying to find out how to return the whole system and find something that will actually work for me.

Reply to @Harvsh I think the controller app update is a car crash. Having spent my career in software support/maintenance I cannot believe they allowed this new release. It just doesn't work. I've finally got my system up and running again by deleting the updated version and then downloading and installing a legacy version… 

https://www.apkmirror.com/apk/sonos-inc/sonos-for-android/sonos-for-android-16-1-release/sonos-16-1-2-android-apk-download/download/?key=42dddd41d4dc87311fc60164716270acc96dc828

Good luck! And don't forget to disable automatic updates!

Does anyone know how to revert to previous iOS version? Lots of places to find the android download but can’t see an iOS one yet.

Would love to sell my system on eBay but after this I fear I would not get much for it 

This seems very similar to what I had happen too, but I haven’t gone through the hassle of rebuilding the system yet; it’s currently mostly functional through the Sonos App on my MacBook, so I’m just trying to ride it out until Sonos gets their act together and rolls back this update or gets it fixed.

 

Userlevel 4
Badge +1

IOS apps cannot be rolled back

Userlevel 1

Reply to @Philip.S I was a software developer for 15 years so I have some idea of what I am doing too.

The update is the First Prize winner for catastrophic updates. As far as I am concerned they have destroyed the system.

Another thing I experience is It seems volume response is very slow when I attempt to change the volume. TuneIn radio seems to be gone, but some of the Favorites I saved are showing under Sonos Favorites. They have a player at bottom of screen and if you want a new source it is on top. I can’t seem to figure out how exactly to get what I want to hear to play because either there is no reaction to Play or no reaction to Stop until the system finally decides to cooperate!

I can not at this time see my own server Music Library with all my music files (on my tablet or phone, but OK on PC which may not be updated as the SONOS icon is still gold). I don’t see any way to use my music library in the apps on devices.

I wrote the CEO about this update and asked if they could give me the previous version back (it seems you have found it and I will give it a try). No reply of course from the CEO.

Whoever is responsible for this update needs to find other employment!

I certainly hope they move themselves on this and either send out a release that fixes the large amount of issues or at least rolls back to the previous fine working version.

 

 

Sonos needs to fix and test their software.

I can run the existing products from Spotify or from my Windows Sonos app.

Why do they spend so little testing with their app updates?

It shouldn’t be on the public to do Sonos’ testing for them.

For now, I’m just going to uninstall my Android Sonos app until they fix it.  The products seem to work fine through other means, so no point in me spending so much time trying to get their failed software to work.

Reply