Answered

Preferred speaker function in Alexa no longer working after latest Sonos update


The preferred speaker function in the Alexa app no longer works after the latest Sonos update. It has always worked perfectly. I have disabled and reabled the Sonos function in the Alexa app and that didn’t work.
icon

Best answer by cbinwnc 8 May 2019, 13:40

Well, magically, it started working again just fine. I made no changes, and it just started working again. Interestingly enough, I got an email from Sonos (in the app) explaining this "new" functionality yesterday, even though I've been using it for months. Something was definitely up with the update. All is OK now. Thanks for the replies.
View original

29 replies

I also can't get this feature to work. I have a Sonos group called Downstairs, it contains 3 Sonos speakers. Alexa knows about this group and I can all Alexa to "play xxxx downstairs" and music will play on the group.

I wanted to set up the preferred speaker option so that I don't have to say 'downstairs' all the time. So I've added the dot to the group and I've set the three Sonos speakers as the 'preferred speaker' for the group, as per the Sonos guide.

 

 

No matter what I try, the music never plays on the Sonos speakers unless I say 'downstairs' in my command. If I just ask for music, it only plays on the dot.

The testing of this Alexa integration for Sonos has been woefully inadequate. It's gotten more robust since launch but it's still pretty awful. How is it that straight-forward things like this are STILL failing for a lot of people. It's really not rocket science to test, find the bugs, and fix them.

I also can't get this feature to work. I have a Sonos group called Downstairs, it contains 3 Sonos speakers. Alexa knows about this group and I can all Alexa to "play xxxx downstairs" and music will play on the group.

I wanted to set up the preferred speaker option so that I don't have to say 'downstairs' all the time. So I've added the dot to the group and I've set the three Sonos speakers as the 'preferred speaker' for the group, as per the Sonos guide.

 

 

No matter what I try, the music never plays on the Sonos speakers unless I say 'downstairs' in my command. If I just ask for music, it only plays on the dot.

The testing of this Alexa integration for Sonos has been woefully inadequate. It's gotten more robust since launch but it's still pretty awful. How is it that straight-forward things like this are STILL failing for a lot of people. It's really not rocket science to test, find the bugs, and fix them.

Userlevel 7
Badge +20

Can you check out my post: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/an-overview-and-explanation-of-the-new-support-for-alexa-grouping-6817788

Can you check out my post: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/an-overview-and-explanation-of-the-new-support-for-alexa-grouping-6817788

I think I’ve set everything up exactly as described (you can see my screenshot). The Sonos speakers are still not used when I ask the dot to play music. I have to specify ‘downstairs’ (the group name) at the end of my command, which I should not have to do if the Sonos speakers are marked as preferred.

Reply