Question

Echo Wall Clock & Sonos One (2nd Gen)?

  • 17 October 2019
  • 13 replies
  • 126 views

Badge

I know that this has been discussed before, and that due to the One (Gen 1) not having Bluetooth there was no pairing with the Echo Wall Clock, however, given that the new One (Gen 2) has a BLE chip, I’m wondering if there’s a way to connect the two of them. 
 

Has anyone had any success getting this to work? 


13 replies

Userlevel 7
Badge +22

Hi jhcovert

The Sonos One (gen2) as well as the Port utilize Bluetooth Low Energy (BLE) protocol. It is not used for linking devices for communication in the sense you are thinking of. BLE in Sonos is used to establish a link for faster setup of a Sonos product. After setup is complete BLE has no other function.  Do not confuse BLE with the BT protocol found in the Sonos Move that allows communication to transmit music files to it.

Badge

Hi AjTrek1,

 

Thanks for the response.

 

My understanding is that the Echo Clock also works on BLE, and not via a standard BT connection (it’s how it keeps from gobbling the stream). 
 

My gut tells me this is a software issue, meaning that if Amazon allowed a 3rd party device to pair, the equipment is in place to make that happen and it would be a matter of turning the functionality on.

 

I’m curious to see if this is a feature that is added to the Sonos One’s (Gen 2) in the near future. Would be a game changer for me as I make use of the clock A LOT while cooking (hence why my Sonos are in the same room).

 

 

 

Userlevel 7
Badge +22

I doubt Sonos will ever make any of their speakers TRANSMIT a BT signal for music files. Even now the Sonos Move only RECEIVES music files over BT.  Nice thought :wink:

Badge

I think you misunderstand: the clock does not play music. It simply provides a visual record of timers that have been set. Nothing more. The amount of data transferred is absolutely minuscule. 


https://www.amazon.com/dp/B07FQDMKFT/ref=cm_sw_r_cp_awdb_t1_qGeQDbZRZ8NJ3

Userlevel 7
Badge +21

@AjTrek1 is right.  Getting the Echo clock to communicate with a Sonos One requires a lot more than both devices have BT or BLE protocols supported.   Sonos would need to have the firmware to manage/control the connection, which is surely Amazon proprietary code.  I’m not aware that they are licensing this out to any third parties.  It’s not just a matter of Amazon allowing pairing to occur, or someone figuring out a hack.  Even if Sonos did have access to impliment,  it’s hard to say that that their would be enough customer interest for Sonos to spend the money to develop and maintain this feature.  And of course, Echos also  communicate with microwaves and buttons through BT as well, not to mention all the other features of Echo that don’t currently exist with Sonos/Alexa implementation.

 

If this is a vital feature to you, I’d recommend adding a echo dot, or perhaps echo show to the room, then pairing your echo and Sonos together with Alexa groups.  This is what I do in several rooms in my home where I either don’t have an Alexa enalbed Sonos speaker or the features of the echo make it worth having the second device present.

Badge

melvimbe, thanks for clarifying. 
 

I tried adding a Dot to the kitchen group (Dot, Sonos One 1, Sonos One 2) and then including the two Sonos One’s I have as preferred speakers, but music only would come out of one of them. Am I doing something wrong? 

This seems like the best approach to get what I want, but I can’t seem to set it up right.

 

Any help or insights would be deeply appreciated.

 

Userlevel 7
Badge +19

I would pair the Sonos speakers as a Stereo Pair in the Sonos App.  They will then show in Alexa as the single device and will then play together in Stereo.  Otherwise I’m not sure you can pair individual  Sonos Speakers through Alexa.  You can group the two in the Sonos app after starting the music stream though.

Userlevel 7
Badge +21

melvimbe, thanks for clarifying. 

I tried adding a Dot to the kitchen group (Dot, Sonos One 1, Sonos One 2) and then including the two Sonos One’s I have as preferred speakers, but music only would come out of one of them. Am I doing something wrong? 

 

It might be helpful to see a screenshot of the group setup.  The first section of the group is for the Alexa enabled device, and this should contain the Dot.  You don’t really need your Sonos Ones in that first group.  The second  section of devices can contain the Sonos Ones if you want their volume to duck when you speak to your Dot.  The Preferred speaker section should contain your Sonos Ones.

 

As @bockersjv stated, you typically want 2 sonos ones in a room to be setup as stereo pair, unless you want them to play mono due to the room layout or something of that nature.

Badge

Just wanted to circle back around and say that I managed to get things working as they should. 

 

I wish I could report that there was a special setting I toggled or some form of trick, but I simply removed and re-added the Echo Dot to the group and it began playing to both speakers. 

 

Unfortunately neither of the speakers are ducking when I speak to the Dot when music is playing, but that’s the next battle and a different post on these forums! 

 

Thanks for all of your input. 

Userlevel 7
Badge +21

Just wanted to circle back around and say that I managed to get things working as they should. 

 

I wish I could report that there was a special setting I toggled or some form of trick, but I simply removed and re-added the Echo Dot to the group and it began playing to both speakers. 

 

Unfortunately neither of the speakers are ducking when I speak to the Dot when music is playing, but that’s the next battle and a different post on these forums! 

 

Thanks for all of your input. 

 

As I stated above, the preferred speakers section doesn’t dictate what speakers will duck or not, they need to be listed in the second/middle section with all the other smart devices.  The change may not take effect immediately since it’s all in the cloud, but it should work .

 

 

Badge

melvimbe, does this look right?

 

 

Userlevel 7
Badge +21

That does look correct...assuming you don’t have some other smart devices named Kitchen and Sitting Room.  However I just checked my master bedroom settings (with and echo show and Sonos Beam) and I have but the Show and Beam setup as Echo devices (top category), and the Beam as the preferred speaker.  The mic on the Beam is turned off and I’m almost sure the setup ducks properly.  You might want to give that a try when you can.  The setup might be slightly different since  Sonos Ones/Beams are setup with voice assistant.

Badge

melvimbe, in another thread I'm involved in, Ryan, a Sonos Community Manager, specifically states: 

 

Currently, if a Sonos speaker has the built in Alexa enabled as an assistant, even if the microphone is turned off, it won't duck in volume unless it hears you say "Alexa". Removing the service from the room but having the skill enabled will still allow you to control the system with Alexa, you just will need to use a different microphone enabled device.

 

So, it sounds as though I need to have the functionality completely removed from the Sonos One’s in order to get ducking to work. The problem is that I’ve set it up exactly as they suggest and still ducking does not work. I’ve tried it with the Sonos One's in the Group and as Preferred Speakers, and out of the group, but still listed as the Preferred Speakers. No change in ducking behavior. Very frustrating. So close to having things exactly as I’d like them. 

 

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-echo-dot-group-ducking-6830792

Reply