Answered

Alexa voice assist stops working S2


Sonos hive, seeing if anyone else is seeing this issue. I upgraded to S2 and did a full redetect of every device in my Sonos system. All are compatible with S2 and all upgraded successful. Alexa detected my SonosOne and picked up all my devices. So far so good. 

My SonosOne was not showing the mic active. I figured out this was due to the voice service not being set right. I went through pass after pass of trying to get it working only to be stopped by the dreaded error that sonos could not make the amazon account "There is a problem adding Alexa."

I have tried multiple speakers alexa enabled sonos speakers; same issue. I have also ripped out the sonos skill and put it back to no avail. It all worked under S1 software. And all the Alexa-Sonos groups and play services work. So this is limited to just voice services.

What is interesting is I CAN successfully add the Google Assistant service without issue. So I  thinking this is a compatibility issue with S2 and Alexa.

Anyone else seeing this issue? Amy suggestions are welcome and I am glad to provide further info

Thanks in advance for your help

 

 

 

icon

Best answer by d2iguy 24 June 2020, 13:25

[solved]

This morning I successfully pulled my Sonos ONE back into Alexa. It looks like the 12.0.1 release fixes the issue. But, there is a catch: the 12.0.1 update will not come install if you were an early adopter of S2 via SONOS. Here are the symptoms and the fix:

  • Within the SONOS app, you go to System - About My System and you will see you are running Version 12.0
  • If you go to System - System Updates and check for updates, the SONOS app will indicate there is an update and take you to the app store. There you will see the version is 12.0.1.
  • The app store WILL NOT give you the option to install or upgrade as it “thinks” you already have the upgraded versions (12.01)...but you don’t.
  • Uninstall the app from your device and then go back to the app store and install the app store-version. Once complete, check the System-About My System and you will see it now says Version 12.0.1.
  • Now go and add the Alexa assistant back to your devices and you should not longer get the dreaded unable to connect to Alexa error.

Give this process a shot and see if you have the same success. Go luck!

View original

68 replies

Badge

Yes, exactly the same issue. Been going crazy resetting everything, removed alexa, uninstalled etc. Nothing works.  I'm now guessing we'll have to wait for a fix. I'm gonna use Google for now but will switch back when I can.

Whew! Glad to know someone else is in the canoe with me. I am guessing it is an authentication bug between Sonos and Alexa. 

I saw in another thread that disabling the Sonos skill in the Alexa app and then reenabling fixes this.

After upgrading to s2, Alexa responded to me but did nothing.  So I disabled the Sonos skill in the Alexa app on my phone and then reenabled it, and now it works.

Unfortunately,  that has not worked for me. That was one of the first things I tried.

Badge

Same here.  Today I'm going for a full restart. Everything factory reset,  power off, removed from accounts etc. Installed as a new system.  Will report back if that works

Badge

Unfortunately no it did not. Think I'll go back to S1 

Badge

Can't go back, I think I've all I can just waiting for a fix now.

I don’t know if this makes any difference but for reference:
Living Room: paired gen2 Play:5’s with gen2 sub
Office: paired gen1 One’s
Move

Alexa works on all with S2.
I use S2 on Galaxy Note 8 and on Windows 10.

When S1 first appeared I ran Update.
I installed S2 app on my phone and ran Update, then installed S2 for Windows.
With Alexa app on my phone I disabled, then reenabled the Sonos skill.

Same problem here! I have tried  the suggested fixes and it still does not work! Sadly my kindle fire also cannot run s 2!

Here is some additional info about the issue and why I believe some of you are having success while others are not:

  • If your Alexa-enabled Sonos device was already configured and you simply upgraded to S2 and did not have to reset or re-provision those devices (it simply did the upgrade), chances are S2+Alexa voice is working
  • If you had to reset or re-provision a voice-enabled Sonos speaker (eg One or Beam), the Alexa voice assist will not go back in place no matter what you try

In my case, I did the S2 upgrade on my Galaxy S9+ phone and pushed to my Sonos devices. My Sonos One fell out of the Sonos network after the upgrade. I reset and re-provisioned it successfully. However, Alexa voice would not link to it. Alexa DOES see all the devices via the Sonos One so I know they are talking to each other; it is just the voice assist. My Beam continued to work with Alexa Voice Assist since I didn’t reset it. Then, testing my theory, I did a reset and re-provision. It successfully detected but broke Alexa Voice Assistant.

I suspect those of you who successfully disabled/enabled the Sonos skill in Alexa did not have to reset and re-provision the Sonos speaker. Hence, Alexa Voice Assistant is still working. If you follow my steps above, I believe it will break.

I just set up a pair of new Sonos Fives and built in Alexa is not working. I can only control the speakers via Alexa through a separate Amazon device (echo).

Badge

I spent a long call with very helpful tech support and tried lots of different config changes but we did not fix it.  From sonos end this should be fine.  We left it with a few things for me to check to rule out specific problems my end but they did not help so it seems to me a bug that needs fixing but Sonos need to be able to reproduce it to that.

Userlevel 4
Badge +2

Alexa also stopped working for me and now I can’t link the accounts between Sonos S2 and Alexa! Frustrating!!!

Userlevel 1
Badge

Hi,

I’ve the same problem : unable to re-link Sonos and Alexa. When I try to enable skill, always the same answer : “unable to link Sonos at this time, please try again later”. It makes me crazy :rage:

Other thread about the same problem : https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-alexa-integration-broken-since-s2-update-help-6843457?postid=16444557#post16444557

 

Please, Sonos Staff, look at this, it seems to be a real bug.

Thanks.

Userlevel 7
Badge +20

All

Please open the Sonos App>Settings>Services & Voice>Amazon Alexa and ensure that all of your Sonos Alexa devices are set as Enabled.

EDIT:

I’ve posted in that thread but it appears to be an intermittent issue, it worked on the forth attempt - so just keep trying and it may work.  I wonder if this is a time out issue?

Userlevel 1
Badge

@UKMedia : I’ve tried to enable skill many time… Always unable to add skill.

 

Same issue with me. Nothing works now. Today morning I could enable Alexa but Spotify was not responding, only music from Amazon Music. Then after installing and reinstalling all apps finally Alexa is not not even possible to activate in the Sonos app. Try again later message. 
I hope the issue is solved soon. Also the problem in Alexa enabling Spotify is not solved. Seems there are major issues that started today. Yesterday all worked fine. 
 

Is Spotify working with Alexa app for anyone? 
 

Also Sonos skill does not install.

 

 

Yep, same.thing here.
 

I have 2 Sonos ones and I can't add the Sonos skill in the Alexa app or the Alexa voice skill in the Sonos app.…

 

Don't they test these things first?! 

Userlevel 2
Badge +3

I live in Philippines , after Sonos S2 upgrade, Alexa/ Sonos doesn’t work anymore, is there a way to make it work again?

Add Voice Service is no longer available on my Sonos S2 App > System & Voice, cannot add any Voice Service at all

Badge

Very similar situation here. Short story is I can’t enable the sonos skill in the alexa app, or add alexa as a voice service from the sonos app.

 

 

I have 4 x Play:1 and 1 x One (1st gen). S2 upgrade was fine to begin with.

 

In one of the bedrooms we have an echo dot clock linked to the Play:1 in that room. Yesterday I noticed that Alexa was responding to commands to play music, but nothing was palying from the Play:1 as it usually would do. I checked the sonos app and it hadn’t recieved the request to play from Spotify, but if I tried to play the music from spotify or sonos app it worked fine.

 

I looked around online and saw that it could be due to linking authentication issues, so I did as instructed and unlinked the sonos and alexa etc.

 

Now I am in the same boat as most of you and seems like it is an S2 issue?

 

Userlevel 1
Badge

Hi,

It seems to be a general issu (see: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/unable-to-link-akexa-with-sonos-1-6843573)

I’m in the same cas as most people : if you unlink Alexa and Sonos, no way to relink.

Very frustrating.

I’ve open a cas on twitter support and support ask me some try : ungroup all speaker, wire speaker directly on router without result. 

I suspect software issu and I’m really sure there is a big problem between Sonos and Alexa Sonos skill.

Same here as well.
Also tried enabling Alex directly over the Alexa Web interface ( https://alexa.amazon.replacewithyourcountry ) when it didn’t work on the phone (Android 10;Pixel 3a).

No success there as well.

Background:

Updated to S2 at the 10th, no issues whatsoever, around 10 days later Alexa only plays 1 song and stops. Tried removing and enabling Alex again and eventually tried removing an adding the skill.
And since then I cannot enable it again. Like in the screenshot above “There was a problem adding Alexa”.

And, of course, I cannot link Speakers with Alexa, very likely due to it too.

 

Google Assistant works fine depending how you define “works”. Compared to Alexa the music playback capabilities of GA are ..well.. utterly horrible.

“Alexa, play some rock music" → “Ok, Rock playlist is playing from Amazon music”. *Music plays*

“Ok Google, play some rock music" → “Ok, Rock Music is playing from YT Music. .. I cannot find the requested content” *GA enabled speaker is flying through the window*
 

Badge

Good news. Just got my system linked and working as it was before.

 

Ironically, I was on hold with Sonos support at the time and I tried it via the browser and it linked!

 

 

Userlevel 1
Badge

Good news for you. Do you think you do specific thing that explain it works now ??

Badge

 

Good news for you. Do you think you do specific thing that explain it works now ??

 

I did everything exactly as I had done before, just this time it worked when I must have tried 50+ times before and got the above messages.

 

The support person on the phone did say they’d had a lot of calls about this.

 

I enabled and linked the skill via alexa.amazon.co.uk first, then I added the alexa voice service in the S2 app. After that, I tested that the One worked before setting a Play:1 as preferred speaker for my other Alexa enabled devices.

Reply