Alexa Sonos Roam

Show first post

60 replies

Badge +1

My workaround was removing all smart assistants from the Roam and just use my iphone and desktop PC. 

Can you play Spotify through the Sonos app? And I assume you’re using the same Spotify account in both Alexa and  Sonos.

Do you have any Amazon echo’s in your house?  If so do they work with Spotify?  Another option to test is to try that spotify voice command in the Alexa app and see how it responds.  I’m not allow that as I think the Alexa and Amazon music apps will only play Amazon music.  

I’m just trying to see if this is an Alexa problem or a Sonos problem.  I do think it’s Alexa though, based on the response you’re getting back.  Alexa is running validation and rejecting the command before it’s sent to Sonos.


Userlevel 1

I have 2 echo dots that are still working with spotify/ playing the news. The alexa app says I have to use a connected device to use spotify though, like you mentioned. 


Thanks for your insight- it’s strange that it’s just the roam that won’t play the news (my other sonos devices still will). The spotify issue is for all of the sonos.

Just posting to stay up to date on this.  Same issue with “News/Flash Briefing” on Roam not ever playing content, just the initial ‘announcement’ that “Here is your flash briefing”.  All other services via Alexa and Spotify seem to be working just fine.

Userlevel 1

Nope- still not fixed! 

Did you get this working. I have a similar issue where Roam won’t read me the news or play my Audible book using Alexa. It says it’s going to, but nothing happens. Both these things worked fine on my Sonos Move (and my Amazon Echos). It just seems to be Roam that’s not happy. It does play music from my Amazon account though using Alexa - so it half works! 

I’m having similar problems with my Roam.

if I ask the time I get the time.

if I ask for news/music it acknowledges the request but then nothing.

My echo dot and flex, when I ask, will respond with time/news/music correctly.

Same here. Spotify works, however for news, it acknowledges the request and nothing happens.

Followed the various “solutions”, i.e. de-register and re-enable but no cigar.

Same issue here, same error message. None of the suggestions in this thread have worked. I hope @sonos will respond and fix this quickly. 

Solved my problems eventually by disabling Sonos skill on alexa and then re-enabling.

Maybe that will work for you (but I wouldn’t bet on it - hold the cigar).

I’ve got lots of older sonos kit and I’m now struggling to set up the sonos 1 app to use it.

nothing is ever easy with Sonos!

  1. Remove the S2 App & install S1 App on your mobile device (mobile must meet the Sonos Requirements).
  2. Create a new Sonos Household using an S1-only compatible Sonos device.
  3. Add the remaining required devices to the S1 HH. 
  4. Reinstall S2 App and choose to connect to the ‘existing’ system when prompted and select the join button on a device in your ‘existing’ S2 HH