Answered

Alexa says "sorry, that device is offline"


Userlevel 1
not sure which device or settings i need to address to get "that device" online. Everything is connected through my wifi.
icon

Best answer by iwb100 18 July 2018, 15:44

Disable the sonos skill in the alexa app then re-enable it. I had the issue when setting up the beam and that fixed it.

Moderator Note: If the information listed here did not resolve your issue, try this topic: Resolving the Majority of Issues with Alexa on Sonos
View original

22 replies

Userlevel 1
I experienced the same problem... "sorry, that device is offline" with my Sonos One. I solved the issue by going to alexa.amazon.com, logging in and selecting Skills. I enabled the Sonos skill, then clicked discover devices. I was back in business after that. For some reason I had to do this process online rather than via the Alexa app. Technology... love it... hate it... C'est la vie!
Userlevel 3
Badge +2
Disable the sonos skill in the alexa app then re-enable it. I had the issue when setting up the beam and that fixed it.

Moderator Note: If the information listed here did not resolve your issue, try this topic: Resolving the Majority of Issues with Alexa on Sonos
Userlevel 3
Badge +11

In that case, try these steps below:

  • Disable the Sonos Skill within the Alexa app. Do not re-enable the skill just yet.
  • Next, open the Sonos app to remove Alexa voice services as well.
  • Log out of all Amazon Apps on the mobile device, i.e. Amazon Shopping App, Alexa App, Amazon.com and Amazon Music.
  • Go through the Alexa Setup in Sonos again.
  • Follow the prompts to set up voice services which will require you log in your Amazon account, to link them together.
  • If that's all worked you should hear the Sonos One say "Hello". Try asking it to play something like a radio station (Radio by TuneIn is enabled by default) and see if that works.
  • If this does not work, or you are getting stuck at any stage, please post a diagnostic confirmation number and describe how/where it went wrong. 

 

 

Keep me posted whether or not this helps.

Badge

THANK YOU!!! I tried other suggestions, but only this worked. Have had this issue for a while. Closing and exiting everything as you noted, was the only thing that worked. Now my MOVE is working like a charm. Thank you very very much!!!

Same problem, but I didn’t want it to use the Sonos speaker. It would try to play from so is, say it couldn’t connect & not play anything at all out of the Alexa speaker I asked to ply music. My fix was to remove any Sonos speakers as the ‘preferred’ speaker in all device groups in the Alexa app

Userlevel 7
Badge +20
Hi

If you open the Alexa App>Settings it will show the status of all Alexa devices. Sometimes opening the Alexa app in a browser (www.alexa.com or www.alexa.co.uk) will sort this problem and the device will switch to on-line.
I had the same problem. It turns out I hadn’t logged back in again on the Sonos app after updating it. So go to settings and check you are logged in under account settings. Good luck
Userlevel 3
Badge +11

@archiekilp, do you have Alexa and/or Sonos setup at multiple locations or addresses? Alexa can have trouble with multiple locations on the same account.

I experienced the same problem... "sorry, that device is offline" with my Sonos One. I solved the issue by going to alexa.amazon.com, logging in and selecting Skills. I enabled the Sonos skill, then clicked discover devices. I was back in business after that. For some reason I had to do this process online rather than via the Alexa app. Technology... love it... hate it... C'est la vie!

It helped to solve the problem, thank you!

I tried everything you said, joined Alexa with my sonos and it said hello and speaks to me but when I ask it to play my music it says “playing songs in your library, sorry this device is offline”. what do I do?

Userlevel 7
Badge +20

You follow the advice here

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sorry-that-device-is-offline-6821288

 NOTE actions must be taken on PC or Mac browser

Tried it and didn’t work, and I’ve tried so many other things aswell

 

Userlevel 3
Badge +11

@Treble I am sorry to hear about your issue. Can you tell me if you have Alexa and/or Sonos setup at multiple addresses under the same account?

Userlevel 1

None of these suggestions worked. She still says “sorry on Sonos is offline” and I have my Sonos speakers set as default. 

Userlevel 3
Badge +11

@steviez 

 

Do you currently have Alexa setup in multiple locations under the same Amazon account?

Userlevel 1

@steviez

 

Do you currently have Alexa setup in multiple locations under the same Amazon account?

Yes.  I have multiple Alex devices throughout, in each room, as well as multiple Sonos speakers. 

Userlevel 3
Badge +11

Sorry for the confusion. When I mentioned multiple locations, I’ve meant if you also use Alexa from another site?

Userlevel 1

Sorry for the confusion. When I mentioned multiple locations, I’ve meant if you also use Alexa in a different street address?

 

No.  Just one apartment.

Userlevel 3
Badge +11

No problem at all! :smiley:

Check to make sure the speaker button on the top of the Sonos speaker is on. Mine was off and as soon as I turned it on the problem was solved! ?
Userlevel 2
Badge

Within the Alexa app select the zone/room in question.  Within the next menu there is a preferred speaker that must be identified.  Often times the app will recognize the room,  but you still need to assign a speaker.  Once the speaker is selected and saved within the Alexa app for that particular room, it will play just fine.

enjoy!

I get exactly the same here tried all steps but doesn’t work and to be honest the Alexa integration on all my Sonos products is dire including the beam very unimpressed with the Alexa side of things 

Reply