Answered

Volume control Sonos Playbar through Samsung One Remote

  • 14 February 2018
  • 30 replies
  • 123886 views


Show first post

30 replies

I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!

—————————————————————
Following instructions worked for me

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and *hit "No" (unsuccessful) for 1st time & hit “Yes” for 2nd time to covert Samsung to Infrared*, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

Ok I have a 2019 Q8 Samsung.  I only use the streaming interface on the tv.  There isn’t a one connect box.  How do I set up the remote to work?  
 

After you go through the initial remote set up you can’t try it a fourth time.  After the third time of telling it that it didn’t work it asks for the model number of your home theater system.  I put in Playbar and then go through the same three set up attempts again. 
 

It ridiculous to spend this much money on a sound system to have to do all of these work around a to get it to work.   

I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers
Worked for me thanks.
Can anybody tell me how change the label on screen from Samsung to Sonos?

Reply