Sonos AMP (not connect:amp) repair

  • 6 February 2021
  • 0 replies
  • 1709 views

Userlevel 4
Badge +6
  • Prominent Collaborator I
  • 121 replies

I have two Sonos AMPs that have no power.  I have had a lot of success fixing Connect and Connect:AMP (old and new) devices (there are other threads here on this site), so thought I’d have a look at this AMP problem.

After getting it open (see here), I was able to extract the first of two PC boards.  The first board is entirely made up of the power supply.  The outputs are provided to the rest of the unit via two metallic standoffs.  There is also a small connection to the RCA connectors -- I haven’t looked into that yet, other than to see that there seems to be an optical trigger feeding back to the power supply (I have no idea what it is for).

The power board has a much newer fabrication technique, and looks like it will be quite a lot harder to diagnose and repair.  I couldn’t find the problem with it.  

BUT… I moved on.  The power board outputs are marked GND and 48V, so I fed 48V into the second board via this, from an external power supply.  It worked great, and the device booted up.  Everything worked well, as I got the device set up on my account.  Then… As soon as I played music, the device would play great, but then detect a fault.  This behaviour was just like the connect:amp devices when they had a bad secondary power.  The amp would ratchet the volume back to about 15%, and continue playing, but only at the lower volume.  It also started flashing an amber light (also like the Connect:AMPs).

I removed the second board.  The AMP chip used here seems to be proprietary, and I couldn’t find a schematic for it… so it’s going to be a lot harder to fix these.  I did find a power chip that would accept up to 80V and generate a fixed voltage.  This seems to be working fine, and is supplying power to the AMP at low volumes.  There must be a problem elsewhere though, when the 48V (or some other generated voltage) is switched on to the amp.

That’s a long winded explanation -- what I am hoping is that there is someone else here who can help work through both of these issues -- the power board problem seems to be getting fairly common.  The other problem (amber fault) happens to both of my devices, but I have no idea if that is common to other ‘no power’ failures or or not.

I should point out… Nobody should be opening their devices up, unless they are well aware of the risks and highly competent.  There are no user-servicable parts, and there are dangerous voltages inside to stay away from.

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.