Router identifies wireless devices as wired

  • 19 May 2024
  • 6 replies

Badge +4

I hello all. I recently moved my Sonos devices to reserved IP addresses in my router. That seemed to go well in terms of everything working, but I noticed that the router identifies some of these devices as “wired” when in fact they are wireless. Below is a capture of the devices page. The Playbase is wired directly to the router and is correctly identified as “wired.” However, the Port and the two Play 5s are incorrectly identified as wired. The two Era 100s are correctly identified as wireless, as is the Roam. Is this something that matters? I refreshed the devices page a couple of times but that didn’t change anything.





6 replies

Userlevel 7
Badge +22

Your router is likely confused.

Power down all Sonos, reboot the router, power up your Sonos.

If the router is still confused check their forums to see if they have any help in properly detecting Sonos devices.

Badge +4

I posted a question on the Netgear forum. I’ll let you know what they say


Badge +4

I got a very quick response on the Netflix forum, as follows:

On your list of connected devices I spot some Sonos devices not supporting the dedicated Sonos Wireless network, e.g. the Era 100 and Era 300 (also the Move, Move 2, Roam and Roam SL) which must be connected either to the router Wi-Fi network or to the router Ethernet LAN port(s). Once one of these has an Ethernet connection to your router, it will be identified (along with the Sonos Wireless connected Sonos devices) as Wired.

I am surprised to learn that the ERA 100 and Roam do not support the Sonos Wireless network (aka “Sonosnet”, right?). The poster states that once one of these has an ethernet connection it will be identified as wired. I am not sure what is meant by “ethernet connection” here--does it mean that as long as one of the Era 100s is connected to the router’s wifi network then the other Era 100 and the Roam will show up as wired? If it means that one of the Ea 100s must be cabled to the LAN port then I’m in trouble because the router is nowhere near the router.

Userlevel 7
Badge +22

Ethernet connection for an Era speaker is an Ethernet cable from your router to the Sonos Era Ethernet adapter and then the Era.

The lack of SonosNet on the Era line was a surprise to many. I just took a quick look and didn’t see that mentioned on the sales page or in the product guide.

The Era line is designed to use your WiFi as the connection method and should work fine used that way. The Ethernet option is intended to be used when WiFi is not possible for some reason.

Badge +4

I see.

  1. Before I got the Era 100s and the Roam, I had cabled the Playbase directly to a LAN port on the router, thereby creating a Sonosnet to which the other devices then connected (I guess these other devices are considered by the router to be “wired” since they are communicating with the router through a truly wired device (the Playbase), correct?
  2. Then I got the two Era 100s and the Roam and assumed they would also join the Sonosnet. But since they are not compatible with Sonosnet they established their own wireless connection to the router.
  3. Which brings up the question, would it be better to abandon the Sonosnet by unplugging the Playbase from the router and allow all the devices to interface through wifi, or is it fine to leave it the way it is, with some devices using Sonosnet and others using their own wifi connections? 


  1. Yes, this is how the system is supposed to work.
  2. Again, correct. The Roam and Era 100s still work with the rest of the speakers, as they’re still on the network, and part of your Sonos system.
  3. Shouldn’t make any significant difference, either way, it is completely up to you. I still run in mixed mode, with a BOOST connected to my router, and a Roam connected to my WiFi signal, no issues. 

Important to note, if the Era 100s are set up as surround speakers, they’re actually connected to a hidden 5Ghz channel created by a Sonos soundbar, and not directly to your WiFi. That means they get a proxied IP address from your router, through their connection to the soundbar.