Repair ZP120

Show first post

358 replies

Userlevel 1
Badge +3

Hey man,

No, that doesn’t tell you anything. 

I would check for the bias voltages. 
They must be there, that is how the led is coming on. 
maybe they only come up for a short time. 

Look for missing voltages. Be careful. High voltages at the input. 


I just bought 2 broken Sonos amps, one is completely dead and is waiting for me to disassemble it but before I do that I need some help with the 2nd one.


When plugging in the power cord I can see a white light from the led then it goes off.


the previous owner explained what happened before it died:

“It was late one Friday evening and suddenly I only heard sound from one of the channels (mono) and I tried to remove the speaker cables by turning the knobs, and that didn’t work so I tried even harder and then the amp died. Should I mention that I was a bit drunk? I realize now that you should pull the connectors. “

any clues? I have disassembled it and didn’t see and fried components.

Userlevel 1
Badge +3

2 things about the heat sink clip.

  1. the Mosftet heat sink clip can EASILY bend the thin leads of the Mosfet, so be very careful. You wont know you bent the leads until the fuse blows. (the rectifier leads are much heavier and more resistant to bending) You may want to ohm out the 6 Mosfet pins after the heat sink is installed to make sure. 
  2. Believe it or not i have used a butter knife handle to spread them open and very carefully drop them down into place. Also used a half round file. If you use something abstract let us know so we can add it to the lest. LOL


Userlevel 2
Badge +1

I thought about that and is definitely a possibility, but I don’t want to think about it because then I fully unraveled an inductor when I didn’t need too! :smile:

But, I did do a pretty good job of rewinding it .

It’s all setup and working!

I do have one heat sink clip I cant get back on, frustrating because I never needed to take it off, but there must be some special tool to spread this clip and get it over 2 transistor casings, I’ve read that it is a bear to get back on...and so far it is. 

Userlevel 1
Badge +3

The way that coupled inductor is placed in the board layout always makes me scratch my head when troubleshooting that circuit. Is it possible when you put it back in and blew the fuse, that you had it soldered back in wrong? That would be easy to do.

Good to hear that you seem to have it on the mend!

Userlevel 2
Badge +1

ok-that what interesting, after I thought I had removed the short from the inductor I soldered it back in mounted on the bottom for evaluation, I had a pigtail 5 amp fuse and brought it up slowly with my variac and the 5 amp fuse blew. I thought I was getting a very high resistance reading between the 2 windings where there should be none, I ended up fully unwrapping the inductor and rewrapping it, put a current meter in place of a the fuse in and slowly brought the variac voltage up,watching the current draw, stayed low and got the white light on front and made it up to full voltage with no to put the inductor back in correctly and try to connect...looking real good!

Userlevel 2
Badge +1

See red, on the dc output of the bridge.

Definitely looks like a nick in the wire.

I’ll report my status after I repair the inductor.


Userlevel 1
Badge +3

I have had this exact thing happen but on the 36V output filter. Where is this again on the board?

I definitely would  fix that. 
just extend the wire with a small piece of wire and insulate the connection with shrink tubing. 

This fail means you prob either had a nick on that wire (winding) or you have a nick on the wire and a short down stream that made the nick show itself. 
Either way fix the inductor and make sure nothing is shorted. 

Dim bulb would help here. 

Userlevel 2
Badge +1

Add me to the list of non-working ZP-120, I’ve read through this thread many times trying to gather as much information as possible.At this point the unit, which I purchased at a swap meet, and had never been opened, will not power on. I did find a open 5A fuse but replacing it didn’t make any difference. There are no obvious damage and I have checked the usually diodes and transistors for shorts. Everything I am seeing for in circuit test looks good.

I think I may eventually map out the schematic and post here but for now I have traced the 110ac input all the way to the first bridge rectifier, from ground  the positive side of the rectifier is 60vdc and -60 to the negative side. Which seem reasonable..this is where I’m not to sure to go after this.

New Information:

I knew I was in the right place, L16004 is bad, the question is, can I source this part or is it custom? Maybe I can unwrap it a bit and re-insulate...

If no source does anyone have one from a parts unit? Thanks!




Userlevel 1
Badge +3

Hi satchi24,

So your Connect:AMP will work at 190V but not at 220V?

Ant other symptoms? 


i have Sonos CONNECT:AMP ac190v  can on and working ac 230v cannot on not working can you help me

Found the dram chip one of the pins looks a little weird, otherwise no visible damage I ordered 2 should be here in a couple of days!

Never done this. Looking forward to your results!


Well, I was able to change the DRAM out without much issue. I used kapton, some foil, and the hakko hot air rework. Then I cleaned the pads and put new parts down. Unfortunately, it did not fix it. That pretty much confirms that the issue is probably a cracked solder ball under the BGA, or head-in-pillow or some other similar type defect. I thought about putting it in the xray but it is so hard to see some of these defects and regardless of what I found, it was not repairable.


Any chance you remember what dram you ordered? What amp do you have the CP 100 or the ZP 120? 

I read a lot of things but my English is limited, so I will explain my problem.
I have a ZP100 that works from 3 to 40 minutes when it is turned on, then there is more music and it disappears from the application ....

The problem is already may have happened to one of you, and if so how to solve it?

Thank you very much.

I just disassembled and add thermal dough to the amplification circuits and it seems to work properly now ...


These photos show it a little bit better, there is like extra flux built up on that Solder point.


I don’t see anything that looks particularly bad in those photos unless I am missing something.

I recall the symptoms you are experiencing being related to the dram check but I could be wrong.




There were some smart people posting in this thread. Hoping they are still around. 

I’ve read the entire thread but it’s been a bit unfortunately.

I know it’s been some time, but I have a zp100 and it is blinking a constant white light, never going solid. I have the unit completely torn down and I’ve found 2 possible charred components.

There were some smart people posting in this thread. Hoping they are still around. 

Is this thread completely dead?

My Sonos ZP 100 amp just started acting up so I opened it up to find what appears to be a blown (missing) capacitor.

Trying to locate a replacement cap, but there are no markings on it.

It appears to be of type SMD MLC but that is all I can figure out.

Any guesses to a suitable replacement?

It measures approx. 3mm x 1mm  ..

Perhaps a 1206 ? 


I read a lot of things but my English is limited, so I will explain my problem.
I have a ZP100 that works from 3 to 40 minutes when it is turned on, then there is more music and it disappears from the application ....

The problem is already may have happened to one of you, and if so how to solve it?

Thank you very much.
Userlevel 1
Badge +3
Hey Dan (danrowland),
Can you tell me more about that diode. I dont know them by refdes, more by function.
The CPU_GND and 36V GND are supposed to be tied together, in fact they often blow open and then the biases are not referenced to each other and nothing works.

So if you replaced the PWM and the 10 ohm, then are you getting high voltage on the PWM drain pin?
You should be getting 300ish V across the 2 big storage caps on the primary side. (if I remember correct). If you are not then you still have problems in the rectifier and storage section just before the bias PWM.

There is also an opto in the bias converter feedback that can blow, also the bias converters bias winding storage cap that can cause it to not work.

Hope this helps.
I have a Connect that forgets its configuration. It worked on ethernet but when it was moved to a location that required wifi, it just wouldn't stay connected. After that, it wouldn't stay configured on ethernet either. Sonos made a ridiculous repair offer. For another $60 I could buy a new one. Anyway, does this sound like a logic board problem? I'm thinking on buying a parts unit to see if I can get it working. Any thoughts?
I've got an Connect:Amp that I bought for parts and trying to repair. 10 Ohm resistor totally burned up and charged the board. Replaced that, the fuse, the PWM and a cap that was puffing at the top. I've got voltage on the PWM but nothing on the secondary side at all. I've pulled D16016 and it gives me continuity in both directions so first this is to replace that. Does anyone know the specs on this diode? 15V, 3A? What about the package type? Just need to order some from digikey.

Also, my CPU_GND and 36V GND test points are not buzzing out as shorted. Does this indicate there are other components blown on that side of the transformer? I get no voltages on that side of the transformer BUT I am using a crappy craftsman DMM that probably doesn't work for reading the fast switching voltages on this board.

Any help would be appreciated!