Problems connecting garden room

  • 31 December 2021
  • 12 replies
  • 127 views

Hi there!

So I have a Sonos system in my house. Included in the system is a bridge which is hardwired to my main router (though from what I read, this is largely redundant, but it’s connected anyhow).

I have an outbuilding which is at the end of the garden, and which has the house wifi extended to it via a repeater which is hardwired to another repeater in the house (note it’s not hardwired to the main router as this isn’t possible). The house repeater that the outbuilding repeater is hardwired to is connected to the main house router via Wi-Fi (mesh system - they are all Fritz!boxes).

With my current set up, I don’t appear to be able to add a Sonos speaker in the outbuilding as the system can’t find it (it works if I bring it up to the house and connect it there). I think this is probably because, whilst the wifi is extended to the building, Sonos’s own wifi isn’t.

What do I need to do to make this work? I have tried connecting the outbuilding Sonos speaker to the repeater in the outbuilding via Ethernet but this didn’t work. Do I need another Sonos bridge? Is it even possible? Let me know thank you! :-)

 

 


12 replies

Could you please detail the model(s) of Fritzbox which are in use? Could any of them be splitting off a separate subnet? All Sonos units and controllers should be on the same subnet.

I also seem to recall that Fritzboxes may need to be explicitly configured to forward multicast traffic correctly. You might wish to check that out. 

Thanks Ratty.

the main router is a 7530, and the home repeater is a 3000, ethernetted to another 7530 in the outbuilding which is set up as a repeater.

im not sure I understood the rest of your message - but hopefully the above helps?

 

So the second 7530 is configured in bridge (access point) mode? It would need to be. 

As for the other part, check whether any/all of the Fritzbox units are filtering out multicast/broadcast traffic. These traffic types are required for Sonos. If there’s an IGMP Snooping option try toggling it. 

Hi Ratty 

the second 7530 is set up as a mesh repeater - is this the same thing as a bridge?

 

Hi Ratty 

the second 7530 is set up as a mesh repeater - is this the same thing as a bridge?

 

One would hope so, but it would be worth checking.

When in the main house note your phone’s IP address (A.B.C.D). In the outbuilding do the same (E.F.G.H). If A.B.C is the same as E.F.G then the segments are bridged together.

Thanks Ratty.

I’ve checked in the Fritz system overview and everything that’s connected in all locations all have consistent IP addresses for the first 3 numbers as you noted.

what would be the next thing to check? Sorry if I’m being a bit thick - this very much beyond my tech knowledge!

what would be the next thing to check? 

Multicast filtering. You don’t want it. Sonos uses multicast (and broadcast) to discover the players. 

Ah ok.

I can’t figure out how to check or change that but have reached out to Fritz/AVM and hopefully they will be able to help…!

Hi ratty

ive been doing some googling and this page seems to suggest that all Fritz boxes support multicasting https://en.avm.de/service/knowledge-base/dok/FRITZ-Box-7530/592_Reception-interference-when-watching-TV-over-IPTV-connection/

if this is the case is there anything else I can do to try and fix the problem?

eg would it work if I hardwired one Sonos product to the repeater in the house and another Sonos product to the repeater in the outbuilding (which is itself hardwired to the repeater in the main house)?

 

Sorry - the other thing I would add is that when I am in the outbuilding on my phone which is connected via the extended Wifi, I can use the Sonos apps and see my Sonos devices that are in the main house, I just can’t add another one that’s located in the outbuilding…

A wireless Sonos device in the outbuilding would try to connect back to the units in the house over SonosNet. Presumably this would fail owing to the distance.

Wiring the Sonos to the outbuilding repeater didn’t work? Meshes often use a flavour of spanning tree protocol to prevent loops. This could be fighting with SonosNet’s own STP, such that a wired device ignores the Ethernet. 

I think it would be worth experimenting with ‘mixed mode’. Take the outbuilding Sonos unit back into the house and make sure it connects okay. Then enter your WiFi details via Settings/System/Network. Put the speaker back in the outbuilding and see if it connects to the WiFi there. 

Thank you!

Oddly I tried it again earlier today and it just worked! Possibly something to do with setting up in the house first, but I did that yesterday and tried it and it didn’t work.

but switched in the sonos today and it connected fine.

very strange though!

Reply