Question

Ethernet network crawling

  • 15 May 2024
  • 7 replies
  • 85 views

Badge +1

I just installed 10 amps and connected them all to a tplink switch that then goes to my Unifi switch and then the router. 

Since the install the network is crawling. I read something about a broadcast storm caused by Sonos.  So, i configured STP on the switch as someone recommended that but it still seems slow (although it is better).

Is there anything else I can do? Or can I just disconnect and use wifi only?

 

Thanks. 


7 replies

Userlevel 7
Badge +22

There are some ubiquity topics here with settings suggestions.

Links form my browser history

sonos ubiquity settings

How to configure your UniFi network for Sonos

 

 

Userlevel 6
Badge +11

Yes, unplug all ethernet, if your wireless is stable and reliable,

“wireless mode” is now described as ‘station mode’ in about my system, previously “WM:1”

https://support.sonos.com/en-gb/article/check-if-sonos-is-in-a-wireless-or-wired-setup

Userlevel 6
Badge +11

I had Sonos plugged directly into UniFi switches for many years, I recall I just disabled STP on the ports that devices were was connected to. If your TP-Link is a dumb unmanaged switch with all wired Sonos devices connected to (ie you dont have any Sonos plugged directly into UniFi), you could try just disabling STP on the uplink port on the UniFi that the TP-Link is connected to.

However in this new ‘Era’ of Sonos devices, where there is no SonosNet or ethernet ports, I reconfigured to a fully wireless (Station mode) configuration, as this appears to be the trend if you have an existing stable and reliable WiFi network.

Userlevel 6
Badge +11

Mmm, not sure.

That looks like Android, that I have not used with Sonos. On iOS App I have always seen Wireless Mode (WM) on line after IP address as per:

https://support.sonos.com/en-gb/article/check-if-sonos-is-in-a-wireless-or-wired-setup

Maybe new Android App does not show WM, it does on iOS.

Badge +1

Thank you @Stanley_4 and @craigski.  I will review the links.

@craigski You’re right the TP-Link is unmanaged.  I’ll double check to make sure STP is disabled on uplink.  

What do you mean about “Station mode”.  Do you mean you unplugged all the Sonos amps from Ethernet?  

Badge +1

Thank you all!  I’m in wireless mode now.  It’s a little slow to recognize my system when I open the app but seems ok.  

Badge +1

@craigski 

Not sure why but I don’t have WM anything listed.  

 

Reply