Answered

Sonos Roam in group and showing as playing but no sound


Got the new roam and connecting to to a group of 2 other speakers.

It sits in the same position in my house.

I can see all three in the group, however the roam doesn’t have any sound.

The only way I can get it working is to ungroup and regroup them. I spoke to Sonos who suggested I ungroup everything, then start witht the roam adding the other speakers.

It works for a while, then when I go back to it a few hours later the group is the same but the roam is not playing.

I’ve had no other issues with my sonos speakers other than this - its becoming really annoying - i am seriously thinking about returning this for a refund.

icon

Best answer by Corry P 3 May 2021, 11:28

Hi @nantwichguy 

Welcome to the Sonos Community!

It seems your Sonos system is having a bit of trouble remaining connected to your Google Mesh - it’s trying to steer them to a 5GHz connection because they have 5GHz radios, but some won’t do so as they reserve their 5GHz radios for direct links (like your surrounds to your Arc).

As the Google Mesh will not allow you to split the 2.4 and 5GHz bands, we’ll need to take another path towards connection.

Please connect any one Sonos device (not a Surround, Sub or Roam) to your Google Mesh (or to a network switch attached to Google) with an ethernet cable and wait for about 1 minute. Keep the device 1m away from your Google node and router.

This device will transmit a private WiFi just for other Sonos devices which each device will repeat, creating their own mesh. The Roam will not connect to this network (SonosNet), but it will happily connect to 5GHz WiFi.

When creating a large group, it’s best to put the ethernet-connected device in charge of the group (selected first).

With the minute over, please check Settings » System » About my System and check that all speakers apart from the Roam report WM:0. Reboot any that don’t.

If you’ve had to move a speaker to do this, I recommend you test long-term (a week or so) and if you’re then happy with the performance but need to move your speaker back again, you may want to add a Boost to your system.

I hope this helps.

 

 

 

View original

4 replies

Userlevel 6
Badge +16

Hi @nantwichguy 

Welcome to the Sonos Community!

It seems your Sonos system is having a bit of trouble remaining connected to your Google Mesh - it’s trying to steer them to a 5GHz connection because they have 5GHz radios, but some won’t do so as they reserve their 5GHz radios for direct links (like your surrounds to your Arc).

As the Google Mesh will not allow you to split the 2.4 and 5GHz bands, we’ll need to take another path towards connection.

Please connect any one Sonos device (not a Surround, Sub or Roam) to your Google Mesh (or to a network switch attached to Google) with an ethernet cable and wait for about 1 minute. Keep the device 1m away from your Google node and router.

This device will transmit a private WiFi just for other Sonos devices which each device will repeat, creating their own mesh. The Roam will not connect to this network (SonosNet), but it will happily connect to 5GHz WiFi.

When creating a large group, it’s best to put the ethernet-connected device in charge of the group (selected first).

With the minute over, please check Settings » System » About my System and check that all speakers apart from the Roam report WM:0. Reboot any that don’t.

If you’ve had to move a speaker to do this, I recommend you test long-term (a week or so) and if you’re then happy with the performance but need to move your speaker back again, you may want to add a Boost to your system.

I hope this helps.

 

 

 

Hi Corry

Thank you for your detailed repsonse. I’ve now returned the google mesh wifi and have currently replaced this with a split channel router (which allows a different network name per channel) - all my speakers are now connected solely to the 2.4ghz channel.

I’m happy to say everything is now working perfectly. Grouped speakers with the roam in remain grouped and play - even the following day.

I’m going to get another mesh network - however this time I’ll ensure that the channels can be split and named specifically.

nantwichguy

Userlevel 6
Badge +16

Hi @nantwichguy 

I’m glad you’ve found a fix!

I’m not sure that any of the popular mesh systems allow splitting the bands. Hopefully someone in the Community that owns one that does can prove me wrong?

The new netgear ones offer this plus another 5ghz channel forwireless backhaul  - not too expensive so will probably go for this

 

https://kb.netgear.com/000063028/What-are-the-features-of-the-Nighthawk-Tri-band-Mesh-WiFi-6-products

 

Thanks again for your help

 

Reply