Question

sonos connect gen 2

  • 25 August 2020
  • 3 replies
  • 175 views

Hi, I have Sonos connect gen 2, less than 2 years old. It disappears from the app, white light in the front is flickering, Ethernet lights are on (all of them). I've tried everything to solve this problem with out luck.

What I found on other community is the power supply is faulty.

Any suggestions, experience ?

 


3 replies

Userlevel 5
Badge +16

Hi @ingthor.

Welcome to the Sonos community and thanks for reaching out to us and starting with some basic troubleshooting steps.

I would like to ask specifically what troubleshooting steps have been done so we can better understand the situation.

  • How did the Sonos connect behaved when unplugged from power and plugged back after 10-15 seconds? Did the Sonos connect automatically flickered without transitioning any lights?
  • Can we try unplugging the Sonos Connect from power and plugging it back on a different power outlet? how did the Sonos Connect behave?
  • Can we try to reset the Sonos connect and add it back on the Sonos app iff possible?

If after the above recommendation, there are no changes on the Sonos Connect, I would suggest calling our technical support team for a more in-depth troubleshooting step or possible product replacement.

I hope this helps.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Hi Paul A.

What I have done…

When I unplug power and plug in again it work for few minutes 1-30 min. When it is unplugged for longer time it works for up to one hour.

I have:

Reset Sonos (play + pause)

Wifi on and off, Google wifi mesh

Move wifi from Sonos

Sonos with and without wifi

Different power outlet

-

No matter what I do, it always the same.

This product is a replacement, less than 2 years old.

https://photos.app.goo.gl/oDMcrwSzgi7iNxQc8

Regards Ingthor

Userlevel 5
Badge +16

Hi @ingthor.

Thanks for the immediate response and feedback.

I understand your situation that is why I would highly recommend calling our technical support team for a more in-depth troubleshooting step or possible product replacement. This is no longer a normal Sonos behavior and we would highly appreciate and be more than happy to process a replacement for you once we confirm the issue.

I hope this helps.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Reply