Answered

Sonos Beam won’t stay muted for TV


I have a Sonos Beam connected to a Vizio TV via HDMI ARC. The TV speakers are disabled so Sonos is primary speaker. I followed the setup instructions and everything works fine:

  • Volume up/down works
  • Alexa works
  • Beam manual controls work

The problem I have is that when I press the Vizio remote mute button, the Beam will mute for a short period of time but then will unmute on its own. The duration of time that it stays muted varies between a few seconds to a few minutes. Inevitably though, the TV/Beam will unmute. 
 

I’ve done all of the following things to try to fix the issue:

  • Unplugged power to TV and everything connected to the TV, waiting a minute before plugging back in.
  • Unpair and re-pair the Beam
  • Re-pair TV
  • Re-pair remote
  • Disable “Use IR”
  • Disable Alexa “Word Wake Chime”
  • Updated TV and Beam firmware

Nothing I’ve tried works. Any thoughts? 

icon

Best answer by Ken_Griffiths 12 May 2022, 20:28

View original

5 replies

The problem is in the TV, not the Beam, so focus there. I’d certainly try a reboot of the TV’s OS by unplugging it from the wall for 5 minutes, then plugging it back in. Not sure just a minute, as you’ve done, is long enough to discharge any capacitors that may be keeping the memory active. But then, if that didn’t work, I’d be talking to Vizio’s support. 

The Beam itself is only reacting to data being sent from the TV, and the remote should be paired with the TV, not the Beam, so the TV is the issue.

I already tried unplugging the TV and disconnecting cables. Unfortunately, that did not solve the problem. 

I also removed Alexa as a Voice Assistant thinking it might be interfering with the Mute function, but the problem persisted.

The TV is only 12 months old and has all the latest firmware updates. 

I used to have a Samsung soundbar connected to the same Vizio TV (via HDMI ARC) and it worked perfectly - didn’t have any issues with it staying muted.

Thus, I still believe this is an issue with the Sonos Beam. Any other suggestions would be appreciated. 

Userlevel 7
Badge +22

Its the TV, as Bruce says. You could disable CEC and switch to optical audio, then use IR to control the volume instead. This limits you to DD 5.1 of course.

@EricSands 
Does it make any difference if you maybe toggle off the infrared receiver on the Beam, that’s if you haven’t tried that already? I’m just thinking the Beam is getting a signal to unmute from somewhere, so maybe just rule that out by temporarily switching it off and see what happens.

edit: ah I see now that you have tried that. (I missed it on first glance through the thread, sorry)

@EricSands

If there are any A/V devices connected to the other TV HDMI ports, I think it would be worth uncabling those temporarily. Then power off the TV and Beam (not standby) for 3 mins and reseat the HDMI cable at both ends.

Now power on both and see if the issue goes away. Then add the removed A/V devices back to the TV, just one device at a time .. and check each one and see if the issue returns. If you find a device that’s causing the unmute issue, then see if switching off HDMI-CEC control on that one device only then stops the problem. 

Reply